1
0
Fork 0

dev-python/interleave: new package (DANDI stack)

tests pass

Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Horea Christian <chr@chymera.eu>
This commit is contained in:
Horea Christian 2022-03-29 02:00:28 -04:00
parent 144b85084d
commit 53d1bf27a8
No known key found for this signature in database
GPG Key ID: 161C0BE6255333D3
5 changed files with 115 additions and 0 deletions

View File

@ -0,0 +1 @@
DIST interleave-0.2.0.tar.gz 15879 SHA256 3f9b36057dc1e041affe4fe76bac5256a9f7a02f05112b6162bf91ff4e46bb5d SHA512 ed47603fb0b917e7355c9e461584b5c92ba4beef2416e602da0c8b70f36d9d5d5bc57fa3a71bb00e96e35bd580873dca10cdd19280ace7b717765a8386576a0f WHIRLPOOL c3083f2aef832f70b2a228dad6a304729cd55bd8dc759e158e6db58a0d68eb076c87e5ca44cf724044d953504368e9e9ebad930e94560d1bde4f6b71375c5384

View File

@ -0,0 +1,18 @@
--- a/tox.ini
+++ b/tox.ini
@@ -8,8 +8,6 @@
passenv = CI
deps =
pytest~=7.0
- pytest-cov~=3.0
- pytest-rerunfailures~=10.0
commands =
pytest {posargs} test
@@ -31,7 +29,6 @@
mypy src test
[pytest]
-addopts = --cov=interleave --no-cov-on-fail
filterwarnings = error
norecursedirs = test/data

View File

@ -0,0 +1,50 @@
diff -dupr a/setup.py b/setup.py
--- a/setup.py 2021-02-09 13:49:46.356455141 +0100
+++ b/setup.py 2021-02-09 13:50:49.351076275 +0100
@@ -367,13 +367,15 @@ ext_modules = [
sources=["src/CAST.c"],
py_limited_api=True),
Extension("Crypto.Cipher._raw_des",
- include_dirs=['src/', 'src/libtom/'],
+ include_dirs=['src/'],
sources=["src/DES.c"],
- py_limited_api=True),
+ py_limited_api=True,
+ extra_link_args=["-ltomcrypt"]),
Extension("Crypto.Cipher._raw_des3",
- include_dirs=['src/', 'src/libtom/'],
+ include_dirs=['src/'],
sources=["src/DES3.c"],
- py_limited_api=True),
+ py_limited_api=True,
+ extra_link_args=["-ltomcrypt"]),
Extension("Crypto.Util._cpuid_c",
include_dirs=['src/'],
sources=['src/cpuid.c'],
@@ -410,9 +412,10 @@ ext_modules = [
sources=["src/ARC4.c"],
py_limited_api=True),
Extension("Crypto.Cipher._Salsa20",
- include_dirs=['src/', 'src/libtom/'],
+ include_dirs=['src/'],
sources=["src/Salsa20.c"],
- py_limited_api=True),
+ py_limited_api=True,
+ extra_link_args=["-ltomcrypt"]),
Extension("Crypto.Cipher._chacha20",
include_dirs=['src/'],
sources=["src/chacha20.c"],
Only in b: setup.py.orig
Only in b: setup.py.rej
diff -dupr a/src/DES.c b/src/DES.c
--- a/src/DES.c 2021-02-09 13:49:46.336454729 +0100
+++ b/src/DES.c 2021-02-09 13:50:02.640123617 +0100
@@ -39,7 +39,7 @@ FAKE_INIT(raw_des3)
/* Include the actial DES implementation */
#define LTC_NO_PROTOTYPES
-#include "libtom/tomcrypt_des.c"
+#include <tomcrypt.h>
struct block_state {
symmetric_key sk;

View File

@ -0,0 +1,25 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10})
inherit distutils-r1
DESCRIPTION="Yield from multiple iterators as values become available"
HOMEPAGE="https://github.com/jwodder/interleave"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
RDEPEND="
dev-python/wheel[${PYTHON_USEDEP}]
"
PATCHES=( "${FILESDIR}/${PN}-0.2.0-drop-coverage.patch" )
distutils_enable_tests pytest

View File

@ -0,0 +1,21 @@
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>gentoo@chymera.eu</email>
<name>Horea Christian</name>
</maintainer>
<maintainer type="project">
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>
</maintainer>
<longdescription lang="en">
The interleave package provides a function of the same name that
takes a number of iterators, runs them in separate threads, and
yields the values produced as soon as each one is available.
</longdescription>
<upstream>
<remote-id type="github">jwodder/interleave</remote-id>
<remote-id type="pypi">interleave</remote-id>
</upstream>
</pkgmetadata>