dev-python/dandischema: moved to Gentoo Science
https://gitweb.gentoo.org/proj/sci.git/commit/?id=17b74679f9aef73bcd9eb3db3d0c4797c7d76d9a
This commit is contained in:
parent
ff0f436f9f
commit
144b85084d
@ -1,4 +0,0 @@
|
||||
DIST dandischema-0.4.3.tar.gz 51816 SHA256 345db0c4173c90a4e1ef33cbee1bced5129ac78869f63de8ffc30a40484d21e3 SHA512 dc45788337ac50cf453ae54df49b0abcb6ab51584673619bbe5a1d975a9e7d319f114e0273bebc367296379f9c831bb04b03e04cda0ab6b3206d793a76af7b6c WHIRLPOOL 35d718716ec9453143ce8ecc35f5c203bd663042da661ec84421da81f468fcbcad89a8f4fab1ecc03e6d575aa43795dd019dccb324ba1b6a0040c12c8a6f9e62
|
||||
DIST dandischema-0.5.1.tar.gz 55938 SHA256 12f9fd1d95a6e8eeb5eb451706fc73e403509a1ffe4891b88b0a7637009e7729 SHA512 29f82ff708f2078a5e0df0c800a256b67cb231a4ca98a4110dd718b70887c7771c73d4602c265b7c2e29ea2bbf91a8919d11c100e038a4797edfbc479629d740 WHIRLPOOL f020712e6199a8aa109902f80a59b18c7c19473aa7d22198dc3a27d7a42aa69557e4a95bcbc17a2c7765f30735aa2f1ece7e45afe52b09345ca7182b1658226e
|
||||
DIST dandischema-0.5.3.tar.gz 56223 SHA256 5286e86c40776dae6dafbb59c84efa26440771de40b90453120ebd3b7833da68 SHA512 54bed6ffdad2a6b5bac2d14b6cadcde289654e1f9cf5c8bd4d888f479126b1668b5ba72c2ae9c9295bcea930cfcb4aa52b5b3e19e3137cd5496ae9ece43c0a15 WHIRLPOOL 00c4a0f7b292ef892618d5a669d9b5f4e3bf73dc1fa0dd4bbfd4ae384c8555ca0fe48008d3ec84cb09a490b592f8c7bfa8092ebfcf1ecf1853ec21e13085e60a
|
||||
DIST dandischema-0.6.0.tar.gz 57094 SHA256 f451ff18032b245b999cbbda4d01e2e700d760b0343f7caf300c233f7047324a SHA512 eb87773b05bf48f8278e0fc9cadd9b7e6ea7649091aeccb2510f0cd3df5ddca9c384ae3e6fda0c10c065acd36ec013605e13ae6f514bd96615845809a6ee8760 WHIRLPOOL 0eda8d0fabc469b8dd3aa1936b909dbe8a8a9ec94b5f1f694f0709e21b0214387fa327a29373e4a97fc0338d54a4cc73ad9b0a1e3f3bf558079dad385e72e27b
|
@ -1,46 +0,0 @@
|
||||
# Copyright 1999-2022 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
PYTHON_COMPAT=( python3_{8..10} )
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="Schemata for DANDI archive project"
|
||||
HOMEPAGE="https://github.com/dandi/dandischema"
|
||||
SRC_URI="https://github.com/dandi/dandischema/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test"
|
||||
RESTRICT="!test? ( test )"
|
||||
|
||||
RDEPEND="
|
||||
dev-python/wheel[${PYTHON_USEDEP}]
|
||||
dev-python/jsonschema[${PYTHON_USEDEP}]
|
||||
dev-python/pydantic[${PYTHON_USEDEP}]
|
||||
dev-python/python-email-validator[${PYTHON_USEDEP}]
|
||||
dev-python/requests[${PYTHON_USEDEP}]
|
||||
"
|
||||
DEPEND="
|
||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
||||
"
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${PN}-0.3.4-coverage.patch"
|
||||
"${FILESDIR}/${PN}-0.3.4-versioningit.patch"
|
||||
)
|
||||
|
||||
src_configure() {
|
||||
echo "__version__ = '${PV}'" >> dandischema/_version.py
|
||||
}
|
||||
|
||||
distutils_enable_tests pytest
|
||||
|
||||
python_test() {
|
||||
export DANDI_TESTS_NONETWORK=1
|
||||
pushd dandischema || die
|
||||
epytest tests
|
||||
popd
|
||||
}
|
@ -1,42 +0,0 @@
|
||||
# Copyright 1999-2022 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
DISTUTILS_USE_PEP517=setuptools
|
||||
PYTHON_COMPAT=( python3_{8..10} )
|
||||
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="Schemata for DANDI archive project"
|
||||
HOMEPAGE="https://github.com/dandi/dandischema"
|
||||
SRC_URI="https://github.com/dandi/dandischema/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
|
||||
RDEPEND="
|
||||
dev-python/wheel[${PYTHON_USEDEP}]
|
||||
dev-python/jsonschema[${PYTHON_USEDEP}]
|
||||
dev-python/pydantic[${PYTHON_USEDEP}]
|
||||
dev-python/python-email-validator[${PYTHON_USEDEP}]
|
||||
dev-python/requests[${PYTHON_USEDEP}]
|
||||
"
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${PN}-0.3.4-coverage.patch"
|
||||
)
|
||||
|
||||
src_configure() {
|
||||
echo "__version__ = '${PV}'" >> dandischema/_version.py
|
||||
}
|
||||
|
||||
distutils_enable_tests pytest
|
||||
|
||||
python_test() {
|
||||
export DANDI_TESTS_NONETWORK=1
|
||||
pushd dandischema || die
|
||||
epytest tests
|
||||
popd
|
||||
}
|
@ -1,42 +0,0 @@
|
||||
# Copyright 1999-2022 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
DISTUTILS_USE_PEP517=setuptools
|
||||
PYTHON_COMPAT=( python3_{8..10} )
|
||||
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="Schemata for DANDI archive project"
|
||||
HOMEPAGE="https://github.com/dandi/dandischema"
|
||||
SRC_URI="https://github.com/dandi/dandischema/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
|
||||
RDEPEND="
|
||||
dev-python/wheel[${PYTHON_USEDEP}]
|
||||
dev-python/jsonschema[${PYTHON_USEDEP}]
|
||||
dev-python/pydantic[${PYTHON_USEDEP}]
|
||||
dev-python/python-email-validator[${PYTHON_USEDEP}]
|
||||
dev-python/requests[${PYTHON_USEDEP}]
|
||||
"
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${PN}-0.3.4-coverage.patch"
|
||||
)
|
||||
|
||||
src_configure() {
|
||||
echo "__version__ = '${PV}'" >> dandischema/_version.py
|
||||
}
|
||||
|
||||
distutils_enable_tests pytest
|
||||
|
||||
python_test() {
|
||||
export DANDI_TESTS_NONETWORK=1
|
||||
pushd dandischema || die
|
||||
epytest tests
|
||||
popd
|
||||
}
|
@ -1,42 +0,0 @@
|
||||
# Copyright 1999-2022 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
DISTUTILS_USE_PEP517=setuptools
|
||||
PYTHON_COMPAT=( python3_{8..10} )
|
||||
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="Schemata for DANDI archive project"
|
||||
HOMEPAGE="https://github.com/dandi/dandischema"
|
||||
SRC_URI="https://github.com/dandi/dandischema/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
|
||||
RDEPEND="
|
||||
dev-python/wheel[${PYTHON_USEDEP}]
|
||||
dev-python/jsonschema[${PYTHON_USEDEP}]
|
||||
dev-python/pydantic[${PYTHON_USEDEP}]
|
||||
dev-python/python-email-validator[${PYTHON_USEDEP}]
|
||||
dev-python/requests[${PYTHON_USEDEP}]
|
||||
"
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${PN}-0.3.4-coverage.patch"
|
||||
)
|
||||
|
||||
src_configure() {
|
||||
echo "__version__ = '${PV}'" >> dandischema/_version.py
|
||||
}
|
||||
|
||||
distutils_enable_tests pytest
|
||||
|
||||
python_test() {
|
||||
export DANDI_TESTS_NONETWORK=1
|
||||
pushd dandischema || die
|
||||
epytest tests
|
||||
popd
|
||||
}
|
@ -1,11 +0,0 @@
|
||||
--- a/tox.ini 2021-09-22 19:31:20.534576095 -0400
|
||||
+++ b/tox.ini 2021-09-26 16:11:30.080164191 -0400
|
||||
@@ -17,7 +17,7 @@
|
||||
flake8 --config=setup.cfg {posargs} dandischema setup.py
|
||||
|
||||
[pytest]
|
||||
-addopts = --cov=dandischema --tb=short --durations=10
|
||||
+addopts = --tb=short --durations=10
|
||||
filterwarnings = error
|
||||
|
||||
[coverage:run]
|
@ -1,10 +0,0 @@
|
||||
--- a/setup.py 2021-09-22 19:31:20.533576086 -0400
|
||||
+++ b/setup.py 2021-09-23 07:42:02.856983656 -0400
|
||||
@@ -21,7 +21,7 @@
|
||||
|
||||
# Give setuptools a hint to complain if it's too old a version
|
||||
# Should match pyproject.toml
|
||||
-SETUP_REQUIRES = ["setuptools >= 42.0.0", "versioningit ~= 0.1.0"]
|
||||
+SETUP_REQUIRES = ["setuptools >= 42.0.0"]
|
||||
# This enables setuptools to install wheel on-the-fly
|
||||
SETUP_REQUIRES += ["wheel"] if "bdist_wheel" in sys.argv else []
|
@ -1,26 +0,0 @@
|
||||
<?xml version='1.0' encoding='UTF-8'?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<maintainer type="person">
|
||||
<email>gentoo@chymera.eu</email>
|
||||
<name>Horea Christian</name>
|
||||
</maintainer>
|
||||
<maintainer type="project">
|
||||
<email>sci@gentoo.org</email>
|
||||
<name>Gentoo Science Project</name>
|
||||
</maintainer>
|
||||
<longdescription lang="en">
|
||||
A Python library for maintaining and managing DANDI metadata schemata.
|
||||
The library helps create and validate DANDI schema-compliant metadata
|
||||
for Dandisets and assets. Every Dandiset and associated asset has a
|
||||
metadata object that can be retrieved using the DANDI API. This
|
||||
library uses Pydantic to implement all the metadata classes. Schemas
|
||||
are generated on schema modifications and placed into this repository.
|
||||
Dandischema generates JSON schema definitions and also an associated
|
||||
context.json file for JSON-LD compliance of the metadata models.
|
||||
</longdescription>
|
||||
<upstream>
|
||||
<remote-id type="github">dandi/dandischema</remote-id>
|
||||
<remote-id type="pypi">dandischema</remote-id>
|
||||
</upstream>
|
||||
</pkgmetadata>
|
Loading…
x
Reference in New Issue
Block a user