cf348cd8dc
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Horea Christian <chr@chymera.eu>
31 lines
1.0 KiB
Diff
31 lines
1.0 KiB
Diff
setup.py | 2 +-
|
|
statsmodels/tools/testing.py | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index 1a7da9a..a6d1b33 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -134,7 +134,7 @@ def check_dependency_versions(min_versions):
|
|
(spversion, min_versions['scipy']))
|
|
|
|
try:
|
|
- from pandas.version import short_version as pversion
|
|
+ from pandas import __version__ as pversion
|
|
except ImportError:
|
|
install_requires.append('pandas')
|
|
else:
|
|
diff --git a/statsmodels/tools/testing.py b/statsmodels/tools/testing.py
|
|
index 1fde1de..92e77fc 100644
|
|
--- a/statsmodels/tools/testing.py
|
|
+++ b/statsmodels/tools/testing.py
|
|
@@ -17,7 +17,7 @@ def strip_rc(version):
|
|
def is_pandas_min_version(min_version):
|
|
'''check whether pandas is at least min_version
|
|
'''
|
|
- from pandas.version import short_version as pversion
|
|
+ from pandas import __version__ as pversion
|
|
return StrictVersion(strip_rc(pversion)) >= min_version
|
|
|
|
|