1
0
Fork 0

dev-python/statsmodels: version bump ahead of Gentoo Main

Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: Horea Christian <chr@chymera.eu>
This commit is contained in:
Horea Christian 2019-12-23 15:08:00 +01:00
parent 55f1c3b387
commit cf348cd8dc
No known key found for this signature in database
GPG Key ID: EAA9223EE3BB378A
6 changed files with 164 additions and 0 deletions

View File

@ -0,0 +1,6 @@
*statsmodels-0.10.1 (23 Dec 2019)
23 Dec 2019; <chymera@gentoo.org> +files/statsmodels-0.6.1-numpy-1.10.patch,
+files/statsmodels-0.6.1-pandas-0.17.0.patch, +metadata.xml,
+statsmodels-0.10.1.ebuild:
dev-python/statsmodels: version bump ahead of Gentoo Main

View File

@ -0,0 +1 @@
DIST statsmodels-0.10.1.tar.gz 14056607 SHA256 320659a80f916c2edf9dfbe83512d9004bb562b72eedb7d9374562038697fa10 SHA512 eebbdd02af841f66c93e3ea8998c2a74dcf785e12d95c33e0ff791e4abee932b2b76750cd9734a23e260d99f952be5392204607c42a99122e06340f61c96ae6f WHIRLPOOL 730547f525f9eac48bb057ae0dd7f5863ea688828ec71c99c9ea5eaf813efb534d979b45f8c3db8bfffd25bc3a6cb1e9f8fd9925de46572c838b310e194e55cd

View File

@ -0,0 +1,20 @@
statsmodels/tsa/ar_model.py | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/statsmodels/tsa/ar_model.py b/statsmodels/tsa/ar_model.py
index f0af7ee..fe05634 100644
--- a/statsmodels/tsa/ar_model.py
+++ b/statsmodels/tsa/ar_model.py
@@ -256,10 +256,8 @@ class AR(tsbase.TimeSeriesModel):
Vpinv = np.zeros((p, p), dtype=params.dtype)
for i in range(1, p1):
- Vpinv[i-1, i-1:] = np.correlate(params0, params0[:i],
- old_behavior=False)[:-1]
- Vpinv[i-1, i-1:] -= np.correlate(params0[-i:], params0,
- old_behavior=False)[:-1]
+ Vpinv[i-1, i-1:] = np.correlate(params0, params0[:i])[:-1]
+ Vpinv[i-1, i-1:] -= np.correlate(params0[-i:], params0)[:-1]
Vpinv = Vpinv + Vpinv.T - np.diag(Vpinv.diagonal())
return Vpinv

View File

@ -0,0 +1,30 @@
setup.py | 2 +-
statsmodels/tools/testing.py | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/setup.py b/setup.py
index 1a7da9a..a6d1b33 100644
--- a/setup.py
+++ b/setup.py
@@ -134,7 +134,7 @@ def check_dependency_versions(min_versions):
(spversion, min_versions['scipy']))
try:
- from pandas.version import short_version as pversion
+ from pandas import __version__ as pversion
except ImportError:
install_requires.append('pandas')
else:
diff --git a/statsmodels/tools/testing.py b/statsmodels/tools/testing.py
index 1fde1de..92e77fc 100644
--- a/statsmodels/tools/testing.py
+++ b/statsmodels/tools/testing.py
@@ -17,7 +17,7 @@ def strip_rc(version):
def is_pandas_min_version(min_version):
'''check whether pandas is at least min_version
'''
- from pandas.version import short_version as pversion
+ from pandas import __version__ as pversion
return StrictVersion(strip_rc(pversion)) >= min_version

View File

@ -0,0 +1,34 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
<maintainer type="project">
<email>sci-mathematics@gentoo.org</email>
<name>Gentoo Mathematics Project</name>
</maintainer>
<maintainer type="person">
<email>horea.christ@gmail.com</email>
<name>Horea Christian</name>
</maintainer>
<maintainer type="project">
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
<longdescription lang="en">
statsmodels is a Python module that allows users to explore data,
estimate statistical models, and perform statistical tests. An
extensive list of descriptive statistics, statistical tests,
plotting functions, and result statistics are available for
different types of data and each estimator. Researchers across
fields may find that statsmodels fully meets their needs for
statistical computing and data analysis in Python.
</longdescription>
<upstream>
<remote-id type="pypi">statsmodels</remote-id>
<remote-id type="github">statsmodels</remote-id>
<remote-id type="sourceforge">statsmodels</remote-id>
</upstream>
</pkgmetadata>

View File

@ -0,0 +1,73 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit distutils-r1 eutils
DESCRIPTION="Statistical computations and models for use with SciPy"
HOMEPAGE="https://www.statsmodels.org/stable/index.html"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples test"
COMMON_DEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
>=dev-python/pandas-0.23.0[${PYTHON_USEDEP}]
dev-python/patsy[${PYTHON_USEDEP}]
sci-libs/scipy[${PYTHON_USEDEP}]
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
dev-python/cython[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
doc? (
dev-python/ipykernel[${PYTHON_USEDEP}]
dev-python/jupyter_client[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/nbconvert[${PYTHON_USEDEP}]
dev-python/nbformat[${PYTHON_USEDEP}]
dev-python/numpydoc[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
)
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
)
"
python_prepare_all() {
# Prevent un-needed d'loading
sed -e "/sphinx.ext.intersphinx/d" -i docs/source/conf.py || die
export VARTEXFONTS="${T}"/fonts
export MPLCONFIGDIR="${T}"
echo "backend : Agg" > "${MPLCONFIGDIR}"/matplotlibrc || die
distutils-r1_python_prepare_all
}
python_compile_all() {
use doc && esetup.py build_sphinx -b html --build-dir=docs/build
}
python_test() {
cd "${BUILD_DIR}" || die
python -c 'import statsmodels; statsmodels.test()' || die
}
python_install_all() {
find . -name \*LICENSE.txt -delete || die
use doc && HTML_DOCS=( docs/build/html/. )
if use examples; then
docompress -x /usr/share/doc/${PF}/examples
dodoc -r examples
fi
distutils-r1_python_install_all
}
pkg_postinst() {
optfeature "Plotting functionality" "dev-python/matplotlib"
}