dev-vcs/dandi-cli: version bump
and fixed tests Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Horea Christian <chr@chymera.eu>
This commit is contained in:
parent
53d1bf27a8
commit
a995db862f
@ -3,3 +3,4 @@ DIST dandi-cli-0.30.3.tar.gz 175911 SHA256 ed218df35ee69f6d06fd6c70fe69226aaf6d3
|
||||
DIST dandi-cli-0.31.0.tar.gz 179090 SHA256 6bc9a46e90da1b6b11fcc1492c02223f135ce5a1f42747df8f5cb09fe6cb1c10 SHA512 5c72b0a75469c3f5762a653b454797723251b108c770ad617f814983691f5205c02302a444dc5650754597537d6dd75a3bc84d886a557243d489d738e3033981 WHIRLPOOL 2d2d1ad8e392f0ec0dd707963618cda3e524bd6efbd2240c8fec2fd5bec3ca15f47740a6b96c47f4f4ec05f4abd6fae90875b95fa272d79d42b305385fcafc35
|
||||
DIST dandi-cli-0.34.1.tar.gz 179765 SHA256 7b8ef65b49c6adb42c927018214f11a9c549ba6297373c929b551e1443ca95c0 SHA512 c6e42052a3bbce374589eea43f3cef9525f2d95b555731dc2899f432567c92ab6425a59b131f22f547b9e74a6225462e2dc50a7c3f1b707e17fb49e75d2e0d55 WHIRLPOOL 89b9aa5b6682d4ba2c0b035ea90ad5b77fc025cb7cfd474dc8d41297e3efc567c1ded27751912c0b588f87927a117984889907c60b49dda80eb26bac8be1c93b
|
||||
DIST dandi-cli-0.35.0.tar.gz 180324 SHA256 c05706225096cc2357552c822d6c8da985b553d2b0406415cc0037acac50222f SHA512 07689e678d064501ec6879eeb40389c87491cbde4321b382c5c1041b9a8228845086978629327a9b271b5ac62f4c66e4d3c32c1edffead93ec66ce4d03b96d9a WHIRLPOOL bd970e1983a49a7af547431fb2717cf706884fcc232698b548d687d4971699da49bff818a64081f8d83628f165996fa40182331f740933e87d69cffcd4d85d06
|
||||
DIST dandi-cli-0.37.0.tar.gz 212121 SHA256 4bf40a179d68ae4f0b28a5b62db6da8d14e17e9cb3b747162379cceab8055448 SHA512 fe96b760bb8526cf2670be4523121b389ede82699a8b13a9b46e4511012ab15390d9aec35b5403fa4d52dd79738a37980bcc83755df738b4039ae56eb6ca0f14 WHIRLPOOL 62a0fdc4f527bc246dd0452fd481e19bd07b146b9e118b8caa71227be78f5573649b0f55912cf54fe9606dc0de579692f94cc5a92f5c9a59a9d6c091bc3c068f
|
||||
|
@ -3,7 +3,9 @@
|
||||
|
||||
EAPI=8
|
||||
|
||||
DISTUTILS_USE_PEP517=setuptools
|
||||
PYTHON_COMPAT=( python3_{8..10} )
|
||||
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="DANDI command line client to facilitate common operations"
|
||||
@ -14,8 +16,6 @@ LICENSE="Apache-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test etelemetry"
|
||||
#RESTRICT="test"
|
||||
# Test fail during collection, reported upstream: https://github.com/dandi/dandi-cli/issues/774
|
||||
|
||||
RDEPEND="
|
||||
dev-python/appdirs[${PYTHON_USEDEP}]
|
||||
@ -40,11 +40,7 @@ RDEPEND="
|
||||
dev-python/tenacity[${PYTHON_USEDEP}]
|
||||
dev-python/tqdm[${PYTHON_USEDEP}]
|
||||
dev-python/wheel[${PYTHON_USEDEP}]
|
||||
<dev-python/jsonschema-4[${PYTHON_USEDEP}]
|
||||
"
|
||||
# Errors with newer jsonschema, though not a direct dependency, reported upstream:
|
||||
# https://github.com/dandi/dandi-cli/issues/825
|
||||
# https://github.com/python-hyper/uritemplate/issues/76
|
||||
|
||||
DEPEND="
|
||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
||||
@ -56,6 +52,13 @@ DEPEND="
|
||||
)
|
||||
"
|
||||
|
||||
EPYTEST_DESELECT=(
|
||||
"dandi/tests/test_utils.py::test_get_instance_dandi_with_api"
|
||||
"dandi/tests/test_utils.py::test_get_instance_url"
|
||||
"dandi/tests/test_utils.py::test_get_instance_cli_version_too_old"
|
||||
"dandi/tests/test_utils.py::test_get_instance_bad_cli_version"
|
||||
)
|
||||
|
||||
distutils_enable_tests pytest
|
||||
|
||||
PATCHES=(
|
||||
@ -74,5 +77,5 @@ src_prepare() {
|
||||
|
||||
python_test() {
|
||||
export DANDI_TESTS_NONETWORK=1
|
||||
${EPYTHON} -m pytest -vv || die "Tests failed with ${EPYTHON}"
|
||||
epytest
|
||||
}
|
||||
|
@ -3,7 +3,9 @@
|
||||
|
||||
EAPI=8
|
||||
|
||||
DISTUTILS_USE_PEP517=setuptools
|
||||
PYTHON_COMPAT=( python3_{8..10} )
|
||||
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="DANDI command line client to facilitate common operations"
|
||||
@ -14,8 +16,6 @@ LICENSE="Apache-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test etelemetry"
|
||||
#RESTRICT="test"
|
||||
# Test fail during collection, reported upstream: https://github.com/dandi/dandi-cli/issues/774
|
||||
|
||||
RDEPEND="
|
||||
dev-python/appdirs[${PYTHON_USEDEP}]
|
||||
@ -40,14 +40,9 @@ RDEPEND="
|
||||
dev-python/tenacity[${PYTHON_USEDEP}]
|
||||
dev-python/tqdm[${PYTHON_USEDEP}]
|
||||
dev-python/wheel[${PYTHON_USEDEP}]
|
||||
<dev-python/jsonschema-4[${PYTHON_USEDEP}]
|
||||
"
|
||||
# Errors with newer jsonschema, though not a direct dependency, reported upstream:
|
||||
# https://github.com/dandi/dandi-cli/issues/825
|
||||
# https://github.com/python-hyper/uritemplate/issues/76
|
||||
|
||||
DEPEND="
|
||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
||||
test? (
|
||||
dev-python/anys[${PYTHON_USEDEP}]
|
||||
dev-python/responses[${PYTHON_USEDEP}]
|
||||
@ -56,10 +51,20 @@ DEPEND="
|
||||
)
|
||||
"
|
||||
|
||||
# Some tests require deep copy with git history
|
||||
# https://github.com/dandi/dandi-cli/issues/878#issuecomment-1021720299
|
||||
EPYTEST_DESELECT=(
|
||||
"dandi/tests/test_utils.py::test_get_instance_dandi_with_api"
|
||||
"dandi/tests/test_utils.py::test_get_instance_url"
|
||||
"dandi/tests/test_utils.py::test_get_instance_cli_version_too_old"
|
||||
"dandi/tests/test_utils.py::test_get_instance_bad_cli_version"
|
||||
)
|
||||
|
||||
distutils_enable_tests pytest
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${PN}-0.34.1-pip-versioncheck.patch"
|
||||
"${FILESDIR}/${PN}-0.35.0-test_nonetwork.patch"
|
||||
)
|
||||
|
||||
src_prepare() {
|
||||
@ -74,5 +79,5 @@ src_prepare() {
|
||||
|
||||
python_test() {
|
||||
export DANDI_TESTS_NONETWORK=1
|
||||
${EPYTHON} -m pytest -vv || die "Tests failed with ${EPYTHON}"
|
||||
epytest
|
||||
}
|
||||
|
87
dev-vcs/dandi-cli/dandi-cli-0.37.0.ebuild
Normal file
87
dev-vcs/dandi-cli/dandi-cli-0.37.0.ebuild
Normal file
@ -0,0 +1,87 @@
|
||||
# Copyright 1999-2022 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
DISTUTILS_USE_PEP517=setuptools
|
||||
PYTHON_COMPAT=( python3_{8..10} )
|
||||
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="DANDI command line client to facilitate common operations"
|
||||
HOMEPAGE="https://github.com/dandi/dandi-cli"
|
||||
SRC_URI="https://github.com/dandi/dandi-cli/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test etelemetry"
|
||||
RESTRICT="test"
|
||||
# video tests fail:
|
||||
# https://github.com/dandi/dandi-cli/issues/944
|
||||
|
||||
RDEPEND="
|
||||
dev-python/appdirs[${PYTHON_USEDEP}]
|
||||
dev-python/click[${PYTHON_USEDEP}]
|
||||
dev-python/click-didyoumean[${PYTHON_USEDEP}]
|
||||
~dev-python/dandischema-0.6.0[${PYTHON_USEDEP}]
|
||||
dev-python/fasteners[${PYTHON_USEDEP}]
|
||||
dev-python/fscacher[${PYTHON_USEDEP}]
|
||||
dev-python/humanize[${PYTHON_USEDEP}]
|
||||
dev-python/interleave[${PYTHON_USEDEP}]
|
||||
dev-python/joblib[${PYTHON_USEDEP}]
|
||||
dev-python/keyring[${PYTHON_USEDEP}]
|
||||
dev-python/keyrings_alt[${PYTHON_USEDEP}]
|
||||
dev-python/packaging[${PYTHON_USEDEP}]
|
||||
dev-python/pycryptodomex[${PYTHON_USEDEP}]
|
||||
>=dev-python/pydantic-1.9.0[${PYTHON_USEDEP}]
|
||||
dev-python/pynwb[${PYTHON_USEDEP}]
|
||||
dev-python/pyout[${PYTHON_USEDEP}]
|
||||
dev-python/python-dateutil[${PYTHON_USEDEP}]
|
||||
dev-python/requests[${PYTHON_USEDEP}]
|
||||
dev-python/ruamel-yaml[${PYTHON_USEDEP}]
|
||||
dev-python/semantic_version[${PYTHON_USEDEP}]
|
||||
dev-python/tenacity[${PYTHON_USEDEP}]
|
||||
dev-python/wheel[${PYTHON_USEDEP}]
|
||||
dev-python/zarr[${PYTHON_USEDEP}]
|
||||
"
|
||||
|
||||
DEPEND="
|
||||
test? (
|
||||
dev-python/anys[${PYTHON_USEDEP}]
|
||||
dev-python/responses[${PYTHON_USEDEP}]
|
||||
dev-python/pyfakefs[${PYTHON_USEDEP}]
|
||||
dev-python/pytest-mock[${PYTHON_USEDEP}]
|
||||
media-libs/opencv[${PYTHON_USEDEP}]
|
||||
)
|
||||
"
|
||||
|
||||
# Some tests require deep copy with git history
|
||||
# https://github.com/dandi/dandi-cli/issues/878#issuecomment-1021720299
|
||||
EPYTEST_DESELECT=(
|
||||
"dandi/tests/test_utils.py::test_get_instance_dandi_with_api"
|
||||
"dandi/tests/test_utils.py::test_get_instance_url"
|
||||
"dandi/tests/test_utils.py::test_get_instance_cli_version_too_old"
|
||||
"dandi/tests/test_utils.py::test_get_instance_bad_cli_version"
|
||||
)
|
||||
|
||||
distutils_enable_tests pytest
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${PN}-0.37.0-pip-versioncheck.patch"
|
||||
)
|
||||
|
||||
src_prepare() {
|
||||
if use etelemetry; then
|
||||
default
|
||||
else
|
||||
eapply "${FILESDIR}/${PN}-0.28.0-no-etelemetry.patch"
|
||||
default
|
||||
sed -i "/etelemetry/d" setup.cfg
|
||||
fi
|
||||
}
|
||||
|
||||
python_test() {
|
||||
export DANDI_TESTS_NONETWORK=1
|
||||
epytest
|
||||
}
|
@ -0,0 +1,21 @@
|
||||
From e5a6dd4bdc4db828ea1de2a48e96cbdb80465e86 Mon Sep 17 00:00:00 2001
|
||||
From: "John T. Wodder II" <git@varonathe.org>
|
||||
Date: Tue, 25 Jan 2022 18:53:53 -0500
|
||||
Subject: [PATCH] Mark a test with missing `skipif_no_network` marker
|
||||
|
||||
---
|
||||
dandi/tests/test_metadata.py | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/dandi/tests/test_metadata.py b/dandi/tests/test_metadata.py
|
||||
index 5896e6ef..a0a6bce1 100644
|
||||
--- a/dandi/tests/test_metadata.py
|
||||
+++ b/dandi/tests/test_metadata.py
|
||||
@@ -351,6 +351,7 @@ def test_parseobourl(url, value):
|
||||
assert parse_purlobourl(url) == value
|
||||
|
||||
|
||||
+@mark.skipif_no_network
|
||||
def test_species():
|
||||
m = {"species": "http://purl.obolibrary.org/obo/NCBITaxon_28584"}
|
||||
assert extract_species(m).json_dict() == {
|
@ -0,0 +1,13 @@
|
||||
--- a/setup.cfg 2021-10-06 11:44:40.549337707 -0400
|
||||
+++ b/dsetup.cfg 2021-10-06 11:45:10.236935245 -0400
|
||||
@@ -30,8 +30,8 @@
|
||||
appdirs
|
||||
click
|
||||
click-didyoumean
|
||||
- dandischema ~= 0.6.0
|
||||
- etelemetry >= 0.2.2
|
||||
+ dandischema
|
||||
+ etelemetry
|
||||
fasteners
|
||||
fscacher
|
||||
# Specifying != might be what causes pip 19.3.1 first to install hdmf 1.5.1
|
@ -19,4 +19,8 @@
|
||||
<use>
|
||||
<flag name="etelemetry">version checking to respect server schema version</flag>
|
||||
</use>
|
||||
<upstream>
|
||||
<remote-id type="github">dandi/dandi-cli</remote-id>
|
||||
<remote-id type="pypi">dandi</remote-id>
|
||||
</upstream>
|
||||
</pkgmetadata>
|
||||
|
Loading…
x
Reference in New Issue
Block a user