1
0
Fork 0

Migrated to main tree

49aa89d2a6
This commit is contained in:
Horea Christian 2019-04-07 10:09:52 +02:00
parent 9c6f3e8a1c
commit 6903e2e48f
7 changed files with 0 additions and 211 deletions

View File

@ -1 +0,0 @@
DIST hdf5-1.10.5.tar.bz2 8706317 SHA256 68d6ea8843d2a106ec6a7828564c1689c7a85714a35d8efafa2fee20ca366f44 SHA512 769e43b8672e26fe24ed68da0228c010d3d9bc950ca09f0bc60707911a2f26f2f8415c8abc8ec06e07667148d8cdb3b0c7b3e7860d9b19739629c5dfd5ce73d4 WHIRLPOOL 29eb782010dc03310e623cacf3aa71b0b9bf3abc01170a870ed62f6a767784513f4757d447e8a9b1ab9d833f4a799a39551d9bd8a78873dd43da31b274435b4c

View File

@ -1,21 +0,0 @@
Prevent build system with messing up LD_LIBRARY_PATH
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -125,8 +125,6 @@ settings_DATA=libhdf5.settings
# Remove the generated .c file if errors occur unless HDF5_Make_Ignore
# is set to ignore the error.
H5Tinit.c: H5detect$(EXEEXT)
- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
- sed -e 's/-L/:/g' -e 's/ //g'`" \
$(RUNSERIAL) ./H5detect$(EXEEXT) > $@ || \
(test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
($(RM) $@ ; exit 1)
@@ -137,8 +135,6 @@ H5Tinit.c: H5detect$(EXEEXT)
# Remove the generated .c file if errors occur unless HDF5_Make_Ignore
# is set to ignore the error.
H5lib_settings.c: H5make_libsettings$(EXEEXT) libhdf5.settings
- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
- sed -e 's/-L/:/g' -e 's/ //g'`" \
$(RUNSERIAL) ./H5make_libsettings$(EXEEXT) > $@ || \
(test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
($(RM) $@ ; exit 1)

View File

@ -1,43 +0,0 @@
--- a/hl/src/H5LTanalyze.c
+++ b/hl/src/H5LTanalyze.c
@@ -40,6 +40,7 @@
#include <string.h>
#include <errno.h>
#include <stdlib.h>
+#include <unistd.h>
/* end standard C headers. */
--- a/hl/src/H5LTanalyze.l
+++ b/hl/src/H5LTanalyze.l
@@ -16,6 +16,7 @@
%{
#include <stdlib.h>
#include <string.h>
+#include <unistd.h>
#include <hdf5.h>
#include "H5LTparse.h"
--- a/test/cache_common.h
+++ b/test/cache_common.h
@@ -702,5 +702,8 @@ void validate_mdc_config(hid_t file_id,
hbool_t compare_init,
int test_num);
+hbool_t resize_configs_are_equal(const H5C_auto_size_ctl_t *a,
+ const H5C_auto_size_ctl_t *b,
+ hbool_t compare_init);
#endif /* _CACHE_COMMON_H */
--- a/testpar/t_span_tree.c
+++ b/testpar/t_span_tree.c
@@ -37,6 +37,9 @@
#include "hdf5.h"
#include "H5private.h"
#include "testphdf5.h"
+#define H5S_PACKAGE
+#define H5S_TESTING
+#include "H5Spkg.h"
static void coll_write_test(int chunk_factor);

View File

@ -1,16 +0,0 @@
Prevent accidental inclusion of mpi c++ headers
when hdf5.h is included third party library
https://bugs.gentoo.org/show_bug.cgi?id=420777
--- a/src/H5public.h
+++ b/src/H5public.h
@@ -58,6 +58,8 @@
# include <stddef.h>
#endif
#ifdef H5_HAVE_PARALLEL
+# define OMPI_SKIP_MPICXX /* Make sure that cxx specific headers are not included */
+# define MPICH_SKIP_MPICXX
# include <mpi.h>
#ifndef MPI_FILE_NULL /*MPIO may be defined in mpi.h already */
# include <mpio.h>

View File

@ -1,15 +0,0 @@
Make sure that during runtime we'll use the same libgfortran as during linking
https://bugs.gentoo.org/show_bug.cgi?id=419991
https://bugs.gentoo.org/show_bug.cgi?id=419895
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -181,6 +181,7 @@
else
H5test_kind_SOURCES = $(srcdir)/H5test_kind.f90
endif
+H5test_kind_LDFLAGS=-static-libgfortran
# Mark this directory as part of the Fortran API
FORTRAN_API=yes

View File

@ -1,95 +0,0 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
FORTRAN_NEEDED=fortran
AUTOTOOLS_AUTORECONF=1
inherit autotools-utils eutils fortran-2 flag-o-matic toolchain-funcs multilib versionator prefix
MY_P=${PN}-${PV/_p/-patch}
MAJOR_P=${PN}-$(get_version_component_range 1-2 ${PV})
DESCRIPTION="General purpose library and file format for storing scientific data"
HOMEPAGE="http://www.hdfgroup.org/HDF5/"
SRC_URI="http://www.hdfgroup.org/ftp/HDF5/releases/${MAJOR_P}/${MY_P}/src/${MY_P}.tar.bz2"
LICENSE="NCSA-HDF"
SLOT="0/${PV%%_p*}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="cxx debug examples fortran +hl mpi static-libs szip threads zlib"
REQUIRED_USE="
cxx? ( !mpi ) mpi? ( !cxx )
threads? ( !cxx !mpi !fortran !hl )"
RDEPEND="
mpi? ( virtual/mpi[romio] )
szip? ( virtual/szip )
zlib? ( sys-libs/zlib:0= )"
DEPEND="${RDEPEND}
sys-devel/libtool:2
>=sys-devel/autoconf-2.69"
S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${PN}-1.8.9-static_libgfortran.patch
"${FILESDIR}"/${PN}-1.8.9-mpicxx.patch
"${FILESDIR}"/${PN}-1.8.13-no-messing-ldpath.patch
)
pkg_setup() {
tc-export CXX CC AR # workaround for bug 285148
use fortran && fortran-2_pkg_setup
if use mpi; then
if has_version 'sci-libs/hdf5[-mpi]'; then
ewarn "Installing hdf5 with mpi enabled with a previous hdf5 with mpi disabled may fail."
ewarn "Try to uninstall the current hdf5 prior to enabling mpi support."
fi
export CC=mpicc
use fortran && export FC=mpif90
elif has_version 'sci-libs/hdf5[mpi]'; then
ewarn "Installing hdf5 with mpi disabled while having hdf5 installed with mpi enabled may fail."
ewarn "Try to uninstall the current hdf5 prior to disabling mpi support."
fi
}
src_prepare() {
# respect gentoo examples directory
sed \
-e "s:hdf5_examples:doc/${PF}/examples:g" \
-i $(find . -name Makefile.am) $(find . -name "run*.sh.in") || die
sed \
-e '/docdir/d' \
-i config/commence.am || die
if ! use examples; then
sed -e '/^install:/ s/install-examples//' \
-i Makefile.am || die #409091
fi
# enable shared libs by default for h5cc config utility
sed -i -e "s/SHLIB:-no/SHLIB:-yes/g" tools/src/misc/h5cc.in || die
hprefixify m4/libtool.m4
autotools-utils_src_prepare
}
src_configure() {
local myeconfargs=(
--docdir="${EPREFIX}"/usr/share/doc/${PF}
--enable-deprecated-symbols
$(use debug && echo --enable-build-mode=debug || echo --enable-build-mode=production)
$(use_enable debug codestack)
$(use_enable cxx)
$(use_enable fortran)
$(use_enable hl)
$(use_enable mpi parallel)
$(use_enable threads threadsafe)
$(use_with szip szlib)
$(use_with threads pthread)
$(use_with zlib)
)
autotools-utils_src_configure
}

View File

@ -1,20 +0,0 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>
</maintainer>
<longdescription>
HDF5 is a file format and library for storing scientific data. HDF5
was designed and implemented to address the deficiencies of HDF4.x. It
has a more powerful and flexible data model, supports files larger
than 2 GB, and supports parallel I/O.
</longdescription>
<use>
<flag name="fortran2003">Enable new features that require Fortran 2003
(http://www.hdfgroup.org/HDF5/doc/fortran/NewFeatures_F2003.pdf)</flag>
<flag name="hl">Enable high level API
(https://support.hdfgroup.org/HDF5/doc/HL/index.html)</flag>
</use>
</pkgmetadata>