NEw package
ahead of inclusion in master
This commit is contained in:
parent
d032e45b55
commit
61e8a9c0b3
1
sci-visualization/fsleyes/Manifest
Normal file
1
sci-visualization/fsleyes/Manifest
Normal file
@ -0,0 +1 @@
|
|||||||
|
DIST fsleyes-0.26.2.tar.gz 82646638 SHA256 d702c8905eaadeb38ac5393a0207074c37639f7a74acc4b1f7e04a84bd17b9f6 SHA512 36bb376726f7cafd2b850686230077f1c4d65692c9d76259a3278e2e1e8bec3df86d0a2439262b56f9ab2d10519fddd89cbbfa5b2fd4c218820b10ecebae59d3 WHIRLPOOL 90737e94f1f7fa9d03f93d5946598a55eb6955170ef6b94e2d7cfb30deb0063daaf30cabf6db052ee9c8a78f5535c2cc003b437d4234d04957c6985d203dc2ad
|
14
sci-visualization/fsleyes/files/fsleyes-0.26.2-fsldir.patch
Normal file
14
sci-visualization/fsleyes/files/fsleyes-0.26.2-fsldir.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
--- a/fsleyes/main.py 2018-09-24 17:46:07.756686411 +0200
|
||||||
|
+++ b/fsleyes/main.py 2018-10-06 14:36:53.328135230 +0200
|
||||||
|
@@ -325,11 +325,6 @@
|
||||||
|
app.SetTopWindow(frame)
|
||||||
|
frame.Show()
|
||||||
|
|
||||||
|
- # Check that $FSLDIR is set, complain
|
||||||
|
- # to the user if it isn't
|
||||||
|
- if not namespace[0].skipfslcheck:
|
||||||
|
- wx.CallAfter(fslDirWarning, frame)
|
||||||
|
-
|
||||||
|
# Check for updates. Ignore point
|
||||||
|
# releases, otherwise users might
|
||||||
|
# get swamped with update notifications.
|
56
sci-visualization/fsleyes/fsleyes-0.26.2.ebuild
Normal file
56
sci-visualization/fsleyes/fsleyes-0.26.2.ebuild
Normal file
@ -0,0 +1,56 @@
|
|||||||
|
# Copyright 1999-2018 Gentoo Foundation
|
||||||
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
|
EAPI=7
|
||||||
|
|
||||||
|
PYTHON_COMPAT=( python{2_7,3_5,3_6} )
|
||||||
|
|
||||||
|
inherit distutils-r1
|
||||||
|
|
||||||
|
MY_HASH="bfc2c0919b68583b6237cbdd9492e69a7bed30189b19dd21f7ba59f9f39e"
|
||||||
|
|
||||||
|
DESCRIPTION="The new FSL image viewer, released with FSL 5.0.10"
|
||||||
|
HOMEPAGE="https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/tree/master"
|
||||||
|
SRC_URI="https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/-/archive/${PV}/${P}.tar.gz"
|
||||||
|
|
||||||
|
LICENSE="Apache-2.0"
|
||||||
|
SLOT="0"
|
||||||
|
KEYWORDS="~amd64 ~x86"
|
||||||
|
IUSE="test"
|
||||||
|
|
||||||
|
DEPEND="
|
||||||
|
test? (
|
||||||
|
${RDEPEND}
|
||||||
|
dev-python/mock[${PYTHON_USEDEP}]
|
||||||
|
dev-python/pytest[${PYTHON_USEDEP}]
|
||||||
|
)
|
||||||
|
dev-python/setuptools[${PYTHON_USEDEP}]
|
||||||
|
"
|
||||||
|
|
||||||
|
RDEPEND="
|
||||||
|
dev-python/fslpy[${PYTHON_USEDEP}]
|
||||||
|
=dev-python/jinja-2*[${PYTHON_USEDEP}]
|
||||||
|
>=dev-python/matplotlib-1.5.1[${PYTHON_USEDEP}]
|
||||||
|
>=dev-python/numpy-1.14.0[${PYTHON_USEDEP}]
|
||||||
|
>=dev-python/pillow-3.4.2[${PYTHON_USEDEP}]
|
||||||
|
>=dev-python/pyopengl-3.1.0[${PYTHON_USEDEP}]
|
||||||
|
>=dev-python/pyopengl_accelerate-3.1.0[${PYTHON_USEDEP}]
|
||||||
|
=dev-python/pyparsing-2*[${PYTHON_USEDEP}]
|
||||||
|
=dev-python/six-1*[${PYTHON_USEDEP}]
|
||||||
|
>=dev-python/wxpython-3.0.2.0[${PYTHON_USEDEP}]
|
||||||
|
>=sci-libs/scipy-0.18[${PYTHON_USEDEP}]
|
||||||
|
=sci-libs/nibabel-2*[${PYTHON_USEDEP}]
|
||||||
|
sci-visualization/fsleyes-widgets[${PYTHON_USEDEP}]
|
||||||
|
sci-visualization/fsleyes-props[${PYTHON_USEDEP}]
|
||||||
|
"
|
||||||
|
|
||||||
|
PATCHES=( "${FILESDIR}/${P}-fsldir.patch" )
|
||||||
|
|
||||||
|
src_prepare() {
|
||||||
|
sed -i -e "s/Pillow>=3.2.0,<5.0/Pillow>=3.2.0/g" requirements.txt
|
||||||
|
distutils-r1_src_prepare
|
||||||
|
}
|
||||||
|
|
||||||
|
python_test() {
|
||||||
|
pytest -v || die
|
||||||
|
}
|
Loading…
x
Reference in New Issue
Block a user