Added patch to parameterzie whirlgif install
This commit is contained in:
parent
5af66b963d
commit
5b49d4877d
@ -29,7 +29,7 @@ EGIT_BRANCH="packaging"
|
||||
SLOT="0"
|
||||
LICENSE="GPL-3+"
|
||||
KEYWORDS=""
|
||||
IUSE="test"
|
||||
IUSE="test whirlgif"
|
||||
RESTRICT="!test? ( test )"
|
||||
|
||||
RDEPEND="
|
||||
@ -74,6 +74,11 @@ src_prepare() {
|
||||
|
||||
src_configure() {
|
||||
#LDFLAGS="-L${S}/${LIBDIR} ${LDFLAGS}" econf --enable-progpath="${EPREFIX}/usr/bin"
|
||||
if use !whirlgif; then
|
||||
#sed -i /whirlgif/d src/CMakeLists_binaries.txt
|
||||
#cat src/CMakeLists_binaries.txt
|
||||
eapply "${FILESDIR}/${PN}-whirlgif.patch"
|
||||
fi
|
||||
export CFLAGS="-pthread ${CFLAGS}"
|
||||
export GIT_REPO_VERSION=3.0.1.1
|
||||
#export LDFLAGS="-lpthread ${LDFLAGS}"
|
||||
@ -126,9 +131,10 @@ src_install() {
|
||||
#addpredict /usr/bin/whirlgif
|
||||
#addpredict /usr/bin/mpeg_encode
|
||||
#exit
|
||||
rm targets_built/whirlgif
|
||||
rm targets_built/mpeg_encode
|
||||
DESTDIR=${D} eninja install
|
||||
cd ${D}
|
||||
#rm usr/bin/whirlgif
|
||||
rm usr/bin/mpeg_encode
|
||||
# This is old example ants stuff.
|
||||
#BUILD_DIR="${WORKDIR}/${P}_build/ANTS-build"
|
||||
#cmake_src_install
|
||||
|
39
sci-biology/afni/files/afni-whirlgif.patch
Normal file
39
sci-biology/afni/files/afni-whirlgif.patch
Normal file
@ -0,0 +1,39 @@
|
||||
diff --git a/packaging/installation_components.txt b/packaging/installation_components.txt
|
||||
index 127193338..ba8825a7b 100644
|
||||
--- a/packaging/installation_components.txt
|
||||
+++ b/packaging/installation_components.txt
|
||||
@@ -347,7 +347,6 @@ uniq_images, corebinaries
|
||||
unu, corebinaries
|
||||
waver, corebinaries
|
||||
whereami, corebinaries
|
||||
-whirlgif, corebinaries
|
||||
3dMax, tcsh
|
||||
3dPAR2AFNI.pl, tcsh
|
||||
@1dDiffMag, tcsh
|
||||
diff --git a/src/CMakeLists_binaries.txt b/src/CMakeLists_binaries.txt
|
||||
index d53368390..8c8e9e1fb 100644
|
||||
--- a/src/CMakeLists_binaries.txt
|
||||
+++ b/src/CMakeLists_binaries.txt
|
||||
@@ -209,7 +209,6 @@ foreach(
|
||||
uniq_images
|
||||
unu
|
||||
whereami
|
||||
- whirlgif
|
||||
)
|
||||
|
||||
add_afni_executable(${target} ${target}.c)
|
||||
diff --git a/src/Makefile.INCLUDE b/src/Makefile.INCLUDE
|
||||
index f44103def..7ac08a87d 100644
|
||||
--- a/src/Makefile.INCLUDE
|
||||
+++ b/src/Makefile.INCLUDE
|
||||
@@ -3495,11 +3495,6 @@ help_format:help_format.o
|
||||
ibinom:ibinom.o
|
||||
$(CC) -o ibinom ibinom.o $(LFLAGS) $(LLIBS)
|
||||
|
||||
-## GIF animation
|
||||
-
|
||||
-whirlgif:whirlgif.h whirlgif.c
|
||||
- $(CC) -o whirlgif whirlgif.c $(INFLAGS) $(LFLAGS) $(LLIBS)
|
||||
-
|
||||
extor.o:extor.c
|
||||
$(CCFAST) -c extor.c $(INFLAGS)
|
Loading…
x
Reference in New Issue
Block a user