Browse Source

dev-python/ezdxf: add

add EZDXF, a mandatory dependency of CadQuery

Signed-off-by: Cecil Curry <leycec@gmail.com>
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
master
leycec 1 year ago committed by Andrew Ammerlaan
parent
commit
9deff28fa1
No known key found for this signature in database
GPG Key ID: A2E2304370447E8E
  1. 1
      dev-python/ezdxf/Manifest
  2. 33
      dev-python/ezdxf/ezdxf-0.16.5.ebuild
  3. 17
      dev-python/ezdxf/metadata.xml

1
dev-python/ezdxf/Manifest

@ -0,0 +1 @@
DIST ezdxf-0.16.5.zip 1552408 BLAKE2B d52131c776c5560da659db67b87a5403a0a0f44aa21781d9599555cc71a3a91cd4e92574f985079456bfd6c844fb693cdef5d16277e83dbd6ca378013d5423ca SHA512 1e35aea16bf169bc2fe3bc3accf83f42189371a80cea259f46dcee1e9c75b613f9c09e6e300a2f331510722a1eefa1550052b7d58c08c4e3a0868cebdfe7b330

33
dev-python/ezdxf/ezdxf-0.16.5.ebuild

@ -0,0 +1,33 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
#FIXME: Upstream explicitly supports "pypy3", but Gentoo dependencies do not.
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Python interface to DXF"
HOMEPAGE="https://pypi.org/project/ezdxf"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="cython matplotlib qt5"
BDEPEND="
cython? ( dev-python/cython[${PYTHON_USEDEP}] )
"
DEPEND="
dev-python/typing-extensions[${PYTHON_USEDEP}]
>=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]
"
RDEPEND="${DEPEND}
matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
qt5? ( dev-python/PyQt5[${PYTHON_USEDEP}] )
"
#FIXME: Enabling tests requires packaging additional packages (e.g., "geomdl").
RESTRICT="test"

17
dev-python/ezdxf/metadata.xml

@ -0,0 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>
</maintainer>
<upstream>
<remote-id type="pypi">ezdxf</remote-id>
<remote-id type="github">mozman/ezdxf</remote-id>
</upstream>
<use>
<flag name="cython">Build Cython-based C extensions</flag>
<flag name="matplotlib">Add support for dev-python/matplotlib</flag>
<flag name="qt5">Add support for dev-python/PyQt5</flag>
</use>
</pkgmetadata>
Loading…
Cancel
Save