Browse Source

dev-libs/lief: do not allow both python and abi_x86_32 to be set

python is not multilib yet

Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
master
Andrew Ammerlaan 1 month ago
parent
commit
9ae61825c1
No known key found for this signature in database GPG Key ID: A2E2304370447E8E
  1. 4
      dev-libs/lief/lief-0.11.5.ebuild

4
dev-libs/lief/lief-0.11.5.ebuild

@ -22,8 +22,10 @@ SRC_URI="https://github.com/lief-project/LIEF/archive/${PV}.tar.gz -> ${P}.tar.g
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
# Python is not multilib yet
IUSE="c examples +python static-libs"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} !abi_x86_32 !abi_x86_x32 )"
# See "cmake/LIEFDependencies.cmake" for C and C++ dependencies.
BDEPEND="

Loading…
Cancel
Save