Browse Source

kde-plasma/libksysguard: Rebase no-detailed-mem-message.patch

Closes: https://bugs.gentoo.org/811879
Package-Manager: Portage-3.0.23, Repoman-3.0.3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
pull/895/merge
Andreas Sturmlechner 5 days ago
parent
commit
e4f5bf1508
No known key found for this signature in database GPG Key ID: 444B0F96FFD22CCB
  1. 26
      kde-plasma/libksysguard/files/libksysguard-5.16.0-no-detailed-mem-message.patch
  2. 28
      kde-plasma/libksysguard/files/libksysguard-5.22.80-no-detailed-mem-message.patch
  3. 2
      kde-plasma/libksysguard/libksysguard-9999.ebuild

26
kde-plasma/libksysguard/files/libksysguard-5.16.0-no-detailed-mem-message.patch

@ -1,26 +0,0 @@
From 49c5fdcc3bfdfedfaeaabac4f0070b986a166ce2 Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <asturm@gentoo.org>
Date: Fri, 7 Jun 2019 22:58:55 +0200
Subject: [PATCH] Gentooify message about QtWebEngineWidgets
Translations can not be provided for this.
---
processui/scripting.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/processui/scripting.cpp b/processui/scripting.cpp
index 83cf895..647194a 100644
--- a/processui/scripting.cpp
+++ b/processui/scripting.cpp
@@ -242,7 +242,7 @@ new QWebChannel(window.qt.webChannelTransport, function(channel) {
mScriptingHtmlDialog->webView()->load(fileName);
#else
QMessageBox::critical(this, i18n("QtWebEngineWidgets not available"),
- i18n("KSysGuard library was compiled without QtWebEngineWidgets, please contact your distribution."));
+ QStringLiteral("kde-plasma/libksysguard was built without USE \"webengine\" by user choice, detailed memory information not available."));
#endif
}
#if HAVE_QTWEBENGINEWIDGETS
--
2.21.0

28
kde-plasma/libksysguard/files/libksysguard-5.22.80-no-detailed-mem-message.patch

@ -0,0 +1,28 @@
From 2e2ab674038a1102081ead255a172a42d3a1d27a Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <asturm@gentoo.org>
Date: Tue, 7 Sep 2021 16:08:30 +0200
Subject: [PATCH] Gentooify message about QtWebEngineWidgets
Translations can not be provided for this.
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
---
processui/scripting.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/processui/scripting.cpp b/processui/scripting.cpp
index 1c35f72..7065cbe 100644
--- a/processui/scripting.cpp
+++ b/processui/scripting.cpp
@@ -241,7 +241,7 @@ new QWebChannel(window.qt.webChannelTransport, function(channel) {
#else
QMessageBox::critical(this,
i18n("QtWebEngineWidgets not available"),
- i18n("KSysGuard library was compiled without QtWebEngineWidgets, please contact your distribution."));
+ i18n("kde-plasma/libksysguard was built without USE \"webengine\" by user choice, detailed memory information not available."));
#endif
}
#if WEBENGINE_SCRIPTING_ENABLED
--
2.33.0

2
kde-plasma/libksysguard/libksysguard-9999.ebuild

@ -58,7 +58,7 @@ RDEPEND="${COMMON_DEPEND}
!<kde-plasma/plasma-workspace-5.18.80:5
"
PATCHES=( "${FILESDIR}/${PN}-5.16.0-no-detailed-mem-message.patch" )
PATCHES=( "${FILESDIR}/${PN}-5.22.80-no-detailed-mem-message.patch" )
src_configure() {
local mycmakeargs=(

Loading…
Cancel
Save