holgersson-overlay/net-im/toot/toot-0.47.0.ebuild
Nils Freydank 6657efeb66
net-im/toot: Improve ebuild for QA
Fixes:
  EmptyGlobalAssignment: version 0.47.0: line 31: empty global assignment: BDEPEND=""

Signed-off-by: Nils Freydank <nils.freydank@posteo.de>
2024-12-05 07:14:11 +01:00

31 lines
688 B
Bash

# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_12 )
inherit distutils-r1 pypi
DESCRIPTION="CLI/TUI mastodon client written in python"
HOMEPAGE="https://github.com/ihabunek/toot/ https://pypi.org/project/toot/"
if [[ "${PV}" == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ihabunek/toot"
fi
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
RESTRICT="test"
DEPEND="
dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/urwid[${PYTHON_USEDEP}]
dev-python/wcwidth[${PYTHON_USEDEP}]
"
RDEPEND="${DEPEND}"