Nils Freydank
0a8b7f26e7
Fixes: EmptyGlobalAssignment: version 0.1.2-r1: line 17: empty global assignment: IUSE="" Signed-off-by: Nils Freydank <nils.freydank@posteo.de>
31 lines
683 B
Bash
31 lines
683 B
Bash
# Copyright 1999-2024 Gentoo Authors
|
|
# Distributed under the terms of the GNU General Public License v2
|
|
|
|
EAPI=8
|
|
USE_RUBY="ruby31 ruby32"
|
|
|
|
RUBY_FAKEGEM_RECIPE_DOC="yard"
|
|
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
|
|
|
|
inherit ruby-fakegem
|
|
|
|
DESCRIPTION="Provides support for templates in Prawn"
|
|
HOMEPAGE="https://github.com/prawnpdf/prawn-templates"
|
|
LICENSE="|| ( GPL-2+ GPL-3 Ruby )"
|
|
SLOT="0"
|
|
KEYWORDS="~amd64"
|
|
|
|
# prawn breaks tests for some reasons, needs to be investigated; code
|
|
# still works though.
|
|
RESTRICT="test"
|
|
|
|
ruby_add_rdepend "
|
|
>=dev-ruby/pdf-reader-1.2
|
|
>=dev-ruby/prawn-0.11.1
|
|
"
|
|
|
|
ruby_add_bdepend "test? ( dev-ruby/mocha
|
|
>=dev-ruby/pdf-inspector-1.1.0
|
|
>=dev-ruby/prawn-1.3.0
|
|
)"
|