holgersson-overlay/dev-python/control/control-0.10.1.ebuild
Nils Freydank ca3b1cd8e6
dev-python/control: Bump to 0.11.1, drop ~x86
The new test dep ruff is not keyworded for ~x86.

Actually I've got no ~x86 system anymore to test,
anyways, so let's drop it here.

Signed-off-by: Nils Freydank <nils.freydank@posteo.de>
2024-08-19 05:00:00 +02:00

35 lines
768 B
Bash

# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{12..13} )
inherit distutils-r1 pypi
DESCRIPTION="Python Control Systems Library"
HOMEPAGE="
https://python-control.readthedocs.io/
https://github.com/python-control/python-control
https://pypi.org/project/control/
"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
IUSE="test"
RESTRICT="!test? ( test )"
BDEPEND="
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
dev-python/slycot[${PYTHON_USEDEP}]
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-timeout[${PYTHON_USEDEP}]
dev-util/ruff
)
"
RDEPEND="${DEPEND}"