holgersson-overlay/app-crypt/sirikali/sirikali-1.5.1.ebuild
Nils Freydank 11dd0fb3c3
*/*: Drop all KEYWORDS beside ~amd64
Currently I am only able to seriously test for ~amd64. This also
evectivly reverts the commit that added ~riscv to sys-fs/gocryptfs:
535421924b18f602b971e605782a47cf2fd522ab
2024-08-19 05:00:00 +02:00

47 lines
1003 B
Bash

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
inherit cmake
S="${WORKDIR}/SiriKali-${PV}"
DESCRIPTION="A Qt/C++ GUI front end to some encrypted filesystems and sshfs"
HOMEPAGE="
https://mhogomchungu.github.io/sirikali/
https://github.com/mhogomchungu/sirikali
"
SRC_URI="https://github.com/mhogomchungu/${PN}/releases/download/${PV}/${P}.tar.xz"
LICENSE="GPL-2+"
SLOT="0"
IUSE="gnome-keyring kwallet test"
RESTRICT="!test? ( test )"
KEYWORDS="~amd64"
DEPEND="
dev-libs/libgcrypt:0=
dev-libs/libpwquality
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtwidgets:5
gnome-keyring? ( app-crypt/libsecret )
virtual/pkgconfig
"
src_configure() {
local MY_S_FLAG=false
use kwallet && MY_S_FLAG=true
use gnome-keyring && MY_S_FLAG=true
local mycmakeargs=(
-DCMAKE_INSTALL_PREFIX=/usr
-DCMAKE_BUILD_TYPE=RELEASE
-DNOSECRETSUPPORT=${MY_S_FLAG}
-DNOKDESUPPORT=true
)
cmake_src_configure
}