app-emulation/lxd: Remove package
This commit is contained in:
parent
1a373b8c71
commit
53a60dfab0
@ -1,22 +0,0 @@
|
|||||||
-----BEGIN PGP SIGNED MESSAGE-----
|
|
||||||
Hash: SHA256
|
|
||||||
|
|
||||||
DIST lxd-3.16.tar.gz 24863601 BLAKE2B 0087c00d86ea3f623ea31bc008176e4232bb432f5c431c288f5c5ff3e1658abe4e310509088ddc6b23d8db68f8e93997522b8a5c0b19fd243abee13e11d3deb9 SHA512 11c6c5c49ceb23c31979829937e1baad340b8920481ef5b89b2b6d0b6b05967ec1f446f8b0330c11008f6fecea077eed0858af7fe802c50b52148757584fdfb9
|
|
||||||
-----BEGIN PGP SIGNATURE-----
|
|
||||||
|
|
||||||
iQKTBAEBCAB9FiEEcg3s4uUa4XE72XWQvF3CmYqtKyEFAl15G/lfFIAAAAAALgAo
|
|
||||||
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDcy
|
|
||||||
MERFQ0UyRTUxQUUxNzEzQkQ5NzU5MEJDNURDMjk5OEFBRDJCMjEACgkQvF3CmYqt
|
|
||||||
KyFEig/+K356Ua6SrgHuSN9TlzEPrZkEtf1oGQxOGKQx4Qs0Chos4/YI528xVEE8
|
|
||||||
AUeAUda0mR3U5Bl3E1PoZBkxP6yU5w1LPdJ4M/bC8ejBbZuHmixoxxTShKOJt4ph
|
|
||||||
2lyTjx4/jbE0PKeW9WdfJQOTJcqz/wtfeFmHQ1kJHqeHz1XIY1+HGa4w8OsxqAhR
|
|
||||||
bn3/fuU3Wpls46p75e0ZaDMhbSAPOthaHtd/HwK2hvg5SmVX5RUiynfuJjvyZlMk
|
|
||||||
nyn1pXmcE/FCXvj6FLAk07JiluN2NA1CkwaAYDwhT2LSJOEpKNGHYHPlZ/gnWbKp
|
|
||||||
aQBdYsitTO/U5krlH9a9UNKDS4HsN5BQ16RyxonNjn7iLbIvOZ7XjJE1b58sHD0s
|
|
||||||
8xSnk2yxFdahObUolWAgpUd00zonv2fk6q/thtuG9e2V8fRZPcUQj7mK26rRrMAC
|
|
||||||
ZeTgZPzf379QNhHv/Ffh9e49YkVqLEm5aW2pVQHUWS1St7OD9dw7HXIWUGm1nEq7
|
|
||||||
OAUnJvG935YDZGv9kt9qK1W63EK+J/9k7U6lq+OI+Znh41hzdWyycA85ibQLYEAc
|
|
||||||
86vOj/ZxdrW1s859cu0lye1d5kgMFgVZ9JUQtk8er84UA8U+aQ6+A+bF3FG+4TpH
|
|
||||||
9ZJdT470pnGeYa0YxnZwA47yXuawPy24UJK6pA5jj6zbphHqDVg=
|
|
||||||
=jo9w
|
|
||||||
-----END PGP SIGNATURE-----
|
|
@ -1,11 +0,0 @@
|
|||||||
--- /po/de.po 2018-06-27 19:57:56.759130047 -0500
|
|
||||||
+++ /po/de.po 2018-06-27 20:01:09.694634346 -0500
|
|
||||||
@@ -167,7 +167,7 @@
|
|
||||||
"###\n"
|
|
||||||
"### Each property is represented by a single line:\n"
|
|
||||||
"### An example would be:\n"
|
|
||||||
-"### description: My custom image"
|
|
||||||
+"### description: My custom image\n"
|
|
||||||
msgstr ""
|
|
||||||
"### Dies ist eine Darstellung der Eigenschaften eines Images in yaml.\n"
|
|
||||||
"### Jede Zeile die mit '# beginnt wird ignoriert.\n"
|
|
@ -1,24 +0,0 @@
|
|||||||
# Group which owns the shared socket
|
|
||||||
LXD_OPTIONS+=" --group lxd"
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
# Enable cpu profiling into the specified file
|
|
||||||
#LXD_OPTIONS+=" --cpuprofile /tmp/lxc_cpu_profile"
|
|
||||||
|
|
||||||
# Enable memory profiling into the specified file
|
|
||||||
#LXD_OPTIONS+=" --memprofile /tmp/lxc_mem_profile"
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
# Enables debug mode
|
|
||||||
#LXD_OPTIONS+=" --debug"
|
|
||||||
|
|
||||||
# For debugging, print a complete stack trace every n seconds
|
|
||||||
#LXD_OPTIONS+=" --print-goroutines 5"
|
|
||||||
|
|
||||||
# Enables verbose mode
|
|
||||||
#LXD_OPTIONS+=" --verbose"
|
|
||||||
|
|
||||||
# Logfile to log to
|
|
||||||
#LXD_OPTIONS+=" --logfile /var/log/lxd/lxd.log"
|
|
@ -1,46 +0,0 @@
|
|||||||
#!/sbin/openrc-run
|
|
||||||
# Copyright 1999-2019 Gentoo Authors
|
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
|
||||||
|
|
||||||
DAEMON=/usr/sbin/lxd
|
|
||||||
PIDFILE=/run/lxd.pid
|
|
||||||
|
|
||||||
extra_commands="stopall"
|
|
||||||
|
|
||||||
depend() {
|
|
||||||
need net
|
|
||||||
use lxcfs
|
|
||||||
}
|
|
||||||
|
|
||||||
start() {
|
|
||||||
ebegin "Starting lxd service"
|
|
||||||
|
|
||||||
start-stop-daemon --start \
|
|
||||||
--pidfile ${PIDFILE} \
|
|
||||||
--exec ${DAEMON} \
|
|
||||||
--background \
|
|
||||||
--make-pidfile \
|
|
||||||
-- \
|
|
||||||
${LXD_OPTIONS}
|
|
||||||
|
|
||||||
eend $?
|
|
||||||
}
|
|
||||||
|
|
||||||
stop() {
|
|
||||||
if [ "$RC_GOINGDOWN" = "YES" ] || [ "$RC_REBOOT" = "YES" ]; then
|
|
||||||
stopall
|
|
||||||
else
|
|
||||||
ebegin "Stopping lxd service (but not containers)"
|
|
||||||
start-stop-daemon --stop --quiet -R TERM/45 -p ${PIDFILE}
|
|
||||||
eend $?
|
|
||||||
fi
|
|
||||||
}
|
|
||||||
|
|
||||||
stopall() {
|
|
||||||
ebegin "Stopping lxd service and containers"
|
|
||||||
if "${DAEMON}" shutdown; then
|
|
||||||
/etc/init.d/lxd zap
|
|
||||||
rm -f ${PIDFILE}
|
|
||||||
fi
|
|
||||||
eend $?
|
|
||||||
}
|
|
@ -1,10 +0,0 @@
|
|||||||
[Unit]
|
|
||||||
Description=Container hypervisor based on LXC
|
|
||||||
|
|
||||||
[Service]
|
|
||||||
ExecStart=/usr/sbin/lxd --group lxd
|
|
||||||
KillMode=process
|
|
||||||
Restart=on-failure
|
|
||||||
|
|
||||||
[Install]
|
|
||||||
WantedBy=multi-user.target
|
|
@ -1,19 +0,0 @@
|
|||||||
--- /po/pt_BR.po.orig 2018-10-13 23:27:01.523645894 -0500
|
|
||||||
+++ /po/pt_BR.po 2018-10-13 23:28:04.730644762 -0500
|
|
||||||
@@ -95,7 +95,6 @@
|
|
||||||
"###\n"
|
|
||||||
"### Note that the name is shown but cannot be changed"
|
|
||||||
msgstr ""
|
|
||||||
-"\n"
|
|
||||||
"### Esta é uma representação em yaml da configuração.\n"
|
|
||||||
"### Qualquer linha começando com '#' será ignorada.\n"
|
|
||||||
"###\n"
|
|
||||||
@@ -112,7 +111,7 @@
|
|
||||||
"### type: disk\n"
|
|
||||||
"### ephemeral: false\n"
|
|
||||||
"###\n"
|
|
||||||
-"### Observe que o nome é exibido mas não pode ser modificado\n"
|
|
||||||
+"### Observe que o nome é exibido mas não pode ser modificado"
|
|
||||||
|
|
||||||
#: lxc/config_metadata.go:63
|
|
||||||
msgid ""
|
|
@ -1,263 +0,0 @@
|
|||||||
# Copyright 1999-2019 Gentoo Authors
|
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
|
||||||
|
|
||||||
EAPI=7
|
|
||||||
|
|
||||||
DESCRIPTION="Fast, dense and secure container management"
|
|
||||||
HOMEPAGE="https://linuxcontainers.org/lxd/introduction/"
|
|
||||||
|
|
||||||
LICENSE="Apache-2.0 BSD BSD-2 LGPL-3 MIT MPL-2.0"
|
|
||||||
SLOT="0"
|
|
||||||
KEYWORDS="~amd64"
|
|
||||||
|
|
||||||
IUSE="+daemon +ipv6 +dnsmasq nls test tools"
|
|
||||||
|
|
||||||
inherit autotools bash-completion-r1 linux-info systemd user
|
|
||||||
|
|
||||||
SRC_URI="https://linuxcontainers.org/downloads/${PN}/${P}.tar.gz"
|
|
||||||
|
|
||||||
DEPEND="
|
|
||||||
dev-lang/tcl
|
|
||||||
>=dev-lang/go-1.9.4
|
|
||||||
dev-libs/libuv
|
|
||||||
dev-libs/protobuf
|
|
||||||
nls? ( sys-devel/gettext )
|
|
||||||
test? (
|
|
||||||
app-misc/jq
|
|
||||||
net-misc/curl
|
|
||||||
sys-devel/gettext
|
|
||||||
)
|
|
||||||
"
|
|
||||||
|
|
||||||
RDEPEND="
|
|
||||||
daemon? (
|
|
||||||
app-arch/xz-utils
|
|
||||||
>=app-emulation/lxc-2.0.7[seccomp]
|
|
||||||
dev-libs/libuv
|
|
||||||
dev-libs/lzo
|
|
||||||
dev-util/xdelta:3
|
|
||||||
dnsmasq? (
|
|
||||||
net-dns/dnsmasq[dhcp,ipv6?]
|
|
||||||
)
|
|
||||||
net-libs/libnfnetlink
|
|
||||||
net-libs/libnsl:0=
|
|
||||||
net-misc/rsync[xattr]
|
|
||||||
sys-apps/iproute2[ipv6?]
|
|
||||||
sys-fs/fuse
|
|
||||||
sys-fs/lxcfs
|
|
||||||
sys-fs/squashfs-tools
|
|
||||||
virtual/acl
|
|
||||||
)
|
|
||||||
"
|
|
||||||
|
|
||||||
CONFIG_CHECK="
|
|
||||||
~BRIDGE
|
|
||||||
~DUMMY
|
|
||||||
~IP6_NF_NAT
|
|
||||||
~IP6_NF_TARGET_MASQUERADE
|
|
||||||
~IPV6
|
|
||||||
~IP_NF_NAT
|
|
||||||
~IP_NF_TARGET_MASQUERADE
|
|
||||||
~MACVLAN
|
|
||||||
~NETFILTER_XT_MATCH_COMMENT
|
|
||||||
~NET_IPGRE
|
|
||||||
~NET_IPGRE_DEMUX
|
|
||||||
~NET_IPIP
|
|
||||||
~NF_NAT_MASQUERADE_IPV4
|
|
||||||
~NF_NAT_MASQUERADE_IPV6
|
|
||||||
~VXLAN
|
|
||||||
"
|
|
||||||
|
|
||||||
ERROR_BRIDGE="BRIDGE: needed for network commands"
|
|
||||||
ERROR_DUMMY="DUMMY: needed for network commands"
|
|
||||||
ERROR_IP6_NF_NAT="IP6_NF_NAT: needed for network commands"
|
|
||||||
ERROR_IP6_NF_TARGET_MASQUERADE="IP6_NF_TARGET_MASQUERADE: needed for network commands"
|
|
||||||
ERROR_IPV6="IPV6: needed for network commands"
|
|
||||||
ERROR_IP_NF_NAT="IP_NF_NAT: needed for network commands"
|
|
||||||
ERROR_IP_NF_TARGET_MASQUERADE="IP_NF_TARGET_MASQUERADE: needed for network commands"
|
|
||||||
ERROR_MACVLAN="MACVLAN: needed for network commands"
|
|
||||||
ERROR_NETFILTER_XT_MATCH_COMMENT="NETFILTER_XT_MATCH_COMMENT: needed for network commands"
|
|
||||||
ERROR_NET_IPGRE="NET_IPGRE: needed for network commands"
|
|
||||||
ERROR_NET_IPGRE_DEMUX="NET_IPGRE_DEMUX: needed for network commands"
|
|
||||||
ERROR_NET_IPIP="NET_IPIP: needed for network commands"
|
|
||||||
ERROR_NF_NAT_MASQUERADE_IPV4="NF_NAT_MASQUERADE_IPV4: needed for network commands"
|
|
||||||
ERROR_NF_NAT_MASQUERADE_IPV6="NF_NAT_MASQUERADE_IPV6: needed for network commands"
|
|
||||||
ERROR_VXLAN="VXLAN: needed for network commands"
|
|
||||||
|
|
||||||
EGO_PN="github.com/lxc/lxd"
|
|
||||||
|
|
||||||
src_prepare() {
|
|
||||||
eapply_user
|
|
||||||
eapply "${FILESDIR}/de-translation-newline-1.patch"
|
|
||||||
|
|
||||||
cd "${S}/_dist/deps/raft" || die "Can't cd to raft dir"
|
|
||||||
# Workaround for " * ACCESS DENIED: open_wr: /dev/zfs"
|
|
||||||
sed -i 's#zfs version | cut -f 2#< /sys/module/zfs/version cut -f 1#' configure.ac || die "Can't sed configure.ac for raft"
|
|
||||||
eautoreconf
|
|
||||||
|
|
||||||
cd "${S}/_dist/deps/dqlite" || die "Can't cd to dqlite dir"
|
|
||||||
eautoreconf
|
|
||||||
|
|
||||||
}
|
|
||||||
|
|
||||||
src_configure() {
|
|
||||||
export GOPATH="${S}/_dist"
|
|
||||||
cd "${GOPATH}/deps/sqlite" || die "Can't cd to sqlite dir"
|
|
||||||
econf --enable-replication --disable-amalgamation --disable-tcl --libdir="${EPREFIX}/usr/lib/lxd"
|
|
||||||
|
|
||||||
cd "${GOPATH}/deps/raft" || die "Can't cd to raft dir"
|
|
||||||
PKG_CONFIG_PATH="${GOPATH}/raft/" econf --libdir=${EPREFIX}/usr/lib/lxd
|
|
||||||
|
|
||||||
cd "${GOPATH}/deps/dqlite" || die "Can't cd to dqlite dir"
|
|
||||||
export RAFT_CFLAGS="-I${GOPATH}/deps/raft/include/"
|
|
||||||
export RAFT_LIBS="${GOPATH}/deps/raft/.libs"
|
|
||||||
export CO_CFLAGS="-I${GOPATH}/deps/libco/"
|
|
||||||
export CO_LIBS="${GOPATH}/deps/libco/"
|
|
||||||
PKG_CONFIG_PATH="${GOPATH}/sqlite/" econf --libdir=${EPREFIX}/usr/lib/lxd
|
|
||||||
}
|
|
||||||
|
|
||||||
src_compile() {
|
|
||||||
export GOPATH="${S}/_dist"
|
|
||||||
|
|
||||||
cd "${GOPATH}/deps/sqlite" || die "Can't cd to sqlite dir"
|
|
||||||
emake
|
|
||||||
|
|
||||||
cd "${GOPATH}/deps/raft" || die "Can't cd to raft dir"
|
|
||||||
emake
|
|
||||||
|
|
||||||
cd "${GOPATH}/deps/libco" || die "Can't cd to libco dir"
|
|
||||||
emake
|
|
||||||
|
|
||||||
cd "${GOPATH}/deps/dqlite" || die "Can't cd to dqlite dir"
|
|
||||||
emake CFLAGS="-I${GOPATH}/deps/sqlite -I${GOPATH}/deps/raft/include" LDFLAGS="-L${GOPATH}/deps/sqlite -L${GOPATH}/deps/raft"
|
|
||||||
|
|
||||||
# We don't use the Makefile here because it builds targets with the
|
|
||||||
# assumption that `pwd` is in a deep gopath namespace, which we're not.
|
|
||||||
# It's simpler to manually call "go install" than patching the Makefile.
|
|
||||||
cd "${S}"
|
|
||||||
go install -v -x ${EGO_PN}/lxc || die "Failed to build the client"
|
|
||||||
|
|
||||||
if use daemon; then
|
|
||||||
|
|
||||||
# LXD depends on a patched, bundled sqlite with replication
|
|
||||||
# capabilities.
|
|
||||||
export CGO_CFLAGS="${CGO_CFLAGS} -I${GOPATH}/deps/sqlite/ -I${GOPATH}/deps/dqlite/include/ -I${GOPATH}/deps/raft/include/ -I${GOPATH}/deps/libco/"
|
|
||||||
export CGO_LDFLAGS="${CGO_LDFLAGS} -L${GOPATH}/deps/sqlite/.libs/ -L${GOPATH}/deps/dqlite/.libs/ -L${GOPATH}/deps/raft/.libs -L${GOPATH}/deps/libco/ -Wl,-rpath,${EPREFIX}/usr/lib/lxd"
|
|
||||||
export LD_LIBRARY_PATH="${GOPATH}/deps/sqlite/.libs/:${GOPATH}/deps/dqlite/.libs/:${GOPATH}/deps/raft/.libs:${GOPATH}/deps/libco/:${LD_LIBRARY_PATH}"
|
|
||||||
|
|
||||||
go install -v -x -tags libsqlite3 ${EGO_PN}/lxd || die "Failed to build the daemon"
|
|
||||||
fi
|
|
||||||
|
|
||||||
if use tools; then
|
|
||||||
go install -v -x ${EGO_PN}/fuidshift || die "Failed to build fuidshift"
|
|
||||||
go install -v -x ${EGO_PN}/lxc-to-lxd || die "Failed to build lxc-to-lxd"
|
|
||||||
go install -v -x ${EGO_PN}/lxd-benchmark || die "Failed to build lxd-benchmark"
|
|
||||||
go install -v -x ${EGO_PN}/lxd-p2c || die "Failed to build lxd-p2c"
|
|
||||||
fi
|
|
||||||
|
|
||||||
use nls && emake build-mo
|
|
||||||
}
|
|
||||||
|
|
||||||
src_test() {
|
|
||||||
if use daemon; then
|
|
||||||
export GOPATH="${S}/_dist"
|
|
||||||
# This is mostly a copy/paste from the Makefile's "check" rule, but
|
|
||||||
# patching the Makefile to work in a non "fully-qualified" go namespace
|
|
||||||
# was more complicated than this modest copy/paste.
|
|
||||||
# Also: sorry, for now a network connection is needed to run tests.
|
|
||||||
# Will properly bundle test dependencies later.
|
|
||||||
go get -v -x github.com/rogpeppe/godeps
|
|
||||||
go get -v -x github.com/remyoudompheng/go-misc/deadcode
|
|
||||||
go get -v -x github.com/golang/lint/golint
|
|
||||||
go test -v ${EGO_PN}/lxd
|
|
||||||
else
|
|
||||||
einfo "No tests to run for client-only builds"
|
|
||||||
fi
|
|
||||||
}
|
|
||||||
|
|
||||||
src_install() {
|
|
||||||
local bindir="_dist/bin"
|
|
||||||
dobin ${bindir}/lxc
|
|
||||||
if use daemon; then
|
|
||||||
|
|
||||||
export GOPATH="${S}/_dist"
|
|
||||||
cd "${GOPATH}/deps/sqlite" || die "Can't cd to sqlite dir"
|
|
||||||
emake DESTDIR="${D}" install
|
|
||||||
|
|
||||||
cd "${GOPATH}/deps/raft" || die "Can't cd to raft dir"
|
|
||||||
emake DESTDIR="${D}" install
|
|
||||||
|
|
||||||
cd "${GOPATH}/deps/libco" || die "Can't cd to libco dir"
|
|
||||||
dolib.so libco.so || die "Can't install libco.so"
|
|
||||||
|
|
||||||
cd "${GOPATH}/deps/dqlite" || die "Can't cd to dqlite dir"
|
|
||||||
emake DESTDIR="${D}" install
|
|
||||||
|
|
||||||
# Must only install libs
|
|
||||||
rm "${D}/usr/bin/sqlite3" || die "Can't remove custom sqlite3 binary"
|
|
||||||
rm -r "${D}/usr/include" || die "Can't remove include directory"
|
|
||||||
|
|
||||||
cd "${S}" || die "Can't cd to \${S}"
|
|
||||||
dosbin ${bindir}/lxd
|
|
||||||
fi
|
|
||||||
|
|
||||||
if use tools; then
|
|
||||||
dobin ${bindir}/fuidshift
|
|
||||||
dobin ${bindir}/lxc-to-lxd
|
|
||||||
dobin ${bindir}/lxd-benchmark
|
|
||||||
dobin ${bindir}/lxd-p2c
|
|
||||||
fi
|
|
||||||
|
|
||||||
if use nls; then
|
|
||||||
domo po/*.mo
|
|
||||||
fi
|
|
||||||
|
|
||||||
if use daemon; then
|
|
||||||
newinitd "${FILESDIR}"/${PN}.initd lxd
|
|
||||||
newconfd "${FILESDIR}"/${PN}.confd lxd
|
|
||||||
|
|
||||||
systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
|
|
||||||
fi
|
|
||||||
|
|
||||||
newbashcomp scripts/bash/lxd-client lxc
|
|
||||||
|
|
||||||
dodoc AUTHORS doc/*
|
|
||||||
}
|
|
||||||
|
|
||||||
pkg_postinst() {
|
|
||||||
elog
|
|
||||||
elog "Consult https://wiki.gentoo.org/wiki/LXD for more information,"
|
|
||||||
elog "including a Quick Start."
|
|
||||||
|
|
||||||
# The messaging below only applies to daemon installs
|
|
||||||
use daemon || return 0
|
|
||||||
|
|
||||||
# The control socket will be owned by (and writeable by) this group.
|
|
||||||
enewgroup lxd
|
|
||||||
|
|
||||||
# Ubuntu also defines an lxd user but it appears unused (the daemon
|
|
||||||
# must run as root)
|
|
||||||
|
|
||||||
elog
|
|
||||||
elog "Though not strictly required, some features are enabled at run-time"
|
|
||||||
elog "when the relevant helper programs are detected:"
|
|
||||||
elog "- sys-apps/apparmor"
|
|
||||||
elog "- sys-fs/btrfs-progs"
|
|
||||||
elog "- sys-fs/lvm2"
|
|
||||||
elog "- sys-fs/zfs"
|
|
||||||
elog "- sys-process/criu"
|
|
||||||
elog
|
|
||||||
elog "Since these features can't be disabled at build-time they are"
|
|
||||||
elog "not USE-conditional."
|
|
||||||
elog
|
|
||||||
elog "Be sure to add your local user to the lxd group."
|
|
||||||
elog
|
|
||||||
elog "Networks with bridge.mode=fan are unsupported due to requiring"
|
|
||||||
elog "a patched kernel and iproute2."
|
|
||||||
}
|
|
||||||
|
|
||||||
# TODO:
|
|
||||||
# - man page, I don't see cobra generating it
|
|
||||||
# - maybe implement LXD_CLUSTER_UPDATE per
|
|
||||||
# https://discuss.linuxcontainers.org/t/lxd-3-5-has-been-released/2656
|
|
||||||
# EM I'm not convinced it's a good design.
|
|
@ -1,40 +0,0 @@
|
|||||||
<?xml version="1.0" encoding="UTF-8"?>
|
|
||||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
|
||||||
<pkgmetadata>
|
|
||||||
<maintainer type="person">
|
|
||||||
<email>holgersson@posteo.de</email>
|
|
||||||
<name>Nils Freydank</name>
|
|
||||||
</maintainer>
|
|
||||||
<maintainer type="person">
|
|
||||||
<email>stasibear@gentoo.org</email>
|
|
||||||
<name>Erik Mackdanz</name>
|
|
||||||
</maintainer>
|
|
||||||
<maintainer type="person">
|
|
||||||
<email>vdupras@gentoo.org</email>
|
|
||||||
<name>Virgil Dupras</name>
|
|
||||||
</maintainer>
|
|
||||||
<maintainer type="project">
|
|
||||||
<email>virtualization@gentoo.org</email>
|
|
||||||
<name>Gentoo Virtualization Project</name>
|
|
||||||
</maintainer>
|
|
||||||
<longdescription>
|
|
||||||
By combining the speed and density of containers with
|
|
||||||
the security of traditional virtual machines, LXD is
|
|
||||||
the next-generation of container hypervisor for Linux
|
|
||||||
from Canonical.
|
|
||||||
</longdescription>
|
|
||||||
<upstream>
|
|
||||||
<remote-id type="github">lxc/lxd</remote-id>
|
|
||||||
</upstream>
|
|
||||||
<use>
|
|
||||||
<flag name="daemon">
|
|
||||||
Build the system daemon, not just the client tool
|
|
||||||
</flag>
|
|
||||||
<flag name="dnsmasq">
|
|
||||||
Depend on dnsmasq to provide DHCP and DNS
|
|
||||||
</flag>
|
|
||||||
<flag name="tools">
|
|
||||||
Build and install optional tools
|
|
||||||
</flag>
|
|
||||||
</use>
|
|
||||||
</pkgmetadata>
|
|
Loading…
Reference in New Issue
Block a user