app-text/zeal: Drop in-tree package

The package was bumped, dropping it from my overlay.

Signed-off-by: Nils Freydank <nils.freydank@posteo.de>
This commit is contained in:
Nils Freydank 2024-10-12 19:46:22 +02:00
parent 4b02cb396f
commit 3b33b60452
Signed by: nfr
GPG Key ID: 0F1DEAB2D36AD112
5 changed files with 0 additions and 155 deletions

View File

@ -1 +0,0 @@
DIST zeal-0.7.1.tar.gz 1201104 BLAKE2B fe9b9cd44f4a946e0de91b37b3336783ae40fdf5faa1230d7b3ce45c44f62e52deec93087fe49922da83e38c9bb0e1e95f1269ed7f8e42efc3e0d740a5d60566 SHA512 8d831aaf4d43e55c60b065beda59e7f8377c4aa778f22e4ddc81d025eeb2d90abe6ffd4e26918a61db374b97ba1236a41b55bce8916b22f55f7394fb266d7543

View File

@ -1,30 +0,0 @@
From d2d95443fcd9f79b70568513412c289219e5afdc Mon Sep 17 00:00:00 2001
From: Nils Freydank <holgersson@posteo.de>
Date: Sat, 23 Mar 2024 19:00:00 +0100
Subject: [PATCH] CMakeLists: Disable -Werror
Gentoo policy is to disable -Werror by default,
see e.g. https://bugs.gentoo.org/926121.
Signed-off-by: Nils Freydank <holgersson@posteo.de>
---
CMakeLists.txt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a6a31c6..4a9a86f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,7 +60,8 @@ add_custom_target(zeal_version
)
if(${CMAKE_VERSION} VERSION_GREATER_EQUAL "3.24.0")
- set(CMAKE_COMPILE_WARNING_AS_ERROR ON)
+ # Upstream is slightly insane.
+ set(CMAKE_COMPILE_WARNING_AS_ERROR OFF)
endif()
add_subdirectory(assets)
--
2.44.0

View File

@ -1,32 +0,0 @@
From dfaa23858280861b9a6d4dc869b98293168ff467 Mon Sep 17 00:00:00 2001
From: Nils Freydank <nils.freydank@posteo.de>
Date: Sat, 23 Mar 2024 19:00:00 +0100
Subject: [PATCH] settings: disable checking for updates by default
Do not query the servers for updates by default on every
startup. The user can still enable this via GUI if desired.
This patch is nearly 1:1 the patch by Henning Schild from 2019-05-09.
Signed-off-by: Nils Freydank <holgersson@posteo.de>
---
src/libs/core/settings.cpp | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/src/libs/core/settings.cpp b/src/libs/core/settings.cpp
index 8bcc6e6..bd81153 100644
--- a/src/libs/core/settings.cpp
+++ b/src/libs/core/settings.cpp
@@ -95,7 +95,8 @@ void Settings::load()
// TODO: Put everything in groups
startMinimized = settings->value(QStringLiteral("start_minimized"), false).toBool();
- checkForUpdate = settings->value(QStringLiteral("check_for_update"), true).toBool();
+ // Disabled by default on Gentoo/Linux via custom patch.
+ checkForUpdate = settings->value(QStringLiteral("check_for_update"), false).toBool();
showSystrayIcon = settings->value(QStringLiteral("show_systray_icon"), true).toBool();
minimizeToSystray = settings->value(QStringLiteral("minimize_to_systray"), false).toBool();
--
2.44.0

View File

@ -1,11 +0,0 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>nils.freydank@posteo.de</email>
<name>Nils Freydank</name>
</maintainer>
<upstream>
<remote-id type="github">zealdocs/zeal</remote-id>
</upstream>
</pkgmetadata>

View File

@ -1,81 +0,0 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake xdg-utils
MY_PV="${PV/_rc/-RC}"
COMMIT_ID="7f938cf4e87b22abc5efd4155b78ea8127eefc4b"
DESCRIPTION="Offline documentation browser inspired by Dash"
HOMEPAGE="
https://zealdocs.org
https://github.com/zealdocs/zeal
"
LICENSE="GPL-3"
if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/zealdocs/${PN}.git"
inherit git-r3
else
if [[ ${PV} == *_p* ]]; then
SRC_URI="https://github.com/zealdocs/${PN}/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${COMMIT_ID}"
else
SRC_URI="https://github.com/zealdocs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/$PN-${MY_PV}/"
fi
fi
KEYWORDS="~amd64"
SLOT="0"
IUSE=""
DEPEND="
app-arch/libarchive:=
dev-db/sqlite:3
dev-qt/qtbase:6[concurrent,gui,network,sqlite,widgets]
dev-qt/qtwebengine:6[widgets]
dev-qt/qtwebchannel:6
x11-libs/libX11
x11-libs/libxcb:=
x11-libs/xcb-util-keysyms
"
RDEPEND="${DEPEND}
x11-themes/hicolor-icon-theme
"
BDEPEND="kde-frameworks/extra-cmake-modules:0"
PATCHES=(
"${FILESDIR}/${PN}-0.7.0-settings-disable-checking-for-updates-by-default.patch"
"${FILESDIR}/${PN}-0.7.0-CMakeLists-Disable-Werror.patch"
)
src_configure() {
local mycmakeargs=(
-D QT_DIR=/usr/$(get_libdir)/cmake/Qt6
-D CMAKE_BUILD_TYPE=Release
# Default string is ${PV}-dev when self-compiled, even from releases.
-D ZEAL_VERSION=${PV}-gentoo
)
cmake_src_configure
}
pkg_postinst() {
xdg_icon_cache_update
xdg_desktop_database_update
if [[ -z "${REPLACING_VERSIONS}" ]]; then
elog ""
elog "If you are interested in dash cheat sheets, you will need to add the XML links"
elog "manually from https://zealusercontributions.vercel.app/cheatsheets."
elog "For details see the upstream issue:"
elog "https://github.com/zealdocs/zeal/issues/498#issuecomment-1848423041"
fi
}
pkg_postrm() {
xdg_icon_cache_update
xdg_desktop_database_update
}