net-mail/urlscan: Bump to 1.0.0, use man page from github.com

The pypi archive has no man page bundled, but the gh archives fail to build,
so let's pull the archive from pypi and the single manpage file from
github.com.

Signed-off-by: Nils Freydank <nils.freydank@posteo.de>
This commit is contained in:
Nils Freydank 2023-06-11 15:09:41 +02:00
parent 6e1b22dcca
commit 1abf627db4
Signed by: nfr
GPG Key ID: 0F1DEAB2D36AD112
3 changed files with 33 additions and 5 deletions

View File

@ -1 +1,2 @@
DIST urlscan-0.9.10.tar.gz 39048 BLAKE2B 3046a273995218a15181db0e94217d06f4294ca334ca3e3cb2d2cae73d222501d32f3720c411277a3e5f889175df8702d217b23eb16f220d8a6549e7a2c7ff1a SHA512 8eb152b83d1f39f776d9a42ef375f80cce2348a59f74dd9a80862c0d756f6ffe5992f61fe5d89fc675fdb4e2d8661b7c7b4744d3908df4e3888b8ec36d50eb1c
DIST urlscan-1.0.0-manpage 7322 BLAKE2B b26b5bf94fd380611413289ace1d4a6ed2c980b1d598e36f7565a252ce6987f55bfb9541fbe9be4132185b2ec685f5ee48ed21e52d746ceba416edbd03d9cad7 SHA512 79543005fd69b417005b11edfdef94afddb77dedecca6f9bedd2d97e792150ff97b513709adbe8a2036e8945ff2333e668b2b8c4c42a89519e22b1c8fb544ab5
DIST urlscan-1.0.0.tar.gz 32733 BLAKE2B 4c116b5a73f0da28b6da85abba2c33230d2375f548837b16b10709a552a4cc885c16c3c3b139b6c3c1bc8b9ea79619ba0a598c84f6975a5abdeafe4abd77b889 SHA512 b13b92ccadb2e443601a99acca998a661c9e834452b1aff83ab2d6011c0f8937d9b9b353a3e5a61da694bfe7b9381624eb023dd18d990d0cddc7cc192a04dd89

View File

@ -0,0 +1,18 @@
# Nils Freydank <holgersson@posteo.de> (2023-06-11)
Respect the gentoo paths for documentation - i.e. manual
installation of the documents.
Updating the patch from 2021-10-06 using setup.py to pyproject.toml
--- a/pyproject.toml 2023-06-11 14:30:00.000000000 +0200
+++ b/pyproject.toml 2023-06-11 14:30.00.000000001 +0200
@@ -49,8 +49,6 @@
version-file = "urlscan/_version.py"
[tool.hatch.build.targets.wheel.shared-data]
-LICENSE = "share/doc/urlscan/LICENSE"
-"README.md" = "share/doc/urlscan/README.md"
"urlscan.1" = "share/man/man1/urlscan.1"
[tool.hatch.build.targets.sdist]

View File

@ -3,16 +3,18 @@
EAPI="8"
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )
DISTUTILS_USE_PEP517=hatchling
PYTHON_COMPAT=( python3_11 )
inherit distutils-r1 pypi
DESCRIPTION="Mutt and terminal url selector (similar to urlview)"
HOMEPAGE="
https://github.com/firecat53/urlscan
https://pypi.org/project/urlscan
https://pypi.org/project/urlscan/
"
SRC_URI+=" https://raw.githubusercontent.com/firecat53/urlscan/1.0.0/urlscan.1 -> ${P}-manpage"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@ -23,4 +25,11 @@ RDEPEND="${DEPEND}"
BDEPEND=""
DOCS=( README.md )
PATCHES=( "${FILESDIR}/${PN}-0.9.7-respect-paths.patch" )
PATCHES=( "${FILESDIR}/${PN}-1.0.0-respect-paths.patch" )
src_install() {
default
distutils-r1_src_install
newman "${DISTDIR}/${P}-manpage" "${PN}.1"
}