22 lines
1.1 KiB
Diff
22 lines
1.1 KiB
Diff
Prevent build system with messing up LD_LIBRARY_PATH
|
|
--- a/src/Makefile.am
|
|
+++ b/src/Makefile.am
|
|
@@ -125,8 +125,6 @@ settings_DATA=libhdf5.settings
|
|
# Remove the generated .c file if errors occur unless HDF5_Make_Ignore
|
|
# is set to ignore the error.
|
|
H5Tinit.c: H5detect$(EXEEXT)
|
|
- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
|
|
- sed -e 's/-L/:/g' -e 's/ //g'`" \
|
|
$(RUNSERIAL) ./H5detect$(EXEEXT) > $@ || \
|
|
(test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
|
|
($(RM) $@ ; exit 1)
|
|
@@ -137,8 +135,6 @@ H5Tinit.c: H5detect$(EXEEXT)
|
|
# Remove the generated .c file if errors occur unless HDF5_Make_Ignore
|
|
# is set to ignore the error.
|
|
H5lib_settings.c: H5make_libsettings$(EXEEXT) libhdf5.settings
|
|
- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
|
|
- sed -e 's/-L/:/g' -e 's/ //g'`" \
|
|
$(RUNSERIAL) ./H5make_libsettings$(EXEEXT) > $@ || \
|
|
(test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
|
|
($(RM) $@ ; exit 1)
|