1
0
mirror of synced 2024-06-13 16:09:59 +02:00
TheChymera-overlay/sci-libs/itk/files/nrrdio-linking.patch
Horea Christian 389efa4b90
sci-libs/itk: dep change ahead of Gentoo Science
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Horea Christian <chr@chymera.eu>
2019-05-18 03:37:33 +02:00

16 lines
582 B
Diff

Description: Link libITKNrrdIO with -lm (needed for sqrt)
Author: Steve Robbins <smr@debian.org>
Forwarded: no
--- insighttoolkit4-4.5.0.orig/Modules/ThirdParty/NrrdIO/src/NrrdIO/CMakeLists.txt
+++ insighttoolkit4-4.5.0/Modules/ThirdParty/NrrdIO/src/NrrdIO/CMakeLists.txt
@@ -64,7 +64,7 @@
ADD_DEFINITIONS(-DTEEM_ZLIB=1)
ADD_LIBRARY(ITKNrrdIO ${nrrdio_SRCS} )
-TARGET_LINK_LIBRARIES(ITKNrrdIO ${ITKZLIB_LIBRARIES})
+TARGET_LINK_LIBRARIES(ITKNrrdIO ${ITKZLIB_LIBRARIES} -lm)
IF(ITK_LIBRARY_PROPERTIES)
SET_TARGET_PROPERTIES(ITKNrrdIO PROPERTIES ${ITK_LIBRARY_PROPERTIES})