d791d3d0fa
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Horea Christian <horea.christ@yandex.com>
33 lines
1.3 KiB
Diff
33 lines
1.3 KiB
Diff
Index: scikit-learn-0.18.1/sklearn/_build_utils/__init__.py
|
|
===================================================================
|
|
--- scikit-learn-0.18.1.orig/sklearn/_build_utils/__init__.py
|
|
+++ scikit-learn-0.18.1/sklearn/_build_utils/__init__.py
|
|
@@ -31,7 +31,7 @@ def get_blas_info():
|
|
return False
|
|
|
|
blas_info = get_info('blas_opt', 0)
|
|
- if (not blas_info) or atlas_not_found(blas_info):
|
|
+ if (not blas_info):
|
|
cblas_libs = ['cblas']
|
|
blas_info.pop('libraries', None)
|
|
else:
|
|
Index: scikit-learn-0.18.1/sklearn/setup.py
|
|
===================================================================
|
|
--- scikit-learn-0.18.1.orig/sklearn/setup.py
|
|
+++ scikit-learn-0.18.1/sklearn/setup.py
|
|
@@ -63,14 +63,6 @@ def configuration(parent_package='', top
|
|
libraries=libraries,
|
|
)
|
|
|
|
- # some libs needs cblas, fortran-compiled BLAS will not be sufficient
|
|
- blas_info = get_info('blas_opt', 0)
|
|
- if (not blas_info) or (
|
|
- ('NO_ATLAS_INFO', 1) in blas_info.get('define_macros', [])):
|
|
- config.add_library('cblas',
|
|
- sources=[join('src', 'cblas', '*.c')])
|
|
- warnings.warn(BlasNotFoundError.__doc__)
|
|
-
|
|
# the following packages depend on cblas, so they have to be build
|
|
# after the above.
|
|
config.add_subpackage('linear_model')
|