1
0
Fork 0
TheChymera-overlay/sci-libs/scikits_learn/files/scikits_learn-0.14.1-system...

29 lines
1.0 KiB
Diff

--- sklearn/setup.py.orig 2013-08-08 13:54:08.310879167 -0700
+++ sklearn/setup.py 2013-08-08 13:52:59.808456423 -0700
@@ -68,14 +68,6 @@
libraries=libraries,
)
- # some libs needs cblas, fortran-compiled BLAS will not be sufficient
- blas_info = get_info('blas_opt', 0)
- if (not blas_info) or (
- ('NO_ATLAS_INFO', 1) in blas_info.get('define_macros', [])):
- config.add_library('cblas',
- sources=[join('src', 'cblas', '*.c')])
- warnings.warn(BlasNotFoundError.__doc__)
-
# the following packages depend on cblas, so they have to be build
# after the above.
config.add_subpackage('linear_model')
--- sklearn/_build_utils.py.orig 2013-08-08 14:01:35.994589269 -0700
+++ sklearn/_build_utils.py 2013-08-08 12:19:41.875967870 -0700
@@ -23,7 +23,7 @@
return False
blas_info = get_info('blas_opt', 0)
- if (not blas_info) or atlas_not_found(blas_info):
+ if (not blas_info):
cblas_libs = ['cblas']
blas_info.pop('libraries', None)
else: