1
0
mirror of synced 2024-06-23 21:02:53 +02:00
TheChymera-overlay/sci-libs/pytorch/files/pytorch-1.4.0-sleef.patch
Horea Christian 61db1849ca
sci-libs/pytorch: fix ahead of Gentoo Science
Bug: https://bugs.gentoo.org/738592
Package-Manager: Portage-3.0.2, Repoman-2.3.23
Signed-off-by: Horea Christian <chr@chymera.eu>
2020-08-23 04:12:34 -04:00

16 lines
796 B
Diff

Give the location of sleef.h.
Reference: https://github.com/pytorch/pytorch/issues/26555
Index: pytorch-1.4.0/caffe2/CMakeLists.txt
===================================================================
--- pytorch-1.4.0.orig/caffe2/CMakeLists.txt
+++ pytorch-1.4.0/caffe2/CMakeLists.txt
@@ -1062,6 +1062,7 @@ if (BUILD_TEST)
add_executable(${test_name} "${test_src}")
target_link_libraries(${test_name} ${Caffe2_MAIN_LIBS} gtest_main)
target_include_directories(${test_name} PRIVATE $<INSTALL_INTERFACE:include>)
+ target_include_directories(${test_name} PRIVATE $<BUILD_INTERFACE:${CMAKE_BINARY_DIR}/include>)
target_include_directories(${test_name} PRIVATE ${Caffe2_CPU_INCLUDE})
add_test(NAME ${test_name} COMMAND $<TARGET_FILE:${test_name}>)
if (INSTALL_TEST)