1
0
Fork 0
TheChymera-overlay/dev-python/pypubsub/pypubsub-4.0.3.ebuild

29 lines
575 B
Bash

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
DESCRIPTION="A Python publish-subcribe library"
HOMEPAGE="https://github.com/schollii/pypubsub/"
SRC_URI="
https://github.com/schollii/pypubsub/archive/v${PV}.tar.gz -> ${P}.tar.gz
"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
RDEPEND=""
python_test() {
distutils_install_for_testing
cd "tests/suite" || die
pytest -vv || die
}