dev-python/spikeextractors: new package (DANDI ephys stack)
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Horea Christian <chr@chymera.eu>
This commit is contained in:
parent
6a385ce253
commit
ef6f025872
6
dev-python/spikeextractors/ChangeLog
Normal file
6
dev-python/spikeextractors/ChangeLog
Normal file
@ -0,0 +1,6 @@
|
||||
*spikeextractors-0.9.7 (14 Oct 2021)
|
||||
|
||||
14 Oct 2021; <chymera@gentoo.org> +.spikeinterface-0.10.0.ebuild.swp,
|
||||
+files/spikeextractors-0.9.7-no-test-install.patch, +metadata.xml,
|
||||
+spikeextractors-0.9.7.ebuild:
|
||||
dev-python/spikeextractors: new package (DANDI ephys stack)
|
1
dev-python/spikeextractors/Manifest
Normal file
1
dev-python/spikeextractors/Manifest
Normal file
@ -0,0 +1 @@
|
||||
DIST spikeextractors-0.9.7.tar.gz 132128 SHA256 5f5d0edb842773648b64258c193a52e56de574e3f451e5a247810db0f8143cc8 SHA512 b4b3ba2d20779d453e85a0fc4964f1ecbe414d629d42202e57ec1191a839e87a22fb3b17702feffd5837554d400883061bb299bbc957bd5752227aac9847a4d7 WHIRLPOOL 0057949ad0a5cd84c5317d2d1bfec22748e05eea387747a9472e81d837a7e23fff759b924ed5469c588556702461d897a8f298d3e581130c075f274ca28b3530
|
@ -0,0 +1,11 @@
|
||||
--- a/setup.py 2021-10-13 15:04:56.840925521 -0400
|
||||
+++ b/setup.py 2021-10-14 16:15:24.934360987 -0400
|
||||
@@ -21,7 +21,7 @@
|
||||
url="https://github.com/SpikeInterface/spikeextractors",
|
||||
long_description=long_description,
|
||||
long_description_content_type="text/markdown",
|
||||
- packages=setuptools.find_packages(),
|
||||
+ packages=setuptools.find_packages(exclude=["tests"]),
|
||||
package_data={},
|
||||
include_package_data=True,
|
||||
install_requires=[
|
15
dev-python/spikeextractors/metadata.xml
Normal file
15
dev-python/spikeextractors/metadata.xml
Normal file
@ -0,0 +1,15 @@
|
||||
<?xml version='1.0' encoding='UTF-8'?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<maintainer type="person">
|
||||
<email>gentoo@chymera.eu</email>
|
||||
<name>Horea Christian</name>
|
||||
</maintainer>
|
||||
<maintainer type="project">
|
||||
<email>sci@gentoo.org</email>
|
||||
<name>Gentoo Science Project</name>
|
||||
</maintainer>
|
||||
<upstream>
|
||||
<remote-id type="github">SpikeInterface/spikeextractors</remote-id>
|
||||
</upstream>
|
||||
</pkgmetadata>
|
61
dev-python/spikeextractors/spikeextractors-0.9.7.ebuild
Normal file
61
dev-python/spikeextractors/spikeextractors-0.9.7.ebuild
Normal file
@ -0,0 +1,61 @@
|
||||
# Copyright 2021 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
PYTHON_COMPAT=( python3_{8..9} )
|
||||
# dev-python/hdf5storage is holding 3.10 back
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="Extract, convert, and interface with extracellular data, now in spikeinterfaces"
|
||||
HOMEPAGE="https://github.com/SpikeInterface/spikeextractors"
|
||||
SRC_URI="https://github.com/SpikeInterface/spikeextractors/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="MIT"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64"
|
||||
# dev-python/hdf5storage, datalad, and neo hold back ~x86
|
||||
IUSE="test"
|
||||
RESTRICT="!test? ( test )"
|
||||
|
||||
DEPEND=""
|
||||
RDEPEND="
|
||||
dev-python/h5py[${PYTHON_USEDEP}]
|
||||
dev-python/hdf5storage[${PYTHON_USEDEP}]
|
||||
dev-python/joblib[${PYTHON_USEDEP}]
|
||||
dev-python/loky[${PYTHON_USEDEP}]
|
||||
dev-python/lxml[${PYTHON_USEDEP}]
|
||||
dev-python/matplotlib[${PYTHON_USEDEP}]
|
||||
dev-python/neo[${PYTHON_USEDEP}]
|
||||
dev-python/numpy[${PYTHON_USEDEP}]
|
||||
dev-python/pandas[${PYTHON_USEDEP}]
|
||||
dev-python/pynwb[${PYTHON_USEDEP}]
|
||||
dev-python/pyyaml[${PYTHON_USEDEP}]
|
||||
dev-python/scipy[${PYTHON_USEDEP}]
|
||||
dev-python/tqdm[${PYTHON_USEDEP}]
|
||||
dev-vcs/datalad
|
||||
"
|
||||
# also needs
|
||||
# pyintan
|
||||
# pyopenephys
|
||||
# nixio
|
||||
# shybird
|
||||
# mtscomp
|
||||
# exdir
|
||||
# sonpy
|
||||
# pyyaml and shybird might not really be needed
|
||||
BDEPEND=""
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${PN}-0.9.7-no-test-install.patch"
|
||||
)
|
||||
|
||||
distutils_enable_tests pytest
|
||||
|
||||
src_install() {
|
||||
pwd
|
||||
ls -lah
|
||||
rm -rf tests/ || die "Could not remove tests directory incorrectly selected by package for install."
|
||||
ls -lah
|
||||
distutils-r1_src_install
|
||||
}
|
Loading…
x
Reference in New Issue
Block a user