Browse Source

dev-vcs/dandi-cli: version bump

test failures

Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Horea Christian <chr@chymera.eu>
master
Horea Christian 3 months ago
parent
commit
e58adb8659
No known key found for this signature in database GPG Key ID: 161C0BE6255333D3
  1. 12
      dev-vcs/dandi-cli/ChangeLog
  2. 2
      dev-vcs/dandi-cli/Manifest
  3. 12
      dev-vcs/dandi-cli/dandi-cli-0.28.0.ebuild
  4. 14
      dev-vcs/dandi-cli/dandi-cli-0.30.3.ebuild
  5. 28
      dev-vcs/dandi-cli/dandi-cli-0.31.0.ebuild
  6. 13
      dev-vcs/dandi-cli/files/dandi-cli-0.27.2-pip-versioncheck.patch
  7. 0
      dev-vcs/dandi-cli/files/dandi-cli-0.28.0-no-etelemetry.patch

12
dev-vcs/dandi-cli/ChangeLog

@ -1,6 +1,8 @@
*dandi-cli-0.30.3 (14 Oct 2021)
*dandi-cli-0.31.0 (29 Oct 2021)
14 Oct 2021; <chymera@gentoo.org> +dandi-cli-0.30.3.ebuild,
+files/dandi-cli-0.28.0-test_nonetwork.patch, -ChangeLog,
dandi-cli-0.28.0.ebuild:
dev-vcs/dandi-cli: new version
29 Oct 2021; <chymera@gentoo.org> +dandi-cli-0.31.0.ebuild,
+files/dandi-cli-0.28.0-no-etelemetry.patch, -ChangeLog,
-dandi-cli-0.27.2.ebuild, -files/dandi-cli-0.27.2-no-etelemetry.patch,
-files/dandi-cli-0.27.2-pip-versioncheck.patch, dandi-cli-0.28.0.ebuild,
dandi-cli-0.30.3.ebuild:
dev-vcs/dandi-cli: version bump test failures

2
dev-vcs/dandi-cli/Manifest

@ -1,3 +1,3 @@
DIST dandi-cli-0.27.2.tar.gz 172781 SHA256 179bbe77be65272932f6e1fc133b043eb94449847155fde3c45455c30b6cbdcc SHA512 00c522a1f5c922e6a38e257defbb02a03480156d61bcf80de3326131533a5cc332771ea05e2a995d7ace71b0ba551151d4ec3d3f4456197cb358133d3aa3fe89 WHIRLPOOL bf059cad4f8a9988a783d0001a68ebec8d480f3188f756af720aa5f0e32002e8301a3f98b2e0c492bb3be07f39959839e8b67c5544c0a3e18e757332a6bdb70c
DIST dandi-cli-0.28.0.tar.gz 173403 SHA256 27b67c93a8625dd15db2e3513ae3448569ccade2dc82eb1f110de5b1c02b5ec3 SHA512 399ee378798a3c7fdc92314dca25e91178bb157145205e43a1d2ec461f36c674ed1b63b97f805ab9d25eb30d18d82827e38024b8a72c691c3992af60fc286be3 WHIRLPOOL 3381c9f7f0c7c5263bb2a8019205a44d0b6084fc9719034462ea7d66f0f23a617dfc3468676102f931444b4b43b788e8c7c65615ebae5f30c635d51badbaf92a
DIST dandi-cli-0.30.3.tar.gz 175911 SHA256 ed218df35ee69f6d06fd6c70fe69226aaf6d3231f8b58abdd1b9fd1477350c44 SHA512 11e73a5acaa05bb2d0287e25e1e25226474f5b076ac58e9bedcb1608e6a509d113960a1d6dfe1b665d99d14d6b4b51f65eb85c38a4f9eba0ddb5492f1890cf96 WHIRLPOOL f12b8c0eada3b6ddf373301e8cfd1b1c1c4339d4ee59fe37b730eb7c91a4c031660da422316c007ce5445d2ab90c83242921cc417dad43c66bad814031811946
DIST dandi-cli-0.31.0.tar.gz 179090 SHA256 6bc9a46e90da1b6b11fcc1492c02223f135ce5a1f42747df8f5cb09fe6cb1c10 SHA512 5c72b0a75469c3f5762a653b454797723251b108c770ad617f814983691f5205c02302a444dc5650754597537d6dd75a3bc84d886a557243d489d738e3033981 WHIRLPOOL 2d2d1ad8e392f0ec0dd707963618cda3e524bd6efbd2240c8fec2fd5bec3ca15f47740a6b96c47f4f4ec05f4abd6fae90875b95fa272d79d42b305385fcafc35

12
dev-vcs/dandi-cli/dandi-cli-0.28.0.ebuild

@ -13,7 +13,7 @@ SRC_URI="https://github.com/dandi/dandi-cli/archive/refs/tags/${PV}.tar.gz -> ${
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test +etelemetry"
IUSE="test etelemetry"
#RESTRICT="test"
# Test fail during collection, reported upstream: https://github.com/dandi/dandi-cli/issues/774
@ -40,7 +40,10 @@ RDEPEND="
dev-python/tenacity[${PYTHON_USEDEP}]
dev-python/tqdm[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
<dev-python/jsonschema-4[${PYTHON_USEDEP}]
"
# Errors with newer jsonschema, though not a direct dependency, reported upstream:
# https://github.com/dandi/dandi-cli/issues/825
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
@ -61,9 +64,12 @@ PATCHES=(
src_prepare() {
if ! use etelemetry; then
eapply "${FILESDIR}/${PN}-0.27.2-no-etelemetry.patch"
eapply "${FILESDIR}/${P}-no-etelemetry.patch"
default
sed -i "/etelemetry/d" setup.cfg
else
default
fi
default
}
python_test() {

14
dev-vcs/dandi-cli/dandi-cli-0.30.3.ebuild

@ -13,7 +13,7 @@ SRC_URI="https://github.com/dandi/dandi-cli/archive/refs/tags/${PV}.tar.gz -> ${
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test +etelemetry"
IUSE="test etelemetry"
#RESTRICT="test"
# Test fail during collection, reported upstream: https://github.com/dandi/dandi-cli/issues/774
@ -40,7 +40,10 @@ RDEPEND="
dev-python/tenacity[${PYTHON_USEDEP}]
dev-python/tqdm[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
<dev-python/jsonschema-4[${PYTHON_USEDEP}]
"
# Errors with newer jsonschema, though not a direct dependency, reported upstream:
# https://github.com/dandi/dandi-cli/issues/825
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
@ -59,10 +62,13 @@ PATCHES=(
)
src_prepare() {
if ! use etelemetry; then
eapply "${FILESDIR}/${PN}-0.27.2-no-etelemetry.patch"
if use etelemetry; then
default
else
eapply "${FILESDIR}/${PN}-0.28.0-no-etelemetry.patch"
default
sed -i "/etelemetry/d" setup.cfg
fi
default
}
python_test() {

28
dev-vcs/dandi-cli/dandi-cli-0.27.2.ebuild → dev-vcs/dandi-cli/dandi-cli-0.31.0.ebuild

@ -13,15 +13,15 @@ SRC_URI="https://github.com/dandi/dandi-cli/archive/refs/tags/${PV}.tar.gz -> ${
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test +etelemetry"
RESTRICT="test"
IUSE="test etelemetry"
#RESTRICT="test"
# Test fail during collection, reported upstream: https://github.com/dandi/dandi-cli/issues/774
RDEPEND="
dev-python/appdirs[${PYTHON_USEDEP}]
dev-python/click[${PYTHON_USEDEP}]
dev-python/click-didyoumean[${PYTHON_USEDEP}]
=dev-python/dandischema-0.3*[${PYTHON_USEDEP}]
=dev-python/dandischema-0.4*[${PYTHON_USEDEP}]
dev-python/fasteners[${PYTHON_USEDEP}]
dev-python/fscacher[${PYTHON_USEDEP}]
dev-python/humanize[${PYTHON_USEDEP}]
@ -29,6 +29,7 @@ RDEPEND="
dev-python/keyring[${PYTHON_USEDEP}]
dev-python/keyrings_alt[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
dev-python/pycryptodomex[${PYTHON_USEDEP}]
dev-python/pydantic[${PYTHON_USEDEP}]
dev-python/pynwb[${PYTHON_USEDEP}]
dev-python/pyout[${PYTHON_USEDEP}]
@ -40,6 +41,8 @@ RDEPEND="
dev-python/tqdm[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
"
# Errors with newer jsonschema, though not a direct dependency, reported upstream:
# https://github.com/dandi/dandi-cli/issues/825
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
@ -54,17 +57,20 @@ DEPEND="
distutils_enable_tests pytest
PATCHES=(
"${FILESDIR}/${P}-pip-versioncheck.patch"
"${FILESDIR}/${PN}-0.28.0-pip-versioncheck.patch"
)
src_prepare() {
if ! use etelemetry; then
eapply "${FILESDIR}/${PN}-0.27.2-no-etelemetry.patch"
if use etelemetry; then
default
else
eapply "${FILESDIR}/${PN}-0.28.0-no-etelemetry.patch"
default
sed -i "/etelemetry/d" setup.cfg
fi
default
}
#python_install_all() {
# distutils-r1_python_install_all
# dodoc README.md
#}
python_test() {
export DANDI_TESTS_NONETWORK=1
${EPYTHON} -m pytest -vv || die "Tests failed with ${EPYTHON}"
}

13
dev-vcs/dandi-cli/files/dandi-cli-0.27.2-pip-versioncheck.patch

@ -1,13 +0,0 @@
--- a/setup.cfg 2021-10-06 11:44:40.549337707 -0400
+++ b/dsetup.cfg 2021-10-06 11:45:10.236935245 -0400
@@ -30,8 +30,8 @@
appdirs
click
click-didyoumean
- dandischema ~= 0.3.1
- etelemetry >= 0.2.2
+ dandischema
+ etelemetry
fasteners
fscacher
# Specifying != might be what causes pip 19.3.1 first to install hdmf 1.5.1

0
dev-vcs/dandi-cli/files/dandi-cli-0.27.2-no-etelemetry.patch → dev-vcs/dandi-cli/files/dandi-cli-0.28.0-no-etelemetry.patch

Loading…
Cancel
Save