Trying to put together an ebuild
This commit is contained in:
parent
35abe2d85c
commit
d4a8072732
5
dev-python/pypubsub/Manifest
Normal file
5
dev-python/pypubsub/Manifest
Normal file
@ -0,0 +1,5 @@
|
|||||||
|
AUX pypubsub-3.3.0-imports.patch 397 BLAKE2B 11cb8b8a8e79193a4b84c1559b41d8d89b407ed3848e2f89e68f63ac8c45aaafef24eab321062d0eada760e5e317c6fec957ae7fc8ad575ae8bd59d0070e4577 SHA512 bf6c674eee0c5bb0ab18c2d2c31029bab9e7f542c0df486805909bffe1bb371d80bf407b51b8afe9c8ef282dbdbae5ecbc776740c586748185d124a8407cd7b0
|
||||||
|
DIST pypubsub-3.3.0-extras.tar.gz 59605 BLAKE2B 1d899a01966d84695087d9c0e046d3d42c81dde6c330b7e7ef5a41b9f2affada47cdc8c254c6628d4f72292fa42306ed0091f5c074a04311370a2ff65f74ffcb SHA512 3351b7af7a7625b9ca9e52f178b6d503d1f6eeda85d7ca1ab6fe8d4782b3965b01dd65cda07fa79811a7f8caa66282f38a2b13dfe84beaacbcb6a8c1825c3994
|
||||||
|
DIST pypubsub-3.3.0.tar.gz 198383 BLAKE2B e25d5012c7d78963646dcf9d4e9799f41fdf2ec5691891a42430d384b85c77b21604a4ead5a42fd33c81758c03e91b16d4bd4ec17f77aec0d520b49be513b7aa SHA512 520361e01b33d466b5387867d7a989ca69256b924cadd65c376e008ec52a6d1d4d09d84afeba8df2558721b62bb8ba6b17a74bbd2173a9867b030bb091889958
|
||||||
|
EBUILD pypubsub-3.3.0.ebuild 2281 BLAKE2B 748bf91d51bd94bc89c0ccef70560f4a94c10f4e31437858411dbf8c1cb0ca22f0729fbf30517075e56f538f108919e20e1f2917c2f730007c41cb39a14a886c SHA512 ff5af81103b0d79d283c2bf6bd7458f46c96d42962f72e7e278195f34b3f69a4c954e9baa6f2b0f1fc6e1040ff1f7bc6c77b88d4582c4a150a80839b1250412d
|
||||||
|
MISC metadata.xml 655 BLAKE2B e43c6f3c232be474cd579a5277566aa925dbe2ded7239462b8e28de71aabb8e4b543593f5b9ef67c617aa3f7545fc1ba184330a53adea52df548e28cb6cfd37b SHA512 1880788a55ff8dfa824edb261ac1d53fb90512d0c0b865549f3f86b96e96209ff9c4fa5c00c0dbeb82812b933ef3ecbd40474a65662a6b9ceb59b62f062934b4
|
15
dev-python/pypubsub/files/pypubsub-3.3.0-imports.patch
Normal file
15
dev-python/pypubsub/files/pypubsub-3.3.0-imports.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
--- a/src/pubsub/core/topicdefnprovider.py 2018-10-06 03:47:21.100705832 +0200
|
||||||
|
+++ b/src/pubsub/core/topicdefnprovider.py 2018-10-06 03:48:55.158820283 +0200
|
||||||
|
@@ -7,10 +7,8 @@
|
||||||
|
import os, re, inspect
|
||||||
|
from textwrap import TextWrapper, dedent
|
||||||
|
|
||||||
|
-from .. import (
|
||||||
|
- policies,
|
||||||
|
- py2and3
|
||||||
|
-)
|
||||||
|
+import policies, py2and3
|
||||||
|
+
|
||||||
|
from .topicargspec import (
|
||||||
|
topicArgsFromCallable,
|
||||||
|
ArgSpecGiven
|
18
dev-python/pypubsub/metadata.xml
Normal file
18
dev-python/pypubsub/metadata.xml
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
<?xml version='1.0' encoding='UTF-8'?>
|
||||||
|
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||||
|
<pkgmetadata>
|
||||||
|
<maintainer type="person">
|
||||||
|
<email>horea.christ@gmail.com</email>
|
||||||
|
<name>Horea Christian</name>
|
||||||
|
</maintainer>
|
||||||
|
<maintainer type="project">
|
||||||
|
<email>sci@gentoo.org</email>
|
||||||
|
<name>Gentoo Science Project</name>
|
||||||
|
</maintainer>
|
||||||
|
<longdescription lang="en">
|
||||||
|
FSLeyes is a viewer for 3D and 4D neuroimaging data. It is intended as a
|
||||||
|
replacement for the much loved FSLView. FSLeyes offers similar functionality
|
||||||
|
to FSLView, and aims to improve and expand upon this functionality in many
|
||||||
|
ways.
|
||||||
|
</longdescription>
|
||||||
|
</pkgmetadata>
|
65
dev-python/pypubsub/pypubsub-3.3.0.ebuild
Normal file
65
dev-python/pypubsub/pypubsub-3.3.0.ebuild
Normal file
@ -0,0 +1,65 @@
|
|||||||
|
# Copyright 1999-2018 Gentoo Foundation
|
||||||
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
|
EAPI=7
|
||||||
|
|
||||||
|
PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
|
||||||
|
|
||||||
|
inherit distutils-r1
|
||||||
|
|
||||||
|
EGIT_COMMIT="c6adca35967db428fbed05086767687ce72baf7a"
|
||||||
|
|
||||||
|
DESCRIPTION="A Python publish-subcribe library"
|
||||||
|
HOMEPAGE="https://github.com/pauldmccarthy/indexed_gzip"
|
||||||
|
SRC_URI="
|
||||||
|
https://github.com/schollii/pypubsub/archive/v${PV}.tar.gz -> ${P}.tar.gz
|
||||||
|
https://github.com/schollii/pypubsub/archive/${EGIT_COMMIT}.tar.gz -> ${P}-extras.tar.gz
|
||||||
|
"
|
||||||
|
|
||||||
|
LICENSE="BSD"
|
||||||
|
SLOT="0"
|
||||||
|
KEYWORDS="~amd64 ~x86"
|
||||||
|
IUSE="test"
|
||||||
|
|
||||||
|
DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
|
||||||
|
RDEPEND=""
|
||||||
|
|
||||||
|
PATCHES=( "${FILESDIR}"/${P}-imports.patch )
|
||||||
|
|
||||||
|
src_prepare() {
|
||||||
|
cp "../${PN}-${EGIT_COMMIT}/"{policies,py2and3}.py src/ || die
|
||||||
|
cp "../${PN}-${EGIT_COMMIT}/setuparg1.py" src/pubsub/core/ || die
|
||||||
|
cp "../${PN}-${EGIT_COMMIT}/setupkwargs.py" src/pubsub/core/ || die
|
||||||
|
cp "../${PN}-${EGIT_COMMIT}/core/arg1/listenerimpl.py" src/pubsub/core/ || die
|
||||||
|
cp "../${PN}-${EGIT_COMMIT}/core/arg1/publisher.py" src/pubsub/core/ || die
|
||||||
|
cp "../${PN}-${EGIT_COMMIT}/core/arg1/publishermixin.py" src/pubsub/core/ || die
|
||||||
|
cp "../${PN}-${EGIT_COMMIT}/core/arg1/topicargspecimpl.py" src/pubsub/core/ || die
|
||||||
|
cp "../${PN}-${EGIT_COMMIT}/core/arg1/topicmgrimpl.py" src/pubsub/core/ || die
|
||||||
|
cp "../${PN}-${EGIT_COMMIT}/core/listenerbase.py" src/pubsub/core/ || die
|
||||||
|
cp "../${PN}-${EGIT_COMMIT}/core/publisherbase.py" src/pubsub/core/ || die
|
||||||
|
cp "../${PN}-${EGIT_COMMIT}/core/treeconfig.py" src/pubsub/core/ || die
|
||||||
|
cp "../${PN}-${EGIT_COMMIT}/core/validatedefnargs.py" src/pubsub/core/ || die
|
||||||
|
touch __init__.py
|
||||||
|
find -type f -exec sed -i\
|
||||||
|
-e "s/from .. import policies/import policies/g"\
|
||||||
|
-e "s/from .. import py2and3/import py2and3/g"\
|
||||||
|
{} + || die
|
||||||
|
distutils-r1_src_prepare
|
||||||
|
}
|
||||||
|
|
||||||
|
src_compile() {
|
||||||
|
distutils-r1_src_compile
|
||||||
|
ls
|
||||||
|
cp "../${PN}-${EGIT_COMMIT}/"{policies,py2and3}.py ${BUILD_DIR} || die
|
||||||
|
}
|
||||||
|
|
||||||
|
python_test() {
|
||||||
|
#cp "../${PN}-${EGIT_COMMIT}/"{policies,py2and3}.py "${BUILD_DIR}" || die
|
||||||
|
cp "../${PN}-${EGIT_COMMIT}/"{policies,py2and3}.py src/ || die
|
||||||
|
cd ${BUILD_DIR} || die
|
||||||
|
nosetests -v || die
|
||||||
|
#for i in tests/suite/*.py; do
|
||||||
|
# echo "Executing ${EPYTHON} ${i}"
|
||||||
|
# ${EPYTHON} "$i" || die "Example Python script $i failed with ${EPYTHON}"
|
||||||
|
#done
|
||||||
|
}
|
Loading…
x
Reference in New Issue
Block a user