1
0
Fork 0

dev-lang/lazarus: merged in Gentoo Main

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ef0418fabdb92ab821f80a552a673b74b862bae4

Signed-off-by: Horea Christian <chr@chymera.eu>
This commit is contained in:
Horea Christian 2020-04-28 03:25:27 -04:00
parent 63c2d64310
commit cdfdd554d8
No known key found for this signature in database
GPG Key ID: EAA9223EE3BB378A
5 changed files with 0 additions and 117 deletions

View File

@ -1,6 +0,0 @@
*lazarus-2.0.6 (31 Mar 2020)
31 Mar 2020; <chymera@gentoo.org> +lazarus-2.0.6.ebuild, -ChangeLog,
-lazarus-2.0.2-r1.ebuild:
dev-lang/lazarus: version bump 2.0.6 ahead of Gentoo Main
https://github.com/gentoo/gentoo/pull/15183

View File

@ -1 +0,0 @@
DIST lazarus-2.0.6.tar.gz 65558951 SHA256 82cdafb0f0c05cf1ebb8e52b58bf980a08a866b6df1003f55ca2da3480e92a6c SHA512 cdb4c5861e130c12bf0a4938a73c439f2766a73008678028d7e9c9bcabe7b277e70025a7c720a5c14c157cf0227e0ff629a44cf983537b3afbf341343e816d07 WHIRLPOOL 89e7bb64151e6b644a06b9059cd30b995dfd25f81fa1131e0abad0d77e63aaa2bf9cd95bf8cb401ef54fd0bf283cc0d782a91ce9a9d4aa0ee665561c83066fc2

View File

@ -1,13 +0,0 @@
--- lazarus/ide/include/unix/lazbaseconf.inc
+++ lazarus/ide/include/unix/lazbaseconf.inc
@@ -24,8 +24,9 @@
}
const
- DefaultFPCSrcDirs: array[1..15] of string = (
+ DefaultFPCSrcDirs: array[1..16] of string = (
// search first for sources with right version
+ '/usr/lib/fpc/$(FPCVer)/source',
'/usr/share/fpcsrc/$(FPCVer)',
// then search for global paths
'/usr/share/fpcsrc',

View File

@ -1,80 +0,0 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit desktop
FPCVER="3.0.4"
PYTHON_HASH="f362a0ea44a1981558539833a0354c1cf4b10eca"
DESCRIPTION="Lazarus IDE is a feature rich visual programming environment emulating Delphi"
HOMEPAGE="https://www.lazarus-ide.org/"
SRC_URI="https://sourceforge.net/projects/${PN}/files/Lazarus%20Zip%20_%20GZip/Lazarus%20${PV}/${P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1-with-linking-exception"
SLOT="0" # Note: Slotting Lazarus needs slotting fpc, see DEPEND.
KEYWORDS="~amd64 ~x86"
IUSE="minimal"
DEPEND=">=dev-lang/fpc-${FPCVER}[source]
net-misc/rsync
x11-libs/gtk+:2
>=sys-devel/binutils-2.19.1-r1:="
RDEPEND="${DEPEND}"
RESTRICT="strip" #269221
S="${WORKDIR}/${PN}"
PATCHES=( "${FILESDIR}"/${PN}-0.9.26-fpcsrc.patch )
src_prepare() {
default
# Use default configuration (minus stripping) unless specifically requested otherwise
if ! test ${PPC_CONFIG_PATH+set} ; then
local FPCVER=$(fpc -iV)
export PPC_CONFIG_PATH="${WORKDIR}"
sed -e 's/^FPBIN=/#&/' /usr/lib/fpc/${FPCVER}/samplecfg |
sh -s /usr/lib/fpc/${FPCVER} "${PPC_CONFIG_PATH}" || die
fi
sed -i \
-e "s;SecondaryConfigPath:='/etc/lazarus';SecondaryConfigPath:=ExpandFileNameUTF8('~/.lazarus');g" \
-e "s;PrimaryConfigPath:=ExpandFileNameUTF8('~/.lazarus');PrimaryConfigPath:='/etc/lazarus';g" \
ide/include/unix/lazbaseconf.inc \
|| die
}
src_compile() {
LCL_PLATFORM=gtk2 emake \
$(usex minimal "" "bigide") \
-j1
}
src_install() {
diropts -m0755
dodir /usr/share
# Using rsync to avoid unnecessary copies and cleaning...
# Note: *.o and *.ppu are needed
rsync -a \
--exclude="CVS" --exclude=".cvsignore" \
--exclude="*.ppw" --exclude="*.ppl" \
--exclude="*.ow" --exclude="*.a"\
--exclude="*.rst" --exclude=".#*" \
--exclude="*.~*" --exclude="*.bak" \
--exclude="*.orig" --exclude="*.rej" \
--exclude=".xvpics" --exclude="*.compiled" \
--exclude="killme*" --exclude=".gdb_hist*" \
--exclude="debian" --exclude="COPYING*" \
--exclude="*.app" \
"${S}" "${ED%/}"/usr/share \
|| die "Unable to copy files!"
dosym ../share/lazarus/startlazarus /usr/bin/startlazarus
dosym ../share/lazarus/startlazarus /usr/bin/lazarus
dosym ../share/lazarus/lazbuild /usr/bin/lazbuild
use minimal || dosym ../share/lazarus/components/chmhelp/lhelp/lhelp /usr/bin/lhelp
dosym ../lazarus/images/ide_icon48x48.png /usr/share/pixmaps/lazarus.png
make_desktop_entry startlazarus "Lazarus IDE" "lazarus"
}

View File

@ -1,17 +0,0 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>amynka@gentoo.org</email>
</maintainer>
<longdescription lang="en">
A Borland Delphi lookalike for linux.
Uses the free pascal compiler.
</longdescription>
<use>
<flag name="minimal">Don't build extra packages from the bigide component</flag>
</use>
<upstream>
<remote-id type="sourceforge">downloads</remote-id>
</upstream>
</pkgmetadata>