sci-biology/fsl: credit and detail the patches.
Package-Manager: Portage-2.3.79, Repoman-2.3.16
This commit is contained in:
parent
886fa7d55f
commit
ccc8a39753
@ -1,3 +1,8 @@
|
||||
19 Jan 2020; François Bissey <frp.bissey@gmail.com>
|
||||
files/fsl-6.0.2-fsldir_redux.patch, files/fsl-6.0.2-no_xmlpp.patch,
|
||||
files/fsl-6.0.2-qstring_compat.patch, files/fsl-6.0.2-setup.patch:
|
||||
sci-biology/fsl: credit and detail the patches.
|
||||
|
||||
08 Nov 2019; François Bissey <frp.bissey@gmail.com> fsl-6.0.2.ebuild:
|
||||
sci-biology/fsl: final touches. Skip mist-clean.
|
||||
|
||||
|
@ -1,3 +1,28 @@
|
||||
From 2bc4be1f55b27a733e1e624b34bc570187ba95e1 Mon Sep 17 00:00:00 2001
|
||||
From: François Bissey <frp.bissey@gmail.com>
|
||||
Date: Mon, 20 Jan 2020 11:40:53 +1300
|
||||
Subject: [PATCH] Making sure fsl code and executable can find other executable
|
||||
and data in standard location.
|
||||
|
||||
---
|
||||
src/fast4/fast_two.cc | 8 ++++----
|
||||
src/feat5/feat_model.cc | 8 +++-----
|
||||
src/feat5/tsplot.cc | 7 +++----
|
||||
src/first/first_utils.cc | 4 ++--
|
||||
src/fnirt/fnirtfns.cpp | 11 ++++-------
|
||||
src/fslsurface/fslsurface_first.cc | 6 ++----
|
||||
src/fslsurface/fslsurfacemaths.cpp | 12 ------------
|
||||
src/libvis/miscpic.h | 7 +------
|
||||
src/melodic/meldata.cc | 4 ++--
|
||||
src/melodic/meloptions.cc | 8 --------
|
||||
src/melodic/meloptions.h | 1 -
|
||||
src/melodic/melreport.cc | 12 ++++++------
|
||||
src/melodic/melreport.h | 20 ++++++++++----------
|
||||
src/mm/mixture_model.cc | 4 ++--
|
||||
src/siena/siena_diff.cc | 28 +++++++++++++---------------
|
||||
src/topup/topupfns.cpp | 3 +--
|
||||
16 files changed, 53 insertions(+), 90 deletions(-)
|
||||
|
||||
diff --git a/src/fast4/fast_two.cc b/src/fast4/fast_two.cc
|
||||
index 592b5df..b525444 100644
|
||||
--- a/src/fast4/fast_two.cc
|
||||
@ -465,3 +490,6 @@ index 6873758..9e8b956 100644
|
||||
if (TOPUP::check_exist(ecfname)) return(ecfname);
|
||||
else if (!TOPUP::extension(ecfname).length()) { // If no path _and_ no extension given
|
||||
ecfname += string(".cnf");
|
||||
--
|
||||
2.24.1
|
||||
|
||||
|
@ -1,3 +1,14 @@
|
||||
From 9de29e5141afa43c06f347ca158b67168fbb0031 Mon Sep 17 00:00:00 2001
|
||||
From: François Bissey <frp.bissey@gmail.com>
|
||||
Date: Mon, 20 Jan 2020 11:46:52 +1300
|
||||
Subject: [PATCH] Build without xmlpp since we use an external ciftilib that
|
||||
doesnt require it. Replace it and other ciftilib flags with CIFTICFLAGS.
|
||||
|
||||
---
|
||||
src/flameo/Makefile | 4 ++--
|
||||
src/melodic/Makefile | 4 ++--
|
||||
2 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/flameo/Makefile b/src/flameo/Makefile
|
||||
index d22eb965..e967e682 100644
|
||||
--- a/src/flameo/Makefile
|
||||
@ -42,3 +53,6 @@ index 50666517..0c356a2d 100644
|
||||
|
||||
TEST_OBJS = test.o
|
||||
|
||||
--
|
||||
2.24.1
|
||||
|
||||
|
@ -1,3 +1,15 @@
|
||||
From 5a5ab3c80eaaea1fe9a43659e2ea5b773b587bb0 Mon Sep 17 00:00:00 2001
|
||||
From: François Bissey <frp.bissey@gmail.com>
|
||||
Date: Mon, 20 Jan 2020 11:51:52 +1300
|
||||
Subject: [PATCH] Because we use qstrings in ciftilib, calls to ciftilib file
|
||||
function have to be made into compatible c strings.
|
||||
|
||||
---
|
||||
src/flameo/gsa.cc | 4 ++--
|
||||
src/melodic/meldata.cc | 2 +-
|
||||
src/melodic/meldata.h | 2 +-
|
||||
3 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/flameo/gsa.cc b/src/flameo/gsa.cc
|
||||
index 70f8f385..16167abe 100644
|
||||
--- a/src/flameo/gsa.cc
|
||||
@ -21,7 +33,7 @@ index 70f8f385..16167abe 100644
|
||||
vector<float> scratchRow(data.Nrows());//read/write a row at a time
|
||||
for (int64_t row=0;row<data.Ncols();row++) {
|
||||
diff --git a/src/melodic/meldata.cc b/src/melodic/meldata.cc
|
||||
index 1749a459..b76f052d 100644
|
||||
index c4ad2349..1515e702 100644
|
||||
--- a/src/melodic/meldata.cc
|
||||
+++ b/src/melodic/meldata.cc
|
||||
@@ -118,7 +118,7 @@ namespace Melodic{
|
||||
@ -46,3 +58,6 @@ index 49774003..f5326bdd 100644
|
||||
cifti::CiftiXML xml(inputCifti.getCiftiXML());
|
||||
cifti::CiftiScalarsMap scalarsMap;
|
||||
std::vector<char> foo = xml.writeXMLToVector();
|
||||
--
|
||||
2.24.1
|
||||
|
||||
|
@ -1,3 +1,19 @@
|
||||
From baae97cc3c8d0cadcabb7ed16559f4e4de26ddbe Mon Sep 17 00:00:00 2001
|
||||
From: François Bissey <frp.bissey@gmail.com>
|
||||
Date: Mon, 20 Jan 2020 11:54:37 +1300
|
||||
Subject: [PATCH] Adjust the build system so it doesnt build packages
|
||||
externally provided by portage. Make the compilation flags more generic and
|
||||
easily adjustable. Make the build system stop at the first fault.
|
||||
|
||||
---
|
||||
build | 6 +++---
|
||||
config/buildSettings.mk | 20 ++++++++++----------
|
||||
config/common/buildproj | 8 +++++---
|
||||
config/common/vars.mk | 10 +++++-----
|
||||
extras/build | 8 ++++----
|
||||
src/mist-clean/Makefile | 2 +-
|
||||
6 files changed, 28 insertions(+), 26 deletions(-)
|
||||
|
||||
diff --git a/build b/build
|
||||
index 05dac06c..d90e407b 100755
|
||||
--- a/build
|
||||
@ -177,3 +193,6 @@ index 20402cca..6918bee4 100755
|
||||
+ rm -f ${OBJS} mist/mist.o mist/mist || echo "CLEAN could not locate some files scheduled for deletion."
|
||||
|
||||
.PHONY: all clean installdata
|
||||
--
|
||||
2.24.1
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user