Merge branch 'master' of github.com:TheChymera/overlay
This commit is contained in:
commit
c90ff55393
@ -1,2 +1,2 @@
|
||||
DIST pypubsub-3.4.0.tar.gz 169245 SHA256 641f03213491de9acd23ce69573fac7a03141c7eedd22d8cd62a70a564629000 SHA512 539e10ddd767a592487a318ec202051a9546a489ccb13cfe9f8016ce129b6428eee5e4fd191cdd513feb9d01886a60823ca1fd05cf96748d90fd2d0fb69b3e3a WHIRLPOOL 758edee90229f8a2ed2b8f397950f99dcf943276e37572736805ffb693454cd4f4f7f0978b8cfa4a21cba79e0f8185c9537fcf2699ca318d785207b44bd25a8d
|
||||
DIST pypubsub-3.4.2.tar.gz 169226 SHA256 105b5779e836058d5deb788413f5a3a60958445d1795cf176b899a4dfbe9a0a7 SHA512 02b3b3e3bfd864606264dca8cb1730f6b2ef94552d888f777f1fc289ba5c39f87af584a7f44b50c34f15f9c89fd09c57c8ed78f2043981cf9e0f8af40d2b96b3 WHIRLPOOL 18c0689f31a063f5fe04f6efbbd718577d2cb0c54f55322fc12adcfdacda31ff394fe4455a1e1cc2584c662809d1199aa1a63a7fb84bb604a8639b13bc4a7a04
|
||||
DIST pypubsub-4.0.3.tar.gz 174033 SHA256 0df83daa1cb0021bab858ff6812d836c9712dea59a5172be1888bb554c3a89a2 SHA512 cf9aca44e91a5d0e5ecf6739deabf2980f9464395c89e3c5335c5248e47c570701e0534bb660c5005325a994d9f8e7f261f36bc8bea74cfc7eb760b73c572652 WHIRLPOOL 706ddf8e86c432f6b7ebbae5a74547b2d54bbae1a04dcf238c96cc90800c2e44c2d35bc14e0e5efa0eb2594a6a2b4167428d28fc9cc72c598eb3e5254e0f3fd3
|
||||
|
@ -1,28 +0,0 @@
|
||||
# Copyright 1999-2019 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=7
|
||||
|
||||
PYTHON_COMPAT=( python2_7 )
|
||||
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="A Python publish-subcribe library"
|
||||
HOMEPAGE="https://github.com/schollii/pypubsub/"
|
||||
SRC_URI="https://github.com/schollii/pypubsub/archive/v${PV}rc1.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="BSD"
|
||||
SLOT="3"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test"
|
||||
|
||||
DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
|
||||
RDEPEND="virtual/python-pathlib[${PYTHON_USEDEP}]"
|
||||
|
||||
python_test() {
|
||||
distutils_install_for_testing
|
||||
cd "tests/suite" || die
|
||||
pytest -vv || die
|
||||
}
|
||||
|
||||
S="${WORKDIR}/${PN}-${PV}rc1"
|
@ -1 +0,0 @@
|
||||
DIST yapf-0.24.0.tar.gz 145607 SHA256 b249ee4a79f0bde2473ab2238dfbb311ae0e789b270779090f77df3269d74821 SHA512 daa61faaa2877af8bc8579b1f6a8e9cf177d1caf27e0430cc508b86b42d907186a0fe14913530368097b888f12c19fc601fbcc1c4e605341ca328e8bf40ea399 WHIRLPOOL 8c0ac36df289bd6fc8feb1e46a55877c588f701820bfec5aab1325c849bc085853c7bbb282afddc6ed68ce258548c7907b7a55ac637bdd3520988cb413d74ba6
|
@ -1,18 +0,0 @@
|
||||
<?xml version='1.0' encoding='UTF-8'?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<maintainer type="person">
|
||||
<email>horea.christ@gmail.com</email>
|
||||
<name>Horea Christian</name>
|
||||
</maintainer>
|
||||
<maintainer type="project">
|
||||
<email>proxy-maint@gentoo.org</email>
|
||||
<name>Proxy Maintainers</name>
|
||||
</maintainer>
|
||||
<longdescription lang="en">
|
||||
YAPF is based off of 'clang-format', developed by Daniel Jasper.
|
||||
In essence, the algorithm takes the code and reformats it to the best
|
||||
formatting that conforms to the style guide, even if the original code
|
||||
didn't violate the style guide.
|
||||
</longdescription>
|
||||
</pkgmetadata>
|
@ -1,23 +0,0 @@
|
||||
# Copyright 2018 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=7
|
||||
|
||||
PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="A formatter for Python files"
|
||||
HOMEPAGE="https://github.com/google/yapf"
|
||||
SRC_URI="https://github.com/google/yapf/archive/v${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test"
|
||||
|
||||
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
|
||||
RDEPEND="${DEPEND}"
|
||||
|
||||
python_test() {
|
||||
esetup.py test || die
|
||||
}
|
@ -1 +0,0 @@
|
||||
DIST hdf5-1.10.5.tar.bz2 8706317 SHA256 68d6ea8843d2a106ec6a7828564c1689c7a85714a35d8efafa2fee20ca366f44 SHA512 769e43b8672e26fe24ed68da0228c010d3d9bc950ca09f0bc60707911a2f26f2f8415c8abc8ec06e07667148d8cdb3b0c7b3e7860d9b19739629c5dfd5ce73d4 WHIRLPOOL 29eb782010dc03310e623cacf3aa71b0b9bf3abc01170a870ed62f6a767784513f4757d447e8a9b1ab9d833f4a799a39551d9bd8a78873dd43da31b274435b4c
|
@ -1,21 +0,0 @@
|
||||
Prevent build system with messing up LD_LIBRARY_PATH
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -125,8 +125,6 @@ settings_DATA=libhdf5.settings
|
||||
# Remove the generated .c file if errors occur unless HDF5_Make_Ignore
|
||||
# is set to ignore the error.
|
||||
H5Tinit.c: H5detect$(EXEEXT)
|
||||
- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
|
||||
- sed -e 's/-L/:/g' -e 's/ //g'`" \
|
||||
$(RUNSERIAL) ./H5detect$(EXEEXT) > $@ || \
|
||||
(test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
|
||||
($(RM) $@ ; exit 1)
|
||||
@@ -137,8 +135,6 @@ H5Tinit.c: H5detect$(EXEEXT)
|
||||
# Remove the generated .c file if errors occur unless HDF5_Make_Ignore
|
||||
# is set to ignore the error.
|
||||
H5lib_settings.c: H5make_libsettings$(EXEEXT) libhdf5.settings
|
||||
- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
|
||||
- sed -e 's/-L/:/g' -e 's/ //g'`" \
|
||||
$(RUNSERIAL) ./H5make_libsettings$(EXEEXT) > $@ || \
|
||||
(test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
|
||||
($(RM) $@ ; exit 1)
|
@ -1,43 +0,0 @@
|
||||
--- a/hl/src/H5LTanalyze.c
|
||||
+++ b/hl/src/H5LTanalyze.c
|
||||
@@ -40,6 +40,7 @@
|
||||
#include <string.h>
|
||||
#include <errno.h>
|
||||
#include <stdlib.h>
|
||||
+#include <unistd.h>
|
||||
|
||||
/* end standard C headers. */
|
||||
|
||||
--- a/hl/src/H5LTanalyze.l
|
||||
+++ b/hl/src/H5LTanalyze.l
|
||||
@@ -16,6 +16,7 @@
|
||||
%{
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
+#include <unistd.h>
|
||||
#include <hdf5.h>
|
||||
#include "H5LTparse.h"
|
||||
|
||||
--- a/test/cache_common.h
|
||||
+++ b/test/cache_common.h
|
||||
@@ -702,5 +702,8 @@ void validate_mdc_config(hid_t file_id,
|
||||
hbool_t compare_init,
|
||||
int test_num);
|
||||
|
||||
+hbool_t resize_configs_are_equal(const H5C_auto_size_ctl_t *a,
|
||||
+ const H5C_auto_size_ctl_t *b,
|
||||
+ hbool_t compare_init);
|
||||
#endif /* _CACHE_COMMON_H */
|
||||
|
||||
--- a/testpar/t_span_tree.c
|
||||
+++ b/testpar/t_span_tree.c
|
||||
@@ -37,6 +37,9 @@
|
||||
#include "hdf5.h"
|
||||
#include "H5private.h"
|
||||
#include "testphdf5.h"
|
||||
+#define H5S_PACKAGE
|
||||
+#define H5S_TESTING
|
||||
+#include "H5Spkg.h"
|
||||
|
||||
|
||||
static void coll_write_test(int chunk_factor);
|
@ -1,16 +0,0 @@
|
||||
Prevent accidental inclusion of mpi c++ headers
|
||||
when hdf5.h is included third party library
|
||||
|
||||
https://bugs.gentoo.org/show_bug.cgi?id=420777
|
||||
|
||||
--- a/src/H5public.h
|
||||
+++ b/src/H5public.h
|
||||
@@ -58,6 +58,8 @@
|
||||
# include <stddef.h>
|
||||
#endif
|
||||
#ifdef H5_HAVE_PARALLEL
|
||||
+# define OMPI_SKIP_MPICXX /* Make sure that cxx specific headers are not included */
|
||||
+# define MPICH_SKIP_MPICXX
|
||||
# include <mpi.h>
|
||||
#ifndef MPI_FILE_NULL /*MPIO may be defined in mpi.h already */
|
||||
# include <mpio.h>
|
@ -1,15 +0,0 @@
|
||||
Make sure that during runtime we'll use the same libgfortran as during linking
|
||||
|
||||
https://bugs.gentoo.org/show_bug.cgi?id=419991
|
||||
https://bugs.gentoo.org/show_bug.cgi?id=419895
|
||||
|
||||
--- a/fortran/src/Makefile.am
|
||||
+++ b/fortran/src/Makefile.am
|
||||
@@ -181,6 +181,7 @@
|
||||
else
|
||||
H5test_kind_SOURCES = $(srcdir)/H5test_kind.f90
|
||||
endif
|
||||
+H5test_kind_LDFLAGS=-static-libgfortran
|
||||
|
||||
# Mark this directory as part of the Fortran API
|
||||
FORTRAN_API=yes
|
@ -1,95 +0,0 @@
|
||||
# Copyright 1999-2017 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=5
|
||||
|
||||
FORTRAN_NEEDED=fortran
|
||||
AUTOTOOLS_AUTORECONF=1
|
||||
|
||||
inherit autotools-utils eutils fortran-2 flag-o-matic toolchain-funcs multilib versionator prefix
|
||||
|
||||
MY_P=${PN}-${PV/_p/-patch}
|
||||
MAJOR_P=${PN}-$(get_version_component_range 1-2 ${PV})
|
||||
|
||||
DESCRIPTION="General purpose library and file format for storing scientific data"
|
||||
HOMEPAGE="http://www.hdfgroup.org/HDF5/"
|
||||
SRC_URI="http://www.hdfgroup.org/ftp/HDF5/releases/${MAJOR_P}/${MY_P}/src/${MY_P}.tar.bz2"
|
||||
|
||||
LICENSE="NCSA-HDF"
|
||||
SLOT="0/${PV%%_p*}"
|
||||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
|
||||
IUSE="cxx debug examples fortran +hl mpi static-libs szip threads zlib"
|
||||
|
||||
REQUIRED_USE="
|
||||
cxx? ( !mpi ) mpi? ( !cxx )
|
||||
threads? ( !cxx !mpi !fortran !hl )"
|
||||
|
||||
RDEPEND="
|
||||
mpi? ( virtual/mpi[romio] )
|
||||
szip? ( virtual/szip )
|
||||
zlib? ( sys-libs/zlib:0= )"
|
||||
|
||||
DEPEND="${RDEPEND}
|
||||
sys-devel/libtool:2
|
||||
>=sys-devel/autoconf-2.69"
|
||||
|
||||
S="${WORKDIR}/${MY_P}"
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}"/${PN}-1.8.9-static_libgfortran.patch
|
||||
"${FILESDIR}"/${PN}-1.8.9-mpicxx.patch
|
||||
"${FILESDIR}"/${PN}-1.8.13-no-messing-ldpath.patch
|
||||
)
|
||||
|
||||
pkg_setup() {
|
||||
tc-export CXX CC AR # workaround for bug 285148
|
||||
use fortran && fortran-2_pkg_setup
|
||||
|
||||
if use mpi; then
|
||||
if has_version 'sci-libs/hdf5[-mpi]'; then
|
||||
ewarn "Installing hdf5 with mpi enabled with a previous hdf5 with mpi disabled may fail."
|
||||
ewarn "Try to uninstall the current hdf5 prior to enabling mpi support."
|
||||
fi
|
||||
export CC=mpicc
|
||||
use fortran && export FC=mpif90
|
||||
elif has_version 'sci-libs/hdf5[mpi]'; then
|
||||
ewarn "Installing hdf5 with mpi disabled while having hdf5 installed with mpi enabled may fail."
|
||||
ewarn "Try to uninstall the current hdf5 prior to disabling mpi support."
|
||||
fi
|
||||
}
|
||||
|
||||
src_prepare() {
|
||||
# respect gentoo examples directory
|
||||
sed \
|
||||
-e "s:hdf5_examples:doc/${PF}/examples:g" \
|
||||
-i $(find . -name Makefile.am) $(find . -name "run*.sh.in") || die
|
||||
sed \
|
||||
-e '/docdir/d' \
|
||||
-i config/commence.am || die
|
||||
if ! use examples; then
|
||||
sed -e '/^install:/ s/install-examples//' \
|
||||
-i Makefile.am || die #409091
|
||||
fi
|
||||
# enable shared libs by default for h5cc config utility
|
||||
sed -i -e "s/SHLIB:-no/SHLIB:-yes/g" tools/src/misc/h5cc.in || die
|
||||
hprefixify m4/libtool.m4
|
||||
autotools-utils_src_prepare
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
local myeconfargs=(
|
||||
--docdir="${EPREFIX}"/usr/share/doc/${PF}
|
||||
--enable-deprecated-symbols
|
||||
$(use debug && echo --enable-build-mode=debug || echo --enable-build-mode=production)
|
||||
$(use_enable debug codestack)
|
||||
$(use_enable cxx)
|
||||
$(use_enable fortran)
|
||||
$(use_enable hl)
|
||||
$(use_enable mpi parallel)
|
||||
$(use_enable threads threadsafe)
|
||||
$(use_with szip szlib)
|
||||
$(use_with threads pthread)
|
||||
$(use_with zlib)
|
||||
)
|
||||
autotools-utils_src_configure
|
||||
}
|
@ -1,20 +0,0 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<maintainer type="project">
|
||||
<email>sci@gentoo.org</email>
|
||||
<name>Gentoo Science Project</name>
|
||||
</maintainer>
|
||||
<longdescription>
|
||||
HDF5 is a file format and library for storing scientific data. HDF5
|
||||
was designed and implemented to address the deficiencies of HDF4.x. It
|
||||
has a more powerful and flexible data model, supports files larger
|
||||
than 2 GB, and supports parallel I/O.
|
||||
</longdescription>
|
||||
<use>
|
||||
<flag name="fortran2003">Enable new features that require Fortran 2003
|
||||
(http://www.hdfgroup.org/HDF5/doc/fortran/NewFeatures_F2003.pdf)</flag>
|
||||
<flag name="hl">Enable high level API
|
||||
(https://support.hdfgroup.org/HDF5/doc/HL/index.html)</flag>
|
||||
</use>
|
||||
</pkgmetadata>
|
@ -1,8 +0,0 @@
|
||||
29 Mar 2019; <chymera@gentoo.org>
|
||||
-files/0001-BUG-Wrap-TransformFileReader-TransformFileWriter.patch,
|
||||
-files/0002-COMP-Fixed-itkQuasiNewtonOptimizerv4-wrapping-warnin.patch,
|
||||
-files/0003-COMP-Fixed-itkGradientDescentOptimizerv4-wrapping-wa.patch,
|
||||
-files/0004-COMP-Warp-OptimizerParameterScalesEstimatorTemplate.patch,
|
||||
-files/0005-make-gdcm-helper-library-static.patch,
|
||||
-files/nrrdio-linking.patch, itk-5.0_rc1.ebuild, metadata.xml:
|
||||
sci-libs/itk: version bump 5.0 ahead of Gentoo Sci
|
@ -1 +0,0 @@
|
||||
DIST v5.0rc01.tar.gz 20944543 SHA256 fa6cd61bc39ccdc53808b9b0df5dd95d63a3c08be130e63ab0f4b77ca9594e46 SHA512 30e327708c7717bb2131911c86802c4104730d146b4263c68ae89384d3f01a6675b3abf5962af14cc7f40984cb1e8eedd911fe0f084a8deb4c79b4239b309728 WHIRLPOOL 6447eccbb17573233f750e3462dadd4c44c177613ca88520787579cc6e10ac523488e44dbf0f3e690a0cc009443b5adccdf62b588bdf6180dbda4a98b7d03cef
|
@ -1,145 +0,0 @@
|
||||
# Copyright 1999-2019 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=6
|
||||
|
||||
PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
|
||||
|
||||
inherit eutils toolchain-funcs cmake-utils python-single-r1
|
||||
|
||||
MY_PV="5.0rc01"
|
||||
|
||||
DESCRIPTION="NLM Insight Segmentation and Registration Toolkit"
|
||||
HOMEPAGE="http://www.itk.org"
|
||||
SRC_URI="https://github.com/InsightSoftwareConsortium/ITK/archive/v${MY_PV}.tar.gz"
|
||||
RESTRICT="primaryuri"
|
||||
|
||||
LICENSE="Apache-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
|
||||
IUSE="debug doc examples fftw python review test vtkglue"
|
||||
|
||||
RDEPEND="
|
||||
dev-libs/double-conversion:0=
|
||||
media-libs/openjpeg:2
|
||||
media-libs/libpng:0=
|
||||
media-libs/tiff:0=
|
||||
sci-libs/dcmtk:0=
|
||||
sci-libs/hdf5:0=[cxx]
|
||||
sys-libs/zlib:0=
|
||||
virtual/jpeg:0=
|
||||
fftw? ( sci-libs/fftw:3.0= )
|
||||
vtkglue? ( sci-libs/vtk:0=[python?] )
|
||||
"
|
||||
DEPEND="${RDEPEND}
|
||||
python? (
|
||||
${PYTHON_DEPS}
|
||||
>=dev-lang/swig-2.0:0
|
||||
>=dev-cpp/gccxml-0.9.0_pre20120309
|
||||
)
|
||||
doc? ( app-doc/doxygen )
|
||||
"
|
||||
|
||||
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
|
||||
|
||||
S="${WORKDIR}/ITK-${MY_PV}"
|
||||
|
||||
pkg_pretend() {
|
||||
if [[ -z ${ITK_COMPUTER_MEMORY_SIZE} ]]; then
|
||||
elog "To tune ITK to make the best use of working memory you can set"
|
||||
elog " ITK_COMPUTER_MEMORY_SIZE=XX"
|
||||
elog "in make.conf, default is 1 (unit is GB)"
|
||||
fi
|
||||
if use python && [[ -z ${ITK_WRAP_DIMS} ]]; then
|
||||
elog "For Python language bindings, you can define the dimensions"
|
||||
elog "you want to create bindings for by setting"
|
||||
elog " ITK_WRAP_DIMS=X;Y;Z..."
|
||||
elog "in make.conf, default is 2;3 for 2D and 3D data"
|
||||
fi
|
||||
}
|
||||
|
||||
src_prepare() {
|
||||
sed -i -e "s/find_package(OpenJPEG 2.0.0/find_package(OpenJPEG/g"\
|
||||
Modules/ThirdParty/GDCM/src/gdcm/CMakeLists.txt
|
||||
default
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
local mycmakeargs=(
|
||||
-DBUILD_SHARED_LIBS=ON
|
||||
-DITK_USE_SYSTEM_DCMTK=ON
|
||||
-DGDCM_USE_SYSTEM_OPENJPEG=ON
|
||||
-DITK_USE_SYSTEM_DOUBLECONVERSION=ON
|
||||
-DITK_USE_SYSTEM_CASTXML=ON
|
||||
-DITK_USE_SYSTEM_HDF5=ON
|
||||
-DITK_USE_SYSTEM_JPEG=ON
|
||||
-DITK_USE_SYSTEM_PNG=ON
|
||||
-DITK_USE_SYSTEM_SWIG=ON
|
||||
-DITK_USE_SYSTEM_TIFF=ON
|
||||
-DITK_USE_SYSTEM_ZLIB=ON
|
||||
-DITK_BUILD_DEFAULT_MODULES=ON
|
||||
-DITK_COMPUTER_MEMORY_SIZE="${ITK_COMPUTER_MEMORY_SIZE:-1}"
|
||||
-DWRAP_ITK_JAVA=OFF
|
||||
-DWRAP_ITK_TCL=OFF
|
||||
-Ddouble-conversion_INCLUDE_DIRS="${EPREFIX}/usr/include/double-conversion"
|
||||
-DBUILD_TESTING="$(usex test)"
|
||||
-DBUILD_EXAMPLES="$(usex examples)"
|
||||
-DITK_USE_REVIEW="$(usex review)"
|
||||
-DITK_INSTALL_LIBRARY_DIR=$(get_libdir)
|
||||
)
|
||||
if use fftw; then
|
||||
mycmakeargs+=(
|
||||
-DUSE_FFTWD=ON
|
||||
-DUSE_FFTWF=ON
|
||||
-DUSE_SYSTEM_FFTW=ON
|
||||
-DITK_WRAP_double=ON
|
||||
-DITK_WRAP_vector_double=ON
|
||||
-DITK_WRAP_covariant_vector_double=ON
|
||||
-DITK_WRAP_complex_double=ON
|
||||
)
|
||||
fi
|
||||
if use vtkglue; then
|
||||
mycmakeargs+=(
|
||||
-DModule_ITKVtkGlue=ON
|
||||
)
|
||||
fi
|
||||
if use python; then
|
||||
mycmakeargs+=(
|
||||
-DITK_WRAP_PYTHON=ON
|
||||
-DITK_WRAP_DIMS="${ITK_WRAP_DIMS:-2;3}"
|
||||
)
|
||||
else
|
||||
mycmakeargs+=(
|
||||
-DITK_WRAP_PYTHON=OFF
|
||||
)
|
||||
fi
|
||||
cmake-utils_src_configure
|
||||
}
|
||||
|
||||
src_install() {
|
||||
cmake-utils_src_install
|
||||
|
||||
if use examples; then
|
||||
insinto /usr/share/doc/${PF}/examples
|
||||
docompress -x /usr/share/doc/${PF}/examples
|
||||
doins -r "${S}"/Examples/*
|
||||
fi
|
||||
|
||||
echo "ITK_DATA_ROOT=${EROOT%/}/usr/share/${PN}/data" > ${T}/40${PN}
|
||||
local ldpath="${EROOT%/}/usr/$(get_libdir)/InsightToolkit"
|
||||
if use python; then
|
||||
echo "PYTHONPATH=${EROOT%/}/usr/$(get_libdir)/InsightToolkit/WrapITK/Python" >> "${T}"/40${PN}
|
||||
ldpath="${ldpath}:${EROOT%/}/usr/$(get_libdir)/InsightToolkit/WrapITK/lib"
|
||||
fi
|
||||
echo "LDPATH=${ldpath}" >> "${T}"/40${PN}
|
||||
doenvd "${T}"/40${PN}
|
||||
|
||||
if use doc; then
|
||||
insinto /usr/share/doc/${PF}/api-docs
|
||||
cd "${WORKDIR}"/html
|
||||
rm *.md5 || die "Failed to remove superfluous hashes"
|
||||
einfo "Installing API docs. This may take some time."
|
||||
insinto /usr/share/doc/${PF}/api-docs
|
||||
doins -r *
|
||||
fi
|
||||
}
|
@ -1,23 +0,0 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<maintainer type="project">
|
||||
<email>maintainer-wanted@gentoo.org</email>
|
||||
</maintainer>
|
||||
<maintainer type="project">
|
||||
<email>sci-biology@gentoo.org</email>
|
||||
<name>Gentoo Biology Project</name>
|
||||
</maintainer>
|
||||
<longdescription lang="en">
|
||||
Insight Segmentation and Registration Toolkit (ITK) is a library
|
||||
that provides developers with an extensive suite of tools for image
|
||||
analysis.
|
||||
</longdescription>
|
||||
<use>
|
||||
<flag name="review">Enable compilation of methods under review</flag>
|
||||
<flag name="vtkglue">PLEASE FIX MY DESCRIPTION</flag>
|
||||
</use>
|
||||
<upstream>
|
||||
<remote-id type="sourceforge">itk</remote-id>
|
||||
</upstream>
|
||||
</pkgmetadata>
|
Loading…
x
Reference in New Issue
Block a user