sci-libs/itk: version bump 5.0 ahead of Gentoo Sci
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Horea Christian <horea.christ@yandex.com>
This commit is contained in:
parent
baf4cbdae1
commit
c5fe10867e
8
sci-libs/itk/ChangeLog
Normal file
8
sci-libs/itk/ChangeLog
Normal file
@ -0,0 +1,8 @@
|
|||||||
|
29 Mar 2019; <chymera@gentoo.org>
|
||||||
|
-files/0001-BUG-Wrap-TransformFileReader-TransformFileWriter.patch,
|
||||||
|
-files/0002-COMP-Fixed-itkQuasiNewtonOptimizerv4-wrapping-warnin.patch,
|
||||||
|
-files/0003-COMP-Fixed-itkGradientDescentOptimizerv4-wrapping-wa.patch,
|
||||||
|
-files/0004-COMP-Warp-OptimizerParameterScalesEstimatorTemplate.patch,
|
||||||
|
-files/0005-make-gdcm-helper-library-static.patch,
|
||||||
|
-files/nrrdio-linking.patch, itk-5.0_rc1.ebuild, metadata.xml:
|
||||||
|
sci-libs/itk: version bump 5.0 ahead of Gentoo Sci
|
@ -1,50 +0,0 @@
|
|||||||
From d069b7b94287dae15fcaf707775f5dd2bbebcc38 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Matt McCormick <matt.mccormick@kitware.com>
|
|
||||||
Date: Wed, 5 Feb 2014 15:52:34 -0500
|
|
||||||
Subject: [PATCH 1/3] BUG: Wrap TransformFileReader, TransformFileWriter.
|
|
||||||
|
|
||||||
Missing CMakeLists.txt in the wrapping directory. Need to explicitly include
|
|
||||||
the headers after "Template" was appended to the class name.
|
|
||||||
|
|
||||||
Suggested-by: Sami Koho <sami.koho@gmail.com>
|
|
||||||
|
|
||||||
Change-Id: I6f994bb18f37d5adf1d0f0311fa73506c41239a7
|
|
||||||
---
|
|
||||||
Modules/IO/TransformBase/wrapping/CMakeLists.txt | 3 +++
|
|
||||||
Modules/IO/TransformBase/wrapping/itkTransformFileReader.wrap | 2 ++
|
|
||||||
Modules/IO/TransformBase/wrapping/itkTransformFileWriter.wrap | 2 ++
|
|
||||||
3 files changed, 7 insertions(+)
|
|
||||||
create mode 100644 Modules/IO/TransformBase/wrapping/CMakeLists.txt
|
|
||||||
|
|
||||||
diff --git a/Modules/IO/TransformBase/wrapping/CMakeLists.txt b/Modules/IO/TransformBase/wrapping/CMakeLists.txt
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..6072567
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/Modules/IO/TransformBase/wrapping/CMakeLists.txt
|
|
||||||
@@ -0,0 +1,3 @@
|
|
||||||
+itk_wrap_module(ITKIOTransformBase)
|
|
||||||
+itk_auto_load_submodules()
|
|
||||||
+itk_end_wrap_module()
|
|
||||||
diff --git a/Modules/IO/TransformBase/wrapping/itkTransformFileReader.wrap b/Modules/IO/TransformBase/wrapping/itkTransformFileReader.wrap
|
|
||||||
index 9b52fbc..662df9e 100644
|
|
||||||
--- a/Modules/IO/TransformBase/wrapping/itkTransformFileReader.wrap
|
|
||||||
+++ b/Modules/IO/TransformBase/wrapping/itkTransformFileReader.wrap
|
|
||||||
@@ -1,3 +1,5 @@
|
|
||||||
+set(WRAPPER_AUTO_INCLUDE_HEADERS OFF)
|
|
||||||
+itk_wrap_include("itkTransformFileReader.h")
|
|
||||||
itk_wrap_class("itk::TransformFileReaderTemplate" POINTER)
|
|
||||||
foreach(t ${WRAP_ITK_REAL})
|
|
||||||
itk_wrap_template("${ITKM_${t}}" "${ITKT_${t}}")
|
|
||||||
diff --git a/Modules/IO/TransformBase/wrapping/itkTransformFileWriter.wrap b/Modules/IO/TransformBase/wrapping/itkTransformFileWriter.wrap
|
|
||||||
index 4f1ac4a..356aaf3 100644
|
|
||||||
--- a/Modules/IO/TransformBase/wrapping/itkTransformFileWriter.wrap
|
|
||||||
+++ b/Modules/IO/TransformBase/wrapping/itkTransformFileWriter.wrap
|
|
||||||
@@ -1,3 +1,5 @@
|
|
||||||
+set(WRAPPER_AUTO_INCLUDE_HEADERS OFF)
|
|
||||||
+itk_wrap_include("itkTransformFileWriter.h")
|
|
||||||
itk_wrap_class("itk::TransformFileWriterTemplate" POINTER)
|
|
||||||
foreach(t ${WRAP_ITK_REAL})
|
|
||||||
itk_wrap_template("${ITKM_${t}}" "${ITKT_${t}}")
|
|
||||||
--
|
|
||||||
1.8.5.3
|
|
||||||
|
|
@ -1,28 +0,0 @@
|
|||||||
From 66d2955fbe5528d9df216c639277d1d2686447e5 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michka Popoff <michkapopoff@gmail.com>
|
|
||||||
Date: Fri, 7 Feb 2014 19:24:49 +0100
|
|
||||||
Subject: [PATCH 2/3] COMP: Fixed itkQuasiNewtonOptimizerv4 wrapping warnings
|
|
||||||
|
|
||||||
The warning :
|
|
||||||
/scratch/dashboards/Linux-x86_64-gcc4.4-WrapITK/ITK-build/Wrapping/Modules/ITKOptimizersv4/itkQuasiNewtonOptimizerv4.xml: warning(5): Unknown type type: itk::QuasiNewtonOptimizerv4 [typedef]
|
|
||||||
/scratch/dashboards/Linux-x86_64-gcc4.4-WrapITK/ITK-build/Wrapping/Modules/ITKOptimizersv4/itkQuasiNewtonOptimizerv4.xml: warning(4): ITK type not wrapped, or currently not known: itk::QuasiNewtonOptimizerv4Template< double >
|
|
||||||
---
|
|
||||||
.../Numerics/Optimizersv4/wrapping/itkQuasiNewtonOptimizerv4.wrap | 8 +++++++-
|
|
||||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/Modules/Numerics/Optimizersv4/wrapping/itkQuasiNewtonOptimizerv4.wrap b/Modules/Numerics/Optimizersv4/wrapping/itkQuasiNewtonOptimizerv4.wrap
|
|
||||||
index 4a43dd4..7eed11c 100644
|
|
||||||
--- a/Modules/Numerics/Optimizersv4/wrapping/itkQuasiNewtonOptimizerv4.wrap
|
|
||||||
+++ b/Modules/Numerics/Optimizersv4/wrapping/itkQuasiNewtonOptimizerv4.wrap
|
|
||||||
@@ -1 +1,7 @@
|
|
||||||
-itk_wrap_simple_class("itk::QuasiNewtonOptimizerv4" POINTER)
|
|
||||||
+set(WRAPPER_AUTO_INCLUDE_HEADERS OFF)
|
|
||||||
+itk_wrap_include("itkQuasiNewtonOptimizerv4.h")
|
|
||||||
+itk_wrap_class("itk::QuasiNewtonOptimizerv4Template" POINTER)
|
|
||||||
+ foreach(t ${WRAP_ITK_REAL})
|
|
||||||
+ itk_wrap_template("${ITKM_${t}}" "${ITKT_${t}}")
|
|
||||||
+ endforeach(t)
|
|
||||||
+itk_end_wrap_class()
|
|
||||||
--
|
|
||||||
1.8.5.3
|
|
||||||
|
|
@ -1,73 +0,0 @@
|
|||||||
From fced46ce8769b4edc7971ea0928045390b5c3f84 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michka Popoff <michkapopoff@gmail.com>
|
|
||||||
Date: Mon, 10 Feb 2014 09:41:42 +0100
|
|
||||||
Subject: [PATCH 3/3] COMP: Fixed itkGradientDescentOptimizerv4 wrapping
|
|
||||||
warnings
|
|
||||||
|
|
||||||
I splitted the 3 wrapping calls in 3 separate files and fixed the wrapping.
|
|
||||||
|
|
||||||
The warnings :
|
|
||||||
/home/kevin/kitware/ITK_Build/Wrapping/Modules/ITKOptimizersv4/itkGradientDescentOptimizerv4.xml: warning(5): Unknown type type: itk::GradientDescentOptimizerBasev4 [typedef]
|
|
||||||
/home/kevin/kitware/ITK_Build/Wrapping/Modules/ITKOptimizersv4/itkGradientDescentOptimizerv4.xml: warning(5): Unknown type type: itk::GradientDescentOptimizerv4 [typedef]
|
|
||||||
/home/kevin/kitware/ITK_Build/Wrapping/Modules/ITKOptimizersv4/itkGradientDescentOptimizerv4.xml: warning(5): Unknown type type: itk::ObjectToObjectOptimizerBase [typedef]
|
|
||||||
/home/kevin/kitware/ITK_Build/Wrapping/Modules/ITKOptimizersv4/itkGradientDescentOptimizerv4.xml: warning(4): ITK type not wrapped, or currently not known: itk::GradientDescentOptimizerBasev4Template< double >
|
|
||||||
/home/kevin/kitware/ITK_Build/Wrapping/Modules/ITKOptimizersv4/itkGradientDescentOptimizerv4.xml: warning(4): ITK type not wrapped, or currently not known: itk::GradientDescentOptimizerv4Template< double >
|
|
||||||
/home/kevin/kitware/ITK_Build/Wrapping/Modules/ITKOptimizersv4/itkGradientDescentOptimizerv4.xml: warning(4): ITK type not wrapped, or currently not known: itk::ObjectToObjectOptimizerBaseTemplate< double >
|
|
||||||
|
|
||||||
Should also hopefully fix the new error on the dashboard I introduced by fixing the itkQuasiNewtonOptimizerv4 warnings (http://review.source.kitware.com/#/c/14317/)
|
|
||||||
/home/kevin/kitware/ITK_Build/Wrapping/Typedefs/itkQuasiNewtonOptimizerv4.i:87: Warning 401: Nothing known about base class 'itk::GradientDescentOptimizerv4Template< float >'. Ignored.
|
|
||||||
/home/kevin/kitware/ITK_Build/Wrapping/Typedefs/itkQuasiNewtonOptimizerv4.i:87: Warning 401: Maybe you forgot to instantiate 'itk::GradientDescentOptimizerv4Template< float >' using %template.
|
|
||||||
|
|
||||||
Change-Id: I15b6af11690ed6efeaced68f73af5212ab5dc364
|
|
||||||
---
|
|
||||||
.../wrapping/itkGradientDescentOptimizerBasev4.wrap | 7 +++++++
|
|
||||||
.../Optimizersv4/wrapping/itkGradientDescentOptimizerv4.wrap | 10 +++++++---
|
|
||||||
.../Optimizersv4/wrapping/itkObjectToObjectOptimizerBase.wrap | 7 +++++++
|
|
||||||
3 files changed, 21 insertions(+), 3 deletions(-)
|
|
||||||
create mode 100644 Modules/Numerics/Optimizersv4/wrapping/itkGradientDescentOptimizerBasev4.wrap
|
|
||||||
create mode 100644 Modules/Numerics/Optimizersv4/wrapping/itkObjectToObjectOptimizerBase.wrap
|
|
||||||
|
|
||||||
diff --git a/Modules/Numerics/Optimizersv4/wrapping/itkGradientDescentOptimizerBasev4.wrap b/Modules/Numerics/Optimizersv4/wrapping/itkGradientDescentOptimizerBasev4.wrap
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..74f5a6c
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/Modules/Numerics/Optimizersv4/wrapping/itkGradientDescentOptimizerBasev4.wrap
|
|
||||||
@@ -0,0 +1,7 @@
|
|
||||||
+set(WRAPPER_AUTO_INCLUDE_HEADERS OFF)
|
|
||||||
+itk_wrap_include("itkGradientDescentOptimizerBasev4.h")
|
|
||||||
+itk_wrap_class("itk::GradientDescentOptimizerBasev4Template" POINTER)
|
|
||||||
+ foreach(t ${WRAP_ITK_REAL})
|
|
||||||
+ itk_wrap_template("${ITKM_${t}}" "${ITKT_${t}}")
|
|
||||||
+ endforeach(t)
|
|
||||||
+itk_end_wrap_class()
|
|
||||||
diff --git a/Modules/Numerics/Optimizersv4/wrapping/itkGradientDescentOptimizerv4.wrap b/Modules/Numerics/Optimizersv4/wrapping/itkGradientDescentOptimizerv4.wrap
|
|
||||||
index d53a176..3236448 100644
|
|
||||||
--- a/Modules/Numerics/Optimizersv4/wrapping/itkGradientDescentOptimizerv4.wrap
|
|
||||||
+++ b/Modules/Numerics/Optimizersv4/wrapping/itkGradientDescentOptimizerv4.wrap
|
|
||||||
@@ -1,3 +1,7 @@
|
|
||||||
-itk_wrap_simple_class("itk::ObjectToObjectOptimizerBase" POINTER)
|
|
||||||
-itk_wrap_simple_class("itk::GradientDescentOptimizerBasev4" POINTER)
|
|
||||||
-itk_wrap_simple_class("itk::GradientDescentOptimizerv4" POINTER)
|
|
||||||
+set(WRAPPER_AUTO_INCLUDE_HEADERS OFF)
|
|
||||||
+itk_wrap_include("itkGradientDescentOptimizerv4.h")
|
|
||||||
+itk_wrap_class("itk::GradientDescentOptimizerv4Template" POINTER)
|
|
||||||
+ foreach(t ${WRAP_ITK_REAL})
|
|
||||||
+ itk_wrap_template("${ITKM_${t}}" "${ITKT_${t}}")
|
|
||||||
+ endforeach(t)
|
|
||||||
+itk_end_wrap_class()
|
|
||||||
diff --git a/Modules/Numerics/Optimizersv4/wrapping/itkObjectToObjectOptimizerBase.wrap b/Modules/Numerics/Optimizersv4/wrapping/itkObjectToObjectOptimizerBase.wrap
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..61b2c44
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/Modules/Numerics/Optimizersv4/wrapping/itkObjectToObjectOptimizerBase.wrap
|
|
||||||
@@ -0,0 +1,7 @@
|
|
||||||
+set(WRAPPER_AUTO_INCLUDE_HEADERS OFF)
|
|
||||||
+itk_wrap_include("itkObjectToObjectOptimizerBase.h")
|
|
||||||
+itk_wrap_class("itk::ObjectToObjectOptimizerBaseTemplate" POINTER)
|
|
||||||
+ foreach(t ${WRAP_ITK_REAL})
|
|
||||||
+ itk_wrap_template("${ITKM_${t}}" "${ITKT_${t}}")
|
|
||||||
+ endforeach(t)
|
|
||||||
+itk_end_wrap_class()
|
|
||||||
--
|
|
||||||
1.8.5.3
|
|
||||||
|
|
@ -1,30 +0,0 @@
|
|||||||
Author: Matt McCormick <matt.mccormick@kitware.com>
|
|
||||||
Date: Thu Feb 6 10:26:49 2014 -0500
|
|
||||||
|
|
||||||
COMP: Wrap OptimizerParameterScalesEstimatorTemplate.
|
|
||||||
|
|
||||||
The class name changed and it became templated. Fixes:
|
|
||||||
|
|
||||||
/playpen/blowekamp/MacOSX-WrapITK/ITK-build/Wrapping/Modules/ITKOptimizersv4/itkOptimizerParameterScalesEstimator.xml:
|
|
||||||
warning(5): Unknown type type: itk::OptimizerParameterScalesEstimator
|
|
||||||
[typedef]
|
|
||||||
/playpen/blowekamp/MacOSX-WrapITK/ITK-build/Wrapping/Modules/ITKOptimizersv4/itkOptimizerParameterScalesEstimator.xml:
|
|
||||||
warning(4): ITK type not wrapped, or currently not known:
|
|
||||||
itk::OptimizerParameterScalesEstimatorTemplate< double >
|
|
||||||
|
|
||||||
Change-Id: Ic6b4d6fba10d5d6c7b58de8d842bad6511e1ae7b
|
|
||||||
|
|
||||||
diff --git a/Modules/Numerics/Optimizersv4/wrapping/itkOptimizerParameterScalesEstimator.wrap b/Modules/Numerics/Optimizersv4/wrapping/itkOptim
|
|
||||||
index efd6a8c..a647ee4 100644
|
|
||||||
--- a/Modules/Numerics/Optimizersv4/wrapping/itkOptimizerParameterScalesEstimator.wrap
|
|
||||||
+++ b/Modules/Numerics/Optimizersv4/wrapping/itkOptimizerParameterScalesEstimator.wrap
|
|
||||||
@@ -1 +1,7 @@
|
|
||||||
-itk_wrap_simple_class("itk::OptimizerParameterScalesEstimator" POINTER)
|
|
||||||
+set(WRAPPER_AUTO_INCLUDE_HEADERS OFF)
|
|
||||||
+itk_wrap_include("itkOptimizerParameterScalesEstimator.h")
|
|
||||||
+itk_wrap_class("itk::OptimizerParameterScalesEstimatorTemplate" POINTER)
|
|
||||||
+ foreach(t ${WRAP_ITK_REAL})
|
|
||||||
+ itk_wrap_template("${ITKM_${t}}" "${ITKT_${t}}")
|
|
||||||
+ endforeach(t)
|
|
||||||
+itk_end_wrap_class()
|
|
||||||
|
|
@ -1,11 +0,0 @@
|
|||||||
diff --git a/Modules/ThirdParty/GDCM/src/CMakeLists.txt b/Modules/ThirdParty/GDCM/src/CMakeLists.txt
|
|
||||||
index e98077c..70f4286 100644
|
|
||||||
--- a/Modules/ThirdParty/GDCM/src/CMakeLists.txt
|
|
||||||
+++ b/Modules/ThirdParty/GDCM/src/CMakeLists.txt
|
|
||||||
@@ -1,5 +1,5 @@
|
|
||||||
if(ITK_USE_SYSTEM_GDCM)
|
|
||||||
- add_library(ITKGDCM ITK-GDCM.cxx)
|
|
||||||
+ add_library(ITKGDCM STATIC ITK-GDCM.cxx)
|
|
||||||
target_link_libraries(ITKGDCM gdcmDICT gdcmMSFF)
|
|
||||||
itk_module_target(ITKGDCM)
|
|
||||||
return()
|
|
@ -1,15 +0,0 @@
|
|||||||
Description: Link libITKNrrdIO with -lm (needed for sqrt)
|
|
||||||
Author: Steve Robbins <smr@debian.org>
|
|
||||||
Forwarded: no
|
|
||||||
|
|
||||||
--- insighttoolkit4-4.5.0.orig/Modules/ThirdParty/NrrdIO/src/NrrdIO/CMakeLists.txt
|
|
||||||
+++ insighttoolkit4-4.5.0/Modules/ThirdParty/NrrdIO/src/NrrdIO/CMakeLists.txt
|
|
||||||
@@ -64,7 +64,7 @@
|
|
||||||
ADD_DEFINITIONS(-DTEEM_ZLIB=1)
|
|
||||||
|
|
||||||
ADD_LIBRARY(ITKNrrdIO ${nrrdio_SRCS} )
|
|
||||||
-TARGET_LINK_LIBRARIES(ITKNrrdIO ${ITKZLIB_LIBRARIES})
|
|
||||||
+TARGET_LINK_LIBRARIES(ITKNrrdIO ${ITKZLIB_LIBRARIES} -lm)
|
|
||||||
|
|
||||||
IF(ITK_LIBRARY_PROPERTIES)
|
|
||||||
SET_TARGET_PROPERTIES(ITKNrrdIO PROPERTIES ${ITK_LIBRARY_PROPERTIES})
|
|
@ -1,4 +1,4 @@
|
|||||||
# Copyright 1999-2019 Gentoo Foundation
|
# Copyright 1999-2019 Gentoo Authors
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
EAPI=6
|
EAPI=6
|
||||||
@ -59,7 +59,7 @@ pkg_pretend() {
|
|||||||
}
|
}
|
||||||
|
|
||||||
src_prepare() {
|
src_prepare() {
|
||||||
sed -i -e "s/find_package(OpenJPEG 2.0.0/find_package(OpenJPEG 2.*/g"\
|
sed -i -e "s/find_package(OpenJPEG 2.0.0/find_package(OpenJPEG/g"\
|
||||||
Modules/ThirdParty/GDCM/src/gdcm/CMakeLists.txt
|
Modules/ThirdParty/GDCM/src/gdcm/CMakeLists.txt
|
||||||
default
|
default
|
||||||
}
|
}
|
||||||
@ -70,7 +70,7 @@ src_configure() {
|
|||||||
-DITK_USE_SYSTEM_DCMTK=ON
|
-DITK_USE_SYSTEM_DCMTK=ON
|
||||||
-DGDCM_USE_SYSTEM_OPENJPEG=ON
|
-DGDCM_USE_SYSTEM_OPENJPEG=ON
|
||||||
-DITK_USE_SYSTEM_DOUBLECONVERSION=ON
|
-DITK_USE_SYSTEM_DOUBLECONVERSION=ON
|
||||||
#-DITK_USE_SYSTEM_GCCXML=ON
|
-DITK_USE_SYSTEM_CASTXML=ON
|
||||||
-DITK_USE_SYSTEM_HDF5=ON
|
-DITK_USE_SYSTEM_HDF5=ON
|
||||||
-DITK_USE_SYSTEM_JPEG=ON
|
-DITK_USE_SYSTEM_JPEG=ON
|
||||||
-DITK_USE_SYSTEM_PNG=ON
|
-DITK_USE_SYSTEM_PNG=ON
|
||||||
|
@ -14,7 +14,6 @@ that provides developers with an extensive suite of tools for image
|
|||||||
analysis.
|
analysis.
|
||||||
</longdescription>
|
</longdescription>
|
||||||
<use>
|
<use>
|
||||||
<flag name="itkv3compat">Enable compatibility with ITK version 3</flag>
|
|
||||||
<flag name="review">Enable compilation of methods under review</flag>
|
<flag name="review">Enable compilation of methods under review</flag>
|
||||||
<flag name="vtkglue">PLEASE FIX MY DESCRIPTION</flag>
|
<flag name="vtkglue">PLEASE FIX MY DESCRIPTION</flag>
|
||||||
</use>
|
</use>
|
||||||
|
Loading…
x
Reference in New Issue
Block a user