diff --git a/app-editors/atom/Manifest b/app-editors/atom/Manifest
new file mode 100644
index 0000000..9b54b3f
--- /dev/null
+++ b/app-editors/atom/Manifest
@@ -0,0 +1,6 @@
+AUX 0002-skip-atom-shell-copy.patch 421 SHA256 4d23cc437766bcb1b07bc8d1842cc5726dcddfdda603a191216e50c93ca4e39b SHA512 c81b3b1d00e66c02a7ecad7eb38660528bbcef69e584f2e7a54ed05f7fd1b31e179640010fc5699625993937f17f62668d25eb97109542e519be22546ccc9b42 WHIRLPOOL 6bb7eabea4789de4dbc345188914d35b5283fefc9562fc90ffa8684ac9b6d7d85b1f1143af2cf36e18285b18100ed2ff1cb45416f8a53bbe8730643330da99d9
+EBUILD atom-0.176.0.ebuild 2367 SHA256 4b9ea8892f0dae8304c5e1aa0529c5a1c259d89aacaf83f2d13e45c3414595cb SHA512 8e212b703f4393c8ab54d58dde81f4ef655f780b97f22b1fe71b50a6433c2daec8d245152f3d9c0caac8a0cb21cb177bbbcdda205fbcd0fef2a4fb3349891836 WHIRLPOOL b6920145cac21fb5597abfdbc9a7851d666590eddd705ccfc5459b73716300ef911889e41e280321d183c2ac6b6cf8946cccb7791a388a3c4e1bc092b705ab5d
+EBUILD atom-0.177.0.ebuild 2543 SHA256 782e2438d39042a65d8a438777803dcb40829ef57f847b3186922d76fecb808e SHA512 0dbe655982b3939091014e7b3102dcdcf058eed0b7db7646b9e6444a161e202495374b2f79b43032987d1f6ab2e7d7cde53d5c69099a57a16ddf5ca727c685ab WHIRLPOOL ea75f45eaf845d4565834f690693f6778c862c29213b8e5994344e40dcd15e55af408caf7939c5180fe6c363b637f7f0bf26b9e9a76e64af312d7ef499b737d6
+EBUILD atom-9999.ebuild 2369 SHA256 859a1c3248eff6f37512c2913a9d427b0c93a9320dcad75b43943c4ddd907d3b SHA512 c952ac5ec5799e270aba409afb5f5a256654d7a64a5e3ea68423481695e747484683de314612756ce039a4fcedce7053c06006b8dcf416dc173479e9472e71ef WHIRLPOOL 668c6ba022b27b1876192bedf435c0d415ef0b21f2dc21f53647cd728600765f5c91741014351572b7d726084bb3c8f731d9a2c415e11db3ee0baad249ba6ab8
+MISC atom-9999.ebuild.1 2536 SHA256 acd879684e3613f9618d8f7ef648c7612dc4495e7849655149a714a3b21b1284 SHA512 d21029d2ba73e9759ea26478ee35a3399b08d48f843711a92e771313d43bd8a76caf00dfdda7bbaa35c2e91cb534b7053ec371846e8859f1dfa4d7ea16a993b4 WHIRLPOOL 9c1d25dc29b740dd42d137c2c1cac1c10dbcb4cd49f6bacddcf39ba6714cc1ca40d9c9665ef659725fa81c81570347f4ae674e2ef5116363f7706af6805fd031
+MISC metadata.xml 411 SHA256 6844740e04599e2fd6f099ab791f2c2b02c2c2d7fa50efaa6efa91118ae4ac9d SHA512 38580ac93c54ae30c52992811245319b1bd3fe435e9f9e127fdc92fdca497b25e94d2cec11bf2a7f07a5f8586ca91dfbc9c940684cd4099b481d3b4ff267ed54 WHIRLPOOL f381c1b03880a5c542997bdad20fe5f09eb223ab6e661408d71308f21f8e1de3ef953fa88b1d2227308190090ec84bce0d3206434062ee785f608f50ab8fd4da
diff --git a/app-editors/atom/atom-0.176.0.ebuild b/app-editors/atom/atom-0.176.0.ebuild
new file mode 100644
index 0000000..ac76202
--- /dev/null
+++ b/app-editors/atom/atom-0.176.0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit git-r3 flag-o-matic python-any-r1 eutils
+
+DESCRIPTION="A hackable text editor for the 21st Century"
+HOMEPAGE="https://atom.io"
+SRC_URI=""
+
+EGIT_REPO_URI="git://github.com/atom/atom"
+
+LICENSE="MIT"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]];then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="v${PV}"
+fi
+
+IUSE=""
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-util/atom-shell:0/20
+ >=net-libs/nodejs-0.10.30[npm]
+ media-fonts/inconsolata
+"
+
+RDEPEND="${DEPEND}"
+
+QA_PRESTRIPPED="/usr/share/atom/resources/app/node_modules/symbols-view/vendor/ctags-linux"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+
+ npm config set python $PYTHON
+}
+
+src_unpack() {
+ git-r3_src_unpack
+}
+
+src_prepare() {
+ # Skip atom-shell download
+ sed -i -e "s/defaultTasks = \['download-atom-shell', /defaultTasks = [/g" \
+ ./build/Gruntfile.coffee \
+ || die "Failed to fix Gruntfile"
+
+ # Skip atom-shell copy
+ epatch "${FILESDIR}/0002-skip-atom-shell-copy.patch"
+
+ # Fix atom location guessing
+ sed -i -e 's/ATOM_PATH="$USR_DIRECTORY\/share\/atom/ATOM_PATH="$USR_DIRECTORY\/../g' \
+ ./atom.sh \
+ || die "Fail fixing atom-shell directory"
+}
+
+src_compile() {
+ ./script/build --verbose --build-dir "${T}" || die "Failed to compile"
+ "${T}/Atom/resources/app/apm/bin/apm" rebuild || die "Failed to rebuild native module"
+ # Setup python path to builtin npm
+ echo "python = $PYTHON" >> "${T}/Atom/resources/app/apm/.apmrc"
+}
+
+src_install() {
+ into /usr
+
+ insinto /usr/share/applications
+
+ insinto /usr/share/${PN}/resources/app
+ exeinto /usr/bin
+
+ cd "${T}/Atom/resources/app"
+ doicon resources/atom.png
+ dodoc LICENSE.md
+
+ # Installs everything in Atom/resources/app
+ doins -r .
+
+ # Fixes permissions
+ fperms +x /usr/share/${PN}/resources/app/atom.sh
+ fperms +x /usr/share/${PN}/resources/app/apm/bin/apm
+ fperms +x /usr/share/${PN}/resources/app/apm/bin/node
+ fperms +x /usr/share/${PN}/resources/app/apm/node_modules/npm/bin/node-gyp-bin/node-gyp
+
+ # Symlinking to /usr/bin
+ dosym ../share/${PN}/resources/app/atom.sh /usr/bin/atom
+ dosym ../share/${PN}/resources/app/apm/bin/apm /usr/bin/apm
+
+ make_desktop_entry "/usr/bin/atom %U" "Atom" "atom" "GNOME;GTK;Utility;TextEditor;Development;" "MimeType=text/plain;\nStartupNotify=true\nStartupWMClass=Atom"
+}
diff --git a/app-editors/atom/atom-0.177.0.ebuild b/app-editors/atom/atom-0.177.0.ebuild
new file mode 100644
index 0000000..989c468
--- /dev/null
+++ b/app-editors/atom/atom-0.177.0.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit git-r3 flag-o-matic python-any-r1 eutils
+
+DESCRIPTION="A hackable text editor for the 21st Century"
+HOMEPAGE="https://atom.io"
+SRC_URI=""
+
+EGIT_REPO_URI="git://github.com/atom/atom"
+
+LICENSE="MIT"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]];then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="v${PV}"
+fi
+
+IUSE=""
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-util/atom-shell:0/21
+ net-libs/nodejs[npm]
+ media-fonts/inconsolata
+"
+RDEPEND="${DEPEND}"
+
+QA_PRESTRIPPED="
+ /usr/share/atom/resources/app/node_modules/symbols-view/vendor/ctags-linux
+"
+pkg_setup() {
+ python-any-r1_pkg_setup
+
+ npm config set python $PYTHON
+}
+
+src_unpack() {
+ git-r3_src_unpack
+}
+
+src_prepare() {
+ # Skip atom-shell download
+ sed -i -e "s/defaultTasks = \['download-atom-shell', /defaultTasks = [/g" \
+ ./build/Gruntfile.coffee \
+ || die "Failed to fix Gruntfile"
+
+ # Skip atom-shell copy
+ epatch "${FILESDIR}/0002-skip-atom-shell-copy.patch"
+
+ # Fix atom location guessing
+ sed -i -e 's/ATOM_PATH="$USR_DIRECTORY\/share\/atom/ATOM_PATH="$USR_DIRECTORY\/../g' \
+ ./atom.sh \
+ || die "Fail fixing atom-shell directory"
+
+ # Make bootstrap process more verbose
+ sed -i -e 's@node script/bootstrap@node script/bootstrap --no-quiet@g' \
+ ./script/build \
+ || die "Fail fixing verbosity of script/build"
+}
+
+src_compile() {
+ ./script/build --verbose --build-dir "${T}" || die "Failed to compile"
+
+ "${T}/Atom/resources/app/apm/bin/apm" rebuild || die "Failed to rebuild native module"
+
+ # Setup python path to builtin npm
+ echo "python = $PYTHON" >> "${T}/Atom/resources/app/apm/.apmrc"
+}
+
+src_install() {
+
+ into /usr
+
+ insinto /usr/share/applications
+
+ insinto /usr/share/${PN}/resources/app
+ exeinto /usr/bin
+
+ cd "${T}/Atom/resources/app"
+ doicon resources/atom.png
+ dodoc LICENSE.md
+
+ # Installs everything in Atom/resources/app
+ doins -r .
+
+ # Fixes permissions
+ fperms +x /usr/share/${PN}/resources/app/atom.sh
+ fperms +x /usr/share/${PN}/resources/app/apm/bin/apm
+ fperms +x /usr/share/${PN}/resources/app/apm/bin/node
+ fperms +x /usr/share/${PN}/resources/app/apm/node_modules/npm/bin/node-gyp-bin/node-gyp
+
+ # Symlinking to /usr/bin
+ dosym ../share/${PN}/resources/app/atom.sh /usr/bin/atom
+ dosym ../share/${PN}/resources/app/apm/bin/apm /usr/bin/apm
+
+ make_desktop_entry "/usr/bin/atom %U" "Atom" "atom" "GNOME;GTK;Utility;TextEditor;Development;" "MimeType=text/plain;\nStartupNotify=true\nStartupWMClass=Atom"
+}
diff --git a/app-editors/atom/atom-9999.ebuild b/app-editors/atom/atom-9999.ebuild
index 8c459c3..3d9d9b7 100644
--- a/app-editors/atom/atom-9999.ebuild
+++ b/app-editors/atom/atom-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=5
+EAPI="5"
PYTHON_COMPAT=( python2_7 )
inherit git-r3 flag-o-matic python-any-r1 eutils
@@ -27,15 +27,15 @@ IUSE=""
DEPEND="
${PYTHON_DEPS}
- dev-util/atom-shell
+ dev-util/atom-shell:0/20
>=net-libs/nodejs-0.10.30[npm]
media-fonts/inconsolata
"
+
RDEPEND="${DEPEND}"
-QA_PRESTRIPPED="
- /usr/share/atom/node_modules/symbols-view/vendor/ctags-linux
-"
+QA_PRESTRIPPED="/usr/share/atom/resources/app/node_modules/symbols-view/vendor/ctags-linux"
+
pkg_setup() {
python-any-r1_pkg_setup
@@ -49,27 +49,27 @@ src_unpack() {
src_prepare() {
# Skip atom-shell download
sed -i -e "s/defaultTasks = \['download-atom-shell', /defaultTasks = [/g" \
- ./build/Gruntfile.coffee \
- || die "Failed to fix Gruntfile"
+ ./build/Gruntfile.coffee \
+ || die "Failed to fix Gruntfile"
# Skip atom-shell copy
epatch "${FILESDIR}/0002-skip-atom-shell-copy.patch"
# Fix atom location guessing
sed -i -e 's/ATOM_PATH="$USR_DIRECTORY\/share\/atom/ATOM_PATH="$USR_DIRECTORY\/../g' \
- ./atom.sh \
- || die "Fail fixing atom-shell directory"
+ ./atom.sh \
+ || die "Fail fixing atom-shell directory"
}
src_compile() {
./script/build --verbose --build-dir "${T}" || die "Failed to compile"
-
- "${T}/Atom/resources/app/apm/node_modules/atom-package-manager/bin/apm" rebuild || die "Failed to rebuild native module"
+ "${T}/Atom/resources/app/apm/bin/apm" rebuild || die "Failed to rebuild native module"
+ # Setup python path to builtin npm
+ echo "python = $PYTHON" >> "${T}/Atom/resources/app/apm/.apmrc"
}
src_install() {
-
- into /usr
+ into /usr
insinto /usr/share/applications
@@ -85,13 +85,13 @@ src_install() {
# Fixes permissions
fperms +x /usr/share/${PN}/resources/app/atom.sh
- fperms +x /usr/share/${PN}/resources/app/apm/node_modules/.bin/apm
- fperms +x /usr/share/${PN}/resources/app/apm/node_modules/atom-package-manager/bin/node
- fperms +x /usr/share/${PN}/resources/app/apm/node_modules/atom-package-manager/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js
+ fperms +x /usr/share/${PN}/resources/app/apm/bin/apm
+ fperms +x /usr/share/${PN}/resources/app/apm/bin/node
+ fperms +x /usr/share/${PN}/resources/app/apm/node_modules/npm/bin/node-gyp-bin/node-gyp
# Symlinking to /usr/bin
dosym ../share/${PN}/resources/app/atom.sh /usr/bin/atom
- dosym ../share/${PN}/resources/app/apm/node_modules/atom-package-manager/bin/apm /usr/bin/apm
+ dosym ../share/${PN}/resources/app/apm/bin/apm /usr/bin/apm
make_desktop_entry "/usr/bin/atom %U" "Atom" "atom" "GNOME;GTK;Utility;TextEditor;Development;" "MimeType=text/plain;\nStartupNotify=true\nStartupWMClass=Atom"
}
diff --git a/app-editors/atom/atom-9999.ebuild.1 b/app-editors/atom/atom-9999.ebuild.1
new file mode 100644
index 0000000..97202e5
--- /dev/null
+++ b/app-editors/atom/atom-9999.ebuild.1
@@ -0,0 +1,99 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit git-r3 flag-o-matic python-any-r1 eutils
+
+DESCRIPTION="A hackable text editor for the 21st Century"
+HOMEPAGE="https://atom.io"
+SRC_URI=""
+
+EGIT_REPO_URI="git://github.com/atom/atom"
+
+LICENSE="MIT"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]];then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="v${PV}"
+fi
+
+IUSE=""
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-util/atom-shell:0/21
+ net-libs/nodejs[npm]
+ media-fonts/inconsolata
+"
+
+RDEPEND="${DEPEND}"
+
+QA_PRESTRIPPED="/usr/share/atom/resources/app/node_modules/symbols-view/vendor/ctags-linux"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ npm config set python $PYTHON
+}
+
+src_unpack() {
+ git-r3_src_unpack
+}
+
+src_prepare() {
+ # Skip atom-shell download
+ sed -i -e "s/defaultTasks = \['download-atom-shell', /defaultTasks = [/g" \
+ ./build/Gruntfile.coffee \
+ || die "Failed to fix Gruntfile"
+
+ # Skip atom-shell copy
+ epatch "${FILESDIR}/0002-skip-atom-shell-copy.patch"
+
+ # Fix atom location guessing
+ sed -i -e 's/ATOM_PATH="$USR_DIRECTORY\/share\/atom/ATOM_PATH="$USR_DIRECTORY\/../g' \
+ ./atom.sh \
+ || die "Fail fixing atom-shell directory"
+
+ # Make bootstrap process more verbose
+ sed -i -e 's@node script/bootstrap@node script/bootstrap --no-quiet@g' \
+ ./script/build \
+ || die "Fail fixing verbosity of script/build"
+}
+
+src_compile() {
+ ./script/build --verbose --build-dir "${T}" || die "Failed to compile"
+ "${T}/Atom/resources/app/apm/bin/apm" rebuild || die "Failed to rebuild native module"
+ # Setup python path to builtin npm
+ echo "python = $PYTHON" >> "${T}/Atom/resources/app/apm/.apmrc"
+}
+
+src_install() {
+ into /usr
+ insinto /usr/share/applications
+ insinto /usr/share/${PN}/resources/app
+ exeinto /usr/bin
+
+ cd "${T}/Atom/resources/app"
+ doicon resources/atom.png
+ dodoc LICENSE.md
+
+ # Installs everything in Atom/resources/app
+ doins -r .
+
+ # Fixes permissions
+ fperms +x /usr/share/${PN}/resources/app/atom.sh
+ fperms +x /usr/share/${PN}/resources/app/apm/bin/apm
+ fperms +x /usr/share/${PN}/resources/app/apm/bin/node
+ fperms +x /usr/share/${PN}/resources/app/apm/node_modules/npm/bin/node-gyp-bin/node-gyp
+
+ # Symlinking to /usr/bin
+ dosym ../share/${PN}/resources/app/atom.sh /usr/bin/atom
+ dosym ../share/${PN}/resources/app/apm/bin/apm /usr/bin/apm
+
+ make_desktop_entry "/usr/bin/atom %U" "Atom" "atom" "GNOME;GTK;Utility;TextEditor;Development;" "MimeType=text/plain;\nStartupNotify=true\nStartupWMClass=Atom"
+}
diff --git a/app-editors/atom/metadata.xml b/app-editors/atom/metadata.xml
new file mode 100644
index 0000000..c6c4c65
--- /dev/null
+++ b/app-editors/atom/metadata.xml
@@ -0,0 +1,13 @@
+
+
+
+
+ aegypius@github.com
+ Nicolas Laurent
+
+
+ mplichta@gmail.com
+ Michal Plichta
+
+ A hackable text editor for the 21st Century
+
diff --git a/dev-util/atom-shell/Manifest b/dev-util/atom-shell/Manifest
new file mode 100644
index 0000000..aa98406
--- /dev/null
+++ b/dev-util/atom-shell/Manifest
@@ -0,0 +1,6 @@
+AUX 0001-fix-atom-shell-linking.patch 539 SHA256 2a3ebdf366b6f617cd1d15d198fc889e115af34312725223e73d53a440712961 SHA512 c81af4a4e440588c1a48814e25d5558d4927fa5113844b7fed2c2fd0222ec9f6c904930c6fd168c4b45c1fd0031664c32b4de43f23f59a2de0a9d6cab71588a1 WHIRLPOOL 030f24d797f0c1b94909b5d40319941cff6a69af99a2fbbe85f0c6b47ea0346406b8641faa4f8cdc60b89c4749856b35a83db67a6077e17dbd64033a4334b1c9
+AUX 0002-fix-brightray-linking.patch 888 SHA256 6a3e551942059db631d439b9ea5210dda2c0c034296b1fcc190b2b7b3c8f231a SHA512 a965f1fbeec418ba16437f93fbe0937b3f3150e67945e129f01d2dc367e8c6c0e8380f6cb3581f085ad510f336c2f4eadba5d2183682217ec30211540189caec WHIRLPOOL 45dd54119e5a294834d1cd517c83ed5fcb12e042998bf22ac94162ca0ced37685edb5802b667dafb5670edc27dea5125948218a1441cd0d6e5e611ac503a7224
+EBUILD atom-shell-0.20.6.ebuild 2304 SHA256 3f8ee3076e3d41e6d8027ba1cd418a30761fb57da27694d16eabfaa0f91a9bb2 SHA512 629a68178dd0260fe2acee826fd19c15cd35e6137400017e5d6177dac4f9e2cae8992ae78c0abd4a2f6a0cdff173ef9693d245342e86d45df4b3b7b76b25bf54 WHIRLPOOL 1c10888bd546cdf6ac390d141971b1b7d90463c83083762edf2c5446e42f5d377141acf03bd408876d44791937239999692641714c76367e993ed856b2234c72
+EBUILD atom-shell-0.21.2.ebuild 2292 SHA256 6fe103144500eb3039c25ba24fc818f997fda6087da29473ddc62c16c504d2ac SHA512 79179f98931c9fddb2efc8f709cc349843ec913bceca206a475a80f865f38e9b8a87414b9e6de27d7f8ff6485b042eea9c121c5b6968fe99217735e211f555ed WHIRLPOOL 9248e3cc11e84a0a828b5dae2462dcfc6ae39ef90dd1fa6055c4dbcc3ce7f553cf5c2a98df9058c2defb5e8fd6724ef5391ad32f876b08ca164811da6b3df390
+EBUILD atom-shell-9999.ebuild 2296 SHA256 3f1d3bbfc6e7a6c53b64e2fa1e44fced0979a42133ab6352d126024b2364ec25 SHA512 7d8636de5454b7385871a988d9b8d378af527355ecbf26da7be86c83f0ce3fc2f84c0d8a786cdfd480073e0389f56a9800eddf58e73feb769e4aea9f8f5285e4 WHIRLPOOL c3c584c799850afc402a42c30feabac9907d6ef03e69396636ec7c215b78c4801c77d560de805b80e5d0c8ea79b9e8755b7417634521568ecf0bd2f5c99ebf5e
+MISC metadata.xml 234 SHA256 528d6a3001781889a3cc70970597d5cd7a90383c6533ffa26c3c61fb99d9b3cb SHA512 5151a3a6fadef0499010e86bc3e70a812d9d46ae3eca47a216520dd094387448b761bd8756530a9cba25a9e2b84ff7a4800f3df86f7a459665629fe094f7103b WHIRLPOOL 4d82231620512150c517fa87e0de4377a2d325625e06de8dd5dcc56871ff901a3bc20f6d079505fc28f9b478e18c1171c1de8d575b5cea1cc6a156763d7087f4
diff --git a/dev-util/atom-shell/atom-shell-0.20.6.ebuild b/dev-util/atom-shell/atom-shell-0.20.6.ebuild
new file mode 100644
index 0000000..57250d8
--- /dev/null
+++ b/dev-util/atom-shell/atom-shell-0.20.6.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+inherit git-r3 flag-o-matic python-any-r1
+
+DESCRIPTION="Cross-platform desktop application shell"
+HOMEPAGE="https://github.com/atom/atom-shell"
+SRC_URI=""
+
+EGIT_REPO_URI="git://github.com/atom/atom-shell"
+
+LICENSE="MIT"
+SLOT="0/20"
+
+if [[ ${PV} == *9999 ]];then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="v${PV}"
+fi
+
+IUSE="debug"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ sys-devel/llvm:0/3.5[clang]
+ dev-lang/python:2.7
+ >=net-libs/nodejs-0.10.30[npm]
+ x11-libs/gtk+:2
+ x11-libs/libnotify
+ gnome-base/libgnome-keyring
+ dev-libs/nss
+ dev-libs/nspr
+ gnome-base/gconf
+ media-libs/alsa-lib
+ net-print/cups
+ sys-libs/libcap
+ x11-libs/libXtst
+ x11-libs/pango
+"
+
+RDEPEND="${DEPEND}
+ ! "${OUT}/version"
+ cp LICENSE "$OUT"
+}
+
+src_install() {
+ into /usr/share/atom
+ insinto /usr/share/atom
+ exeinto /usr/share/atom
+
+ cd "${OUT}"
+
+ doexe atom libchromiumcontent.so libffmpegsumo.so
+
+ doins -r resources
+ doins -r locales
+ doins version
+ doins LICENSE
+ doins icudtl.dat
+ doins content_shell.pak
+}
diff --git a/dev-util/atom-shell/atom-shell-0.21.2.ebuild b/dev-util/atom-shell/atom-shell-0.21.2.ebuild
new file mode 100644
index 0000000..65de84c
--- /dev/null
+++ b/dev-util/atom-shell/atom-shell-0.21.2.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit git-r3 flag-o-matic python-any-r1
+
+DESCRIPTION="Cross-platform desktop application shell"
+HOMEPAGE="https://github.com/atom/atom-shell"
+SRC_URI=""
+
+EGIT_REPO_URI="git://github.com/atom/atom-shell"
+
+LICENSE="MIT"
+SLOT="0/21"
+
+if [[ ${PV} == *9999 ]];then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="v${PV}"
+fi
+
+IUSE="debug"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ sys-devel/llvm:0/3.5[clang]
+ dev-lang/python:2.7
+ net-libs/nodejs[npm]
+ x11-libs/gtk+:2
+ x11-libs/libnotify
+ gnome-base/libgnome-keyring
+ dev-libs/nss
+ dev-libs/nspr
+ gnome-base/gconf
+ media-libs/alsa-lib
+ net-print/cups
+ sys-libs/libcap
+ x11-libs/libXtst
+ x11-libs/pango
+"
+
+RDEPEND="${DEPEND}
+ ! "${OUT}/version"
+ cp LICENSE "$OUT"
+}
+
+src_install() {
+ into /usr/share/atom
+ insinto /usr/share/atom
+ exeinto /usr/share/atom
+
+ cd "${OUT}"
+
+ doexe atom libchromiumcontent.so libffmpegsumo.so
+
+ doins -r resources
+ doins -r locales
+ doins version
+ doins LICENSE
+ doins icudtl.dat
+ doins content_shell.pak
+}
diff --git a/dev-util/atom-shell/atom-shell-9999.ebuild b/dev-util/atom-shell/atom-shell-9999.ebuild
index 4b0d898..a97bdbd 100644
--- a/dev-util/atom-shell/atom-shell-9999.ebuild
+++ b/dev-util/atom-shell/atom-shell-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -14,7 +14,7 @@ SRC_URI=""
EGIT_REPO_URI="git://github.com/atom/atom-shell"
LICENSE="MIT"
-SLOT="0"
+SLOT="0/21"
if [[ ${PV} == *9999 ]];then
KEYWORDS=""
@@ -27,9 +27,9 @@ IUSE="debug"
DEPEND="
${PYTHON_DEPS}
- sys-devel/llvm[clang]
+ sys-devel/llvm:0/3.5[clang]
dev-lang/python:2.7
- >=net-libs/nodejs-0.10.30[npm]
+ net-libs/nodejs[npm]
x11-libs/gtk+:2
x11-libs/libnotify
gnome-base/libgnome-keyring
@@ -42,6 +42,7 @@ DEPEND="
x11-libs/libXtst
x11-libs/pango
"
+
RDEPEND="${DEPEND}
!
+
+
+
+ mplichta@gmail.com
+ Michal Plichta
+
+