dev-python/fslpy: ebuild merged in Gentoo Scinece
https://gitweb.gentoo.org/proj/sci.git/commit/?id=6f5e0a4c6026962a3e4b2aef3df2e20ea231b4e5
This commit is contained in:
parent
f6101338c1
commit
ba6e35cb5e
@ -1,11 +0,0 @@
|
||||
*fslpy-2.6.2 (04 Nov 2019)
|
||||
|
||||
04 Nov 2019; <chymera@gentoo.org> +files/fslpy-2.6.2-exclude_tests.patch,
|
||||
+fslpy-2.6.2.ebuild, -fslpy-1.11.1.ebuild, -fslpy-1.13.3.ebuild:
|
||||
dev-python/fslpy: version bump 2.6.2 ahead of Gentoo Science
|
||||
|
||||
*fslpy-1.11.1 (14 Oct 2018)
|
||||
|
||||
14 Oct 2018; Horea Christian <h.chr@mail.ru> +fslpy-1.11.1.ebuild,
|
||||
+metadata.xml:
|
||||
dev-python/fslpy: new package Ahead of inclusion in Gentoo Science
|
@ -1 +0,0 @@
|
||||
DIST fslpy-2.6.2.tar.gz 4643661 SHA256 9363f02678e7e9cb815352129ab72b6af392b22958b00bb375c57c98600bcd7f SHA512 42c48ec362dc0830486d862171e22b1d9336285f6cf12fc4735909b26802c206aaa090b8a6a1cfbd2f55fc041723a39f7544800c6e10d4b9a4a7ad41b9e12d2e WHIRLPOOL d0eccb3f834880bf964a249bbea23f39a6420babaef1baa646c5c8880709e5b56ec9fe3e607770464701f99a72d785111b88fb38abc3fa41a48547be43db8394
|
@ -1,10 +0,0 @@
|
||||
--- a/setup.py 2019-11-04 18:56:47.407791008 +0100
|
||||
+++ b/setup.py 2019-11-04 20:00:24.844224851 +0100
|
||||
@@ -29,6 +29,6 @@
|
||||
|
||||
packages = find_packages(
|
||||
- exclude=('doc', 'tests', 'dist', 'build', 'fslpy.egg-info'))
|
||||
+ exclude=('doc', 'tests', 'tests.*', 'dist', 'build', 'fslpy.egg-info'))
|
||||
|
||||
# Figure out the current fslpy version, as defined in fsl/version.py. We
|
||||
# don't want to import the fsl package, as this may cause build problems.
|
@ -1,59 +0,0 @@
|
||||
# Copyright 1999-2019 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=7
|
||||
|
||||
PYTHON_COMPAT=( python3_{5,6} )
|
||||
|
||||
inherit distutils-r1 virtualx
|
||||
|
||||
DESCRIPTION="The FSL Python Library"
|
||||
HOMEPAGE="https://git.fmrib.ox.ac.uk/fsl/fslpy"
|
||||
SRC_URI="https://github.com/pauldmccarthy/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="BSD"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test"
|
||||
|
||||
DEPEND="
|
||||
test? (
|
||||
dev-python/pytest[${PYTHON_USEDEP}]
|
||||
dev-python/pytest-cov[${PYTHON_USEDEP}]
|
||||
)
|
||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
||||
"
|
||||
RDEPEND="
|
||||
dev-python/deprecation[${PYTHON_USEDEP}]
|
||||
dev-python/h5py[${PYTHON_USEDEP}]
|
||||
dev-python/indexed_gzip[${PYTHON_USEDEP}]
|
||||
=dev-python/numpy-1*[${PYTHON_USEDEP}]
|
||||
=dev-python/six-1*[${PYTHON_USEDEP}]
|
||||
dev-python/trimesh[${PYTHON_USEDEP}]
|
||||
=dev-python/wxpython-4*[${PYTHON_USEDEP}]
|
||||
=sci-libs/Rtree-0.8.3*[${PYTHON_USEDEP}]
|
||||
sci-libs/scipy[${PYTHON_USEDEP}]
|
||||
>=sci-libs/nibabel-2.3.1[${PYTHON_USEDEP}]
|
||||
"
|
||||
|
||||
# Tests fail on Gentoo with mysterious `Fatal Python error: deallocating None`
|
||||
# https://github.com/pauldmccarthy/fslpy/issues/3
|
||||
#RESTRICT="test"
|
||||
|
||||
#python_prepare_all() {
|
||||
# if use test; then
|
||||
# # Reported upstream
|
||||
# # https://github.com/pauldmccarthy/fslpy/issues/3
|
||||
# #sed -i -e \
|
||||
# # "/def test_loadVestLutFile():/i@pytest.mark.xfail(reason='Known to fail on Gentoo')" \
|
||||
# # tests/test_vest.py || die
|
||||
# #rm tests/test_vest.py
|
||||
# fi
|
||||
# distutils-r1_python_prepare_all
|
||||
#}
|
||||
|
||||
PATCHES=( "${FILESDIR}/${P}-exclude_tests.patch" )
|
||||
|
||||
python_test() {
|
||||
virtx pytest -m "not (dicomtest or fsltest)" --verbose || die
|
||||
}
|
@ -1,18 +0,0 @@
|
||||
<?xml version='1.0' encoding='UTF-8'?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<maintainer type="person">
|
||||
<email>horea.christ@gmail.com</email>
|
||||
<name>Horea Christian</name>
|
||||
</maintainer>
|
||||
<maintainer type="project">
|
||||
<email>sci@gentoo.org</email>
|
||||
<name>Gentoo Science Project</name>
|
||||
</maintainer>
|
||||
<longdescription lang="en">
|
||||
FSLeyes is a viewer for 3D and 4D neuroimaging data. It is intended as a
|
||||
replacement for the much loved FSLView. FSLeyes offers similar functionality
|
||||
to FSLView, and aims to improve and expand upon this functionality in many
|
||||
ways.
|
||||
</longdescription>
|
||||
</pkgmetadata>
|
Loading…
x
Reference in New Issue
Block a user