dev-python/pypubsub: new ebuild
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Horea Christian <horea.christ@yandex.com>
This commit is contained in:
parent
c888af279b
commit
b70e0e858a
@ -1,4 +1,6 @@
|
||||
*pypubsub-3.4.0 (25 Feb 2019)
|
||||
*pypubsub-4.0.3 (18 Mar 2019)
|
||||
|
||||
25 Feb 2019; <chymera@gentoo.org> +pypubsub-3.4.0.ebuild:
|
||||
dev-python/pypubsub:
|
||||
18 Mar 2019; Horea Christian <h.chr@mail.ru> +pypubsub-4.0.3.ebuild,
|
||||
-ChangeLog, -files/pypubsub-3.3.0-imports.patch, -pypubsub-9999.ebuild,
|
||||
pypubsub-3.4.0.ebuild:
|
||||
dev-python/pypubsub: new ebuild
|
||||
|
@ -1 +1,2 @@
|
||||
DIST pypubsub-3.4.0.tar.gz 178268 SHA256 c52d793f6b89b1cd748aa82ac1e1c2014c4fcb78f54903e72853648661b9f564 SHA512 0017fcd32befdb946e85d41d5b2480306b75f0e70acde2dfe38dd8671e09c2b03240de4de3eb7cd5c160e03348ae6c8269263ea483112fbafdbacb8e39c7de5f WHIRLPOOL 44fa8877dacb7d232fa505671582392b624752595cc725cbd1ba24f02e312afd35fa1ddd53eb7117c23c1effc822a07e3db145f6aab70b53b3ede88df30f2990
|
||||
DIST pypubsub-3.4.0.tar.gz 178302 SHA256 f869888c91f008692a4b7ac19b95cc0d997c6dcc4e16f5a48dd64e07d9fd99b9 SHA512 f325363b7fe25ce861c5b7523e03de2230bc960b81a896a72dd22b2fb78990dba01507ce1b9623283dfc46710ae056970e3985ac0c7bc485fe25ac87e51e5223 WHIRLPOOL 223186bf1abbaa81ee3e890f1042bdf3202398d66573ccfefbcb717adc0f77e7b07772b8a85d4acead69d005a1658b28e1aa7118718e287d5a70203c760dd839
|
||||
DIST pypubsub-4.0.3.tar.gz 174033 SHA256 0df83daa1cb0021bab858ff6812d836c9712dea59a5172be1888bb554c3a89a2 SHA512 cf9aca44e91a5d0e5ecf6739deabf2980f9464395c89e3c5335c5248e47c570701e0534bb660c5005325a994d9f8e7f261f36bc8bea74cfc7eb760b73c572652 WHIRLPOOL 706ddf8e86c432f6b7ebbae5a74547b2d54bbae1a04dcf238c96cc90800c2e44c2d35bc14e0e5efa0eb2594a6a2b4167428d28fc9cc72c598eb3e5254e0f3fd3
|
||||
|
@ -1,15 +0,0 @@
|
||||
--- a/src/pubsub/core/topicdefnprovider.py 2013-11-17 12:42:54.000000000 -0600
|
||||
+++ b/src/pubsub/core/topicdefnprovider.py 2019-02-06 17:15:06.138101941 -0600
|
||||
@@ -7,10 +7,8 @@
|
||||
import os, re, inspect
|
||||
from textwrap import TextWrapper, dedent
|
||||
|
||||
-from .. import (
|
||||
- policies,
|
||||
- py2and3
|
||||
-)
|
||||
+import policies, py2and3
|
||||
+
|
||||
from .topicargspec import (
|
||||
topicArgsFromCallable,
|
||||
ArgSpecGiven
|
@ -9,58 +9,18 @@ inherit distutils-r1
|
||||
|
||||
DESCRIPTION="A Python publish-subcribe library"
|
||||
HOMEPAGE="https://github.com/pauldmccarthy/indexed_gzip"
|
||||
SRC_URI="
|
||||
https://github.com/schollii/pypubsub/archive/v${PV}.tar.gz -> ${P}.tar.gz
|
||||
"
|
||||
#https://github.com/schollii/pypubsub/archive/${EGIT_COMMIT}.tar.gz -> ${P}-extras.tar.gz
|
||||
SRC_URI="https://github.com/schollii/pypubsub/archive/v${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="BSD"
|
||||
SLOT="0"
|
||||
SLOT="3"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test"
|
||||
|
||||
DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
|
||||
RDEPEND="virtual/python-pathlib[${PYTHON_USEDEP}]"
|
||||
|
||||
#S="${WORKDIR}/${MY_P}"
|
||||
|
||||
#PATCHES=( "${FILESDIR}"/${P}-imports.patch )
|
||||
#
|
||||
#src_prepare() {
|
||||
# cp "../${PN}-${EGIT_COMMIT}/"{policies,py2and3}.py src/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/setuparg1.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/setupkwargs.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/core/arg1/listenerimpl.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/core/arg1/publisher.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/core/arg1/publishermixin.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/core/arg1/topicargspecimpl.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/core/arg1/topicmgrimpl.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/core/listenerbase.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/core/publisherbase.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/core/treeconfig.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/core/validatedefnargs.py" src/pubsub/core/ || die
|
||||
# touch __init__.py
|
||||
# find -type f -exec sed -i\
|
||||
# -e "s/from .. import policies/import policies/g"\
|
||||
# -e "s/from .. import py2and3/import py2and3/g"\
|
||||
# {} + || die
|
||||
# distutils-r1_src_prepare
|
||||
#}
|
||||
|
||||
#src_compile() {
|
||||
# distutils-r1_src_compile
|
||||
# ls
|
||||
# cp "../${PN}-${EGIT_COMMIT}/"{policies,py2and3}.py ${BUILD_DIR} || die
|
||||
#}
|
||||
|
||||
python_test() {
|
||||
distutils_install_for_testing
|
||||
#cp "../${PN}-${EGIT_COMMIT}/"{policies,py2and3}.py "${BUILD_DIR}" || die
|
||||
#cp "../${PN}-${EGIT_COMMIT}/"{policies,py2and3}.py src/ || die
|
||||
cd "tests/suite" || die
|
||||
pytest -vv || die
|
||||
#for i in tests/suite/*.py; do
|
||||
# echo "Executing ${EPYTHON} ${i}"
|
||||
# ${EPYTHON} "$i" || die "Example Python script $i failed with ${EPYTHON}"
|
||||
#done
|
||||
}
|
||||
|
28
dev-python/pypubsub/pypubsub-4.0.3.ebuild
Normal file
28
dev-python/pypubsub/pypubsub-4.0.3.ebuild
Normal file
@ -0,0 +1,28 @@
|
||||
# Copyright 1999-2019 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=7
|
||||
|
||||
PYTHON_COMPAT=( python3_{4,5,6,7} )
|
||||
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="A Python publish-subcribe library"
|
||||
HOMEPAGE="https://github.com/pauldmccarthy/indexed_gzip"
|
||||
SRC_URI="
|
||||
https://github.com/schollii/pypubsub/archive/v${PV}.tar.gz -> ${P}.tar.gz
|
||||
"
|
||||
|
||||
LICENSE="BSD"
|
||||
SLOT="4"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test"
|
||||
|
||||
DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
|
||||
RDEPEND="virtual/python-pathlib[${PYTHON_USEDEP}]"
|
||||
|
||||
python_test() {
|
||||
distutils_install_for_testing
|
||||
cd "tests/suite" || die
|
||||
pytest -vv || die
|
||||
}
|
@ -1,65 +0,0 @@
|
||||
# Copyright 1999-2019 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=7
|
||||
|
||||
PYTHON_COMPAT=( python2_7 )
|
||||
|
||||
inherit distutils-r1 git-r3
|
||||
|
||||
DESCRIPTION="A Python publish-subcribe library"
|
||||
HOMEPAGE="https://github.com/pauldmccarthy/indexed_gzip"
|
||||
SRC_URI=""
|
||||
EGIT_REPO_URI="https://github.com/schollii/pypubsub"
|
||||
EGIT_BRANCH="v3.4.0"
|
||||
|
||||
LICENSE="BSD"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test"
|
||||
|
||||
DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
|
||||
RDEPEND="virtual/python-pathlib[${PYTHON_USEDEP}]"
|
||||
|
||||
#S="${WORKDIR}/${MY_P}"
|
||||
|
||||
#PATCHES=( "${FILESDIR}"/${P}-imports.patch )
|
||||
#
|
||||
#src_prepare() {
|
||||
# cp "../${PN}-${EGIT_COMMIT}/"{policies,py2and3}.py src/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/setuparg1.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/setupkwargs.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/core/arg1/listenerimpl.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/core/arg1/publisher.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/core/arg1/publishermixin.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/core/arg1/topicargspecimpl.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/core/arg1/topicmgrimpl.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/core/listenerbase.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/core/publisherbase.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/core/treeconfig.py" src/pubsub/core/ || die
|
||||
# cp "../${PN}-${EGIT_COMMIT}/core/validatedefnargs.py" src/pubsub/core/ || die
|
||||
# touch __init__.py
|
||||
# find -type f -exec sed -i\
|
||||
# -e "s/from .. import policies/import policies/g"\
|
||||
# -e "s/from .. import py2and3/import py2and3/g"\
|
||||
# {} + || die
|
||||
# distutils-r1_src_prepare
|
||||
#}
|
||||
|
||||
#src_compile() {
|
||||
# distutils-r1_src_compile
|
||||
# ls
|
||||
# cp "../${PN}-${EGIT_COMMIT}/"{policies,py2and3}.py ${BUILD_DIR} || die
|
||||
#}
|
||||
|
||||
python_test() {
|
||||
distutils_install_for_testing
|
||||
#cp "../${PN}-${EGIT_COMMIT}/"{policies,py2and3}.py "${BUILD_DIR}" || die
|
||||
#cp "../${PN}-${EGIT_COMMIT}/"{policies,py2and3}.py src/ || die
|
||||
cd "tests/suite" || die
|
||||
pytest -vv || die
|
||||
#for i in tests/suite/*.py; do
|
||||
# echo "Executing ${EPYTHON} ${i}"
|
||||
# ${EPYTHON} "$i" || die "Example Python script $i failed with ${EPYTHON}"
|
||||
#done
|
||||
}
|
Loading…
x
Reference in New Issue
Block a user