dev-python/fscacher: version bump with working tests
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Horea Christian <chr@chymera.eu>
This commit is contained in:
parent
7ecffd2541
commit
b6b0d5dd17
@ -1 +1,2 @@
|
|||||||
DIST fscacher-0.1.4.tar.gz 35097 SHA256 d3ecd4cdc9cad2ee84a3f37f74b6ef3f87279cd28d2ccf8025893fc581269aca SHA512 e3e85cee4c446552215b6d7092bdc72c31709e05dee7efb52fc6fc985992a3ece338c5a0dee54ed7e6aec797d4b7e2bd77b00f634112134c61f402b604103b5c WHIRLPOOL 177afbe8e616c081e71aff1bdd2ed7081fcc4d648ff4f8549832d513392ea53b61f172753d6ea401d74186f01928ad4710f7c30ca974e6f4024f37818cf23eaa
|
DIST fscacher-0.1.4.tar.gz 35097 SHA256 d3ecd4cdc9cad2ee84a3f37f74b6ef3f87279cd28d2ccf8025893fc581269aca SHA512 e3e85cee4c446552215b6d7092bdc72c31709e05dee7efb52fc6fc985992a3ece338c5a0dee54ed7e6aec797d4b7e2bd77b00f634112134c61f402b604103b5c WHIRLPOOL 177afbe8e616c081e71aff1bdd2ed7081fcc4d648ff4f8549832d513392ea53b61f172753d6ea401d74186f01928ad4710f7c30ca974e6f4024f37818cf23eaa
|
||||||
|
DIST fscacher-0.2.0.tar.gz 37704 SHA256 7d8f1e6b185658ef049b0e11b9d2caeca5b2b9ac33ff7aeaf9731f3a28f5bd10 SHA512 d3ec18d211e7c5c4e74dbf6d95cecf6558956f24ddeebac3caef66ebfbbdd95055a20c9ea3c9143e65e9de7b5c383f63a10bd8e8cbebea10a2bb5ba70938e89e WHIRLPOOL 350eefa9581a4dfe69d2ab4dd0940687e974ff1771842275f2673afaeaff5cadd6fbf24399e3792b2ee8362c311382d2534076f9c0f531e0313c8cb45338bce0
|
||||||
|
10
dev-python/fscacher/files/fscacher-0.2.0-coverage.patch
Normal file
10
dev-python/fscacher/files/fscacher-0.2.0-coverage.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- a/tox.ini 2021-09-27 01:00:33.935464308 -0400
|
||||||
|
+++ b/tox.ini 2021-09-27 02:48:34.349729243 -0400
|
||||||
|
@@ -31,7 +31,6 @@
|
||||||
|
asv run --strict {posargs} HEAD^1..HEAD
|
||||||
|
|
||||||
|
[pytest]
|
||||||
|
-addopts = --cov=fscacher --no-cov-on-fail
|
||||||
|
filterwarnings =
|
||||||
|
error
|
||||||
|
ignore:The distutils package is deprecated:DeprecationWarning:joblib
|
@ -1,4 +1,4 @@
|
|||||||
# Copyright 1999-2021 Gentoo Authors
|
# Copyright 1999-2022 Gentoo Authors
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
EAPI=8
|
EAPI=8
|
||||||
@ -13,6 +13,7 @@ SRC_URI="https://github.com/con/fscacher/archive/refs/tags/${PV}.tar.gz -> ${P}.
|
|||||||
SLOT="0"
|
SLOT="0"
|
||||||
LICENSE="MIT"
|
LICENSE="MIT"
|
||||||
KEYWORDS="~amd64 ~x86"
|
KEYWORDS="~amd64 ~x86"
|
||||||
|
RESTRICT="test"
|
||||||
|
|
||||||
RDEPEND="
|
RDEPEND="
|
||||||
dev-python/appdirs[${PYTHON_USEDEP}]
|
dev-python/appdirs[${PYTHON_USEDEP}]
|
||||||
|
31
dev-python/fscacher/fscacher-0.2.0.ebuild
Normal file
31
dev-python/fscacher/fscacher-0.2.0.ebuild
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
# Copyright 1999-2022 Gentoo Authors
|
||||||
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
|
EAPI=8
|
||||||
|
|
||||||
|
PYTHON_COMPAT=( python3_{8..10} )
|
||||||
|
inherit distutils-r1
|
||||||
|
|
||||||
|
DESCRIPTION="Cache results of operations on heavy file trees"
|
||||||
|
HOMEPAGE="https://github.com/con/fscacher"
|
||||||
|
SRC_URI="https://github.com/con/fscacher/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
|
||||||
|
|
||||||
|
SLOT="0"
|
||||||
|
LICENSE="MIT"
|
||||||
|
KEYWORDS="~amd64 ~x86"
|
||||||
|
|
||||||
|
RDEPEND="
|
||||||
|
dev-python/appdirs[${PYTHON_USEDEP}]
|
||||||
|
dev-python/joblib[${PYTHON_USEDEP}]
|
||||||
|
"
|
||||||
|
DEPEND="
|
||||||
|
test? (
|
||||||
|
dev-python/pytest-mock[${PYTHON_USEDEP}]
|
||||||
|
)
|
||||||
|
"
|
||||||
|
|
||||||
|
PATCHES=(
|
||||||
|
"${FILESDIR}/${PN}-0.2.0-coverage.patch"
|
||||||
|
)
|
||||||
|
|
||||||
|
distutils_enable_tests pytest
|
@ -16,4 +16,8 @@
|
|||||||
the behavior of `foo()` is pure in the contents of the path and the
|
the behavior of `foo()` is pure in the contents of the path and the
|
||||||
values of its other arguments, fscacher can help cache that function,
|
values of its other arguments, fscacher can help cache that function,
|
||||||
</longdescription>
|
</longdescription>
|
||||||
|
<upstream>
|
||||||
|
<remote-id type="github">con/fscacher</remote-id>
|
||||||
|
<remote-id type="pypi">fscacher</remote-id>
|
||||||
|
</upstream>
|
||||||
</pkgmetadata>
|
</pkgmetadata>
|
||||||
|
Loading…
x
Reference in New Issue
Block a user