Superseded by upstream
https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e8e14b564d7f9cc694a1a96031703be15b2d41bc
This commit is contained in:
parent
cb25e53393
commit
b5627fc697
@ -1,5 +0,0 @@
|
||||
*wxpython-4.0.4 (18 Mar 2019)
|
||||
|
||||
18 Mar 2019; Horea Christian <h.chr@mail.ru> +wxpython-4.0.4.ebuild,
|
||||
-wxpython-4.0.3.ebuild, metadata.xml:
|
||||
dev-python/wxpython: version bump
|
@ -1 +0,0 @@
|
||||
DIST wxpython-4.0.4.tar.gz 68791657 SHA256 0d9ef4260cb2f3e23ed9dcf6baa905ba585ac7d631613cddc299c4c83463ae29 SHA512 48895f191150c63c253eb4136b78ff7803b6df566ca92b9fcf3c3fff3c893a57ff52a51b331333cf2200a053b8d0ea7facb39d7bfb581a78e009a24c31437cae WHIRLPOOL 3037c8dfa5d528198b63d86166cbaed356aa38cf0534522786b2b075ff569a00e462df6bfbf2c9d0639c2c78cb114b3e120f008dc7ab9f21f3a034515580559b
|
@ -1,18 +0,0 @@
|
||||
--- a/setup.py 2018-06-26 04:20:04.000000000 +0200
|
||||
+++ b/setup.py 2018-11-06 17:47:28.940450375 +0100
|
||||
@@ -105,6 +105,7 @@
|
||||
"""
|
||||
user_options = [
|
||||
('skip-build', None, 'skip building the C/C++ code (assumes it has already been done)'),
|
||||
+ ('parallel=', 'j', "number of parallel build jobs")
|
||||
]
|
||||
boolean_options = ['skip-build']
|
||||
|
||||
@@ -112,6 +113,7 @@
|
||||
def initialize_options(self):
|
||||
orig_build.initialize_options(self)
|
||||
self.skip_build = '--skip-build' in sys.argv
|
||||
+ self.parallel = None
|
||||
|
||||
def finalize_options(self):
|
||||
orig_build.finalize_options(self)
|
@ -1,59 +0,0 @@
|
||||
--- a/wscript 2018-06-26 07:20:04.000000000 +0500
|
||||
+++ b/wscript 2018-10-29 20:10:06.236956371 +0500
|
||||
@@ -131,8 +131,8 @@
|
||||
_copyEnvGroup(conf.env, '_WX', '_WXGL')
|
||||
conf.env.LIB_WXGL += cfg.makeLibName('gl')
|
||||
|
||||
- _copyEnvGroup(conf.env, '_WX', '_WXWEBVIEW')
|
||||
- conf.env.LIB_WXWEBVIEW += cfg.makeLibName('webview')
|
||||
+ #_copyEnvGroup(conf.env, '_WX', '_WXWEBVIEW')
|
||||
+ #conf.env.LIB_WXWEBVIEW += cfg.makeLibName('webview')
|
||||
|
||||
_copyEnvGroup(conf.env, '_WX', '_WXXML')
|
||||
conf.env.LIB_WXXML += cfg.makeLibName('xml', isMSWBase=True)
|
||||
@@ -220,16 +220,16 @@
|
||||
uselib_store='WXGL', mandatory=True,
|
||||
msg='Finding libs for WXGL')
|
||||
|
||||
- conf.check_cfg(path=conf.options.wx_config, package='',
|
||||
- args='--cxxflags --libs webview,core,net' + rpath,
|
||||
- uselib_store='WXWEBVIEW', mandatory=True,
|
||||
- msg='Finding libs for WXWEBVIEW')
|
||||
-
|
||||
- if isDarwin:
|
||||
- conf.check_cfg(path=conf.options.wx_config, package='',
|
||||
- args='--cxxflags --libs core,net' + rpath,
|
||||
- uselib_store='WXWEBKIT', mandatory=True,
|
||||
- msg='Finding libs for WXWEBKIT')
|
||||
+ #conf.check_cfg(path=conf.options.wx_config, package='',
|
||||
+ # args='--cxxflags --libs webview,core,net' + rpath,
|
||||
+ # uselib_store='WXWEBVIEW', mandatory=True,
|
||||
+ # msg='Finding libs for WXWEBVIEW')
|
||||
+
|
||||
+ #if isDarwin:
|
||||
+ # conf.check_cfg(path=conf.options.wx_config, package='',
|
||||
+ # args='--cxxflags --libs core,net' + rpath,
|
||||
+ # uselib_store='WXWEBKIT', mandatory=True,
|
||||
+ # msg='Finding libs for WXWEBKIT')
|
||||
|
||||
conf.check_cfg(path=conf.options.wx_config, package='',
|
||||
args='--cxxflags --libs xml,core,net' + rpath,
|
||||
@@ -567,7 +567,7 @@
|
||||
makeETGRule(bld, 'etg/_stc.py', '_stc', 'WXSTC')
|
||||
makeETGRule(bld, 'etg/_html.py', '_html', 'WXHTML')
|
||||
makeETGRule(bld, 'etg/_glcanvas.py', '_glcanvas', 'WXGL')
|
||||
- makeETGRule(bld, 'etg/_html2.py', '_html2', 'WXWEBVIEW')
|
||||
+ #makeETGRule(bld, 'etg/_html2.py', '_html2', 'WXWEBVIEW')
|
||||
makeETGRule(bld, 'etg/_xml.py', '_xml', 'WXXML')
|
||||
makeETGRule(bld, 'etg/_xrc.py', '_xrc', 'WXXRC')
|
||||
makeETGRule(bld, 'etg/_richtext.py', '_richtext', 'WXHTML WXRICHTEXT')
|
||||
@@ -577,8 +577,8 @@
|
||||
makeETGRule(bld, 'etg/_aui.py', '_aui', 'WXAUI')
|
||||
|
||||
# Modules that are platform-specific
|
||||
- if isDarwin:
|
||||
- makeETGRule(bld, 'etg/_webkit.py', '_webkit', 'WXWEBKIT')
|
||||
+ #if isDarwin:
|
||||
+ #makeETGRule(bld, 'etg/_webkit.py', '_webkit', 'WXWEBKIT')
|
||||
if isWindows:
|
||||
makeETGRule(bld, 'etg/_msw.py', '_msw', 'WX')
|
@ -1,15 +0,0 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<maintainer type="project">
|
||||
<email>wxwidgets@gentoo.org</email>
|
||||
<name>Gentoo wxWidgets Project</name>
|
||||
</maintainer>
|
||||
<maintainer type="project">
|
||||
<email>python@gentoo.org</email>
|
||||
<name>Python</name>
|
||||
</maintainer>
|
||||
<upstream>
|
||||
<remote-id type="sourceforge">wxpython</remote-id>
|
||||
</upstream>
|
||||
</pkgmetadata>
|
@ -1,67 +0,0 @@
|
||||
# Copyright 1999-2019 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=6
|
||||
|
||||
PYTHON_COMPAT=( python2_7 python3_{5,6} )
|
||||
WX_GTK_VER="3.0"
|
||||
|
||||
inherit distutils-r1 wxwidgets
|
||||
|
||||
P_HASH="7c3ced03c3c76b9f98e4a0edae1801755a7599ebf481c04d9f77dfff17e3"
|
||||
MY_PN="wxPython"
|
||||
|
||||
DESCRIPTION="A blending of the wxWindows C++ class library with Python"
|
||||
HOMEPAGE="http://www.wxpython.org/"
|
||||
SRC_URI="https://files.pythonhosted.org/packages/17/74/${P_HASH}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="wxWinLL-3"
|
||||
SLOT="3.0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test"
|
||||
|
||||
RDEPEND="
|
||||
dev-python/appdirs[${PYTHON_USEDEP}]
|
||||
dev-python/numpy[${PYTHON_USEDEP}]
|
||||
dev-python/pillow[${PYTHON_USEDEP}]
|
||||
$(python_gen_cond_dep 'dev-python/pypubsub:3[${PYTHON_USEDEP}]' -2 )
|
||||
$(python_gen_cond_dep 'dev-python/pypubsub:4[${PYTHON_USEDEP}]' -3 )
|
||||
dev-python/requests[${PYTHON_USEDEP}]
|
||||
dev-python/six[${PYTHON_USEDEP}]
|
||||
dev-python/sphinx[${PYTHON_USEDEP}]
|
||||
dev-python/twine[${PYTHON_USEDEP}]
|
||||
dev-python/wheel[${PYTHON_USEDEP}]
|
||||
"
|
||||
|
||||
DEPEND="
|
||||
dev-python/pip[${PYTHON_USEDEP}]
|
||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
||||
test? (
|
||||
${RDEPEND}
|
||||
dev-python/pytest[${PYTHON_USEDEP}]
|
||||
)
|
||||
"
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${PN}"-4.0.3-webkit.patch
|
||||
"${FILESDIR}/${PN}"-4.0.3-parallel.patch
|
||||
)
|
||||
|
||||
S="${WORKDIR}/${MY_PN}-${PV}"
|
||||
|
||||
python_prepare_all() {
|
||||
if use test; then
|
||||
# Errors reported upstream: https://github.com/wxWidgets/Phoenix/issues/1025
|
||||
sed -i \
|
||||
-e "/class GetAutoCompleteListTestCase(GetAttributeTestCase):/i@unittest.skip('Known to fail')" \
|
||||
-e "/class GetAttributeNamesTestCase(GetAttributeTestCase):/i@unittest.skip('Known to fail')" \
|
||||
wx/py/tests/test_introspect.py || die
|
||||
fi
|
||||
distutils-r1_python_prepare_all
|
||||
}
|
||||
|
||||
python_test() {
|
||||
distutils-r1_install_for_testing
|
||||
cd "${BUILD_DIR}/lib/wx/py/tests" || die
|
||||
${EPYTHON} -m unittest discover || die
|
||||
}
|
Loading…
x
Reference in New Issue
Block a user