1
0
Fork 0

sci-biology/ants: pushed to Gentoo Science

https://gitweb.gentoo.org/proj/sci.git/commit/?id=40022cd56f21a7152d812b6435734aafa032c7f8

Signed-off-by: Horea Christian <chr@chymera.eu>
This commit is contained in:
Horea Christian 2020-09-25 15:46:29 -04:00
parent 5a99fee6e2
commit b0a124bbb2
No known key found for this signature in database
GPG Key ID: EAA9223EE3BB378A
7 changed files with 0 additions and 288 deletions

View File

@ -1,50 +0,0 @@
*ants-2.3.4 (04 Aug 2020)
04 Aug 2020; <chymera@gentoo.org> +ants-2.3.4.ebuild,
+files/ants-2.3.4-libdir.patch, +files/ants-2.3.4-version.patch,
-ants-2.3.1_p20191013.ebuild, -files/ants-2.3.1_p20191013-logic.patch,
-files/ants-2.3.1_p20191013-paths.patch:
sci-biology/ants: version bump 2.3.4 ahead of Gentoo Science
16 May 2020; <chymera@gentoo.org> ants-2.3.1_p20191013.ebuild:
sci-biology/ants: building from tarball, failing
*ants-2.3.1_p20191013 (14 Dec 2019)
14 Dec 2019; <chymera@gentoo.org> +ants-2.3.1_p20191013.ebuild,
-ants-9999.ebuild, metadata.xml:
sci-biology/ants: prefix fix ahead of Gentoo Science
25 Nov 2019; <chymera@gentoo.org> -ants-2.3.1_p20191013.ebuild:
sci-biology/ants: migrated version bump to Gentoo Scinece https://gitweb.gent
oo.org/proj/sci.git/commit/?id=402183f38c721910fe038ed4ce04e0a98a37c584
17 Oct 2019; <chymera@gentoo.org> ants-9999.ebuild:
sci-biology/ants: patch merged by ANTs upstream
13 Oct 2019; <chymera@gentoo.org> +files/ants-2.3.1_p20191013-logic.patch,
+files/ants-2.3.1_p20191013-paths.patch, ants-2.3.1_p20191013.ebuild,
ants-9999.ebuild:
sci-biology/ants: updated ebuild style
23 Sep 2019; <chymera@gentoo.org> ants-2.3.1_p20190704.ebuild:
sci-biology/ants: improved testing support
*ants-2.3.1_p20190704 (21 Sep 2019)
21 Sep 2019; <chymera@gentoo.org> +ants-2.3.1_p20190704.ebuild,
-ants-2.3.1-r1.ebuild, -ants-2.3.1.ebuild, ants-9999.ebuild:
sci-biology/ants: version bump 2.3.1_p20190704
*ants-2.3.1 (18 May 2019)
18 May 2019; <chymera@gentoo.org> +ants-2.3.1.ebuild:
sci-biology/ants: unsandboxed fix fro bundling Do not include in Gentoo
Science, work on unbundled revbump
*ants-2.3.1-r1 (25 Mar 2019)
*ants-9999 (25 Mar 2019)
25 Mar 2019; <chymera@gentoo.org> +ants-2.3.1-r1.ebuild, +ants-9999.ebuild,
+files/99ants, +metadata.xml:
sci-biology/ants: fixes ahead of Gentoo Science

View File

@ -1,2 +0,0 @@
DIST ants-2.3.4.tar.gz 2455843 SHA256 590b678f6fcbfa2f7bca4ae6059f49d5cf64ad07b2ed5088fb9226cb0f28ffec SHA512 084161505671a19530bec40c8209a67510d7de6e9d5afd151b806755ca703dadbea17c0a8d5c6472c7a81185821e17213ebf1488bc0325bfe858af783e8e6575 WHIRLPOOL bbdd587645580d5e47d5d276fdeba4d76330ab9ad10e7fecc6ebebb1c83f681db1d678bbfbb9bb36775606a2cfdc89dd38a759da0cb8e4a5d8e4a3967e8634c9
DIST ants_testdata-2.3.4.tar.xz 25056552 SHA256 75fa0ada62533aa1636fa4db9b677564723622e4b25348a0e8b3a366b6d00e82 SHA512 a266fbf2de0003ee689a9369c424c97c92cdf7e4d08ba713623948276d96c9f0f02ab14480c329f462db0059217138680bfe39654f9ec4ac99bf947f51da853d WHIRLPOOL 3d269afa1d7d9b7426000c48c3773c09bc92d3f4c790dfd71ccb6f6fc98db7e8c16534f4e852f7b5eb793819ec40b7054ff7371eb07b9219fe3787b15c118783

View File

@ -1,77 +0,0 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_MAKEFILE_GENERATOR="emake"
inherit cmake multilib
MY_PN="ANTs"
DESCRIPTION="Advanced Normalitazion Tools for neuroimaging"
HOMEPAGE="http://stnava.github.io/ANTs/"
SRC_URI="
https://github.com/ANTsX/ANTs/archive/v${PV}.tar.gz -> ${P}.tar.gz
test? (
http://chymera.eu/distfiles/ants_testdata-${PV}.tar.xz
)
"
SLOT="0"
LICENSE="BSD"
KEYWORDS="~amd64 ~x86"
IUSE="test vtk"
DEPEND="
vtk? (
~sci-libs/itk-5.1.0[vtkglue]
sci-libs/vtk
)
!vtk? ( ~sci-libs/itk-5.1.0 )
"
RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${P}-version.patch"
"${FILESDIR}/${P}-libdir.patch"
)
S="${WORKDIR}/${MY_PN}-${PV}"
src_unpack() {
default
if use test; then
mkdir -p "${S}/.ExternalData/MD5" || die "Could not create test data directory."
tar xvf "${DISTDIR}/ants_testdata-${PV}.tar.xz" -C "${S}/.ExternalData/MD5/" > /dev/null || die "Could not unpack test data."
fi
}
src_configure() {
local mycmakeargs=(
-DUSE_SYSTEM_ITK=ON
-DITK_DIR="${EROOT}/usr/include/ITK-5.1/"
-DBUILD_TESTING="$(usex test ON OFF)"
-DUSE_VTK=$(usex vtk ON OFF)
-DUSE_SYSTEM_VTK=$(usex vtk ON OFF)
-DANTS_SNAPSHOT_VERSION:STRING=${PV}
)
use vtk && mycmakeargs+=(
-DVTK_DIR="${EROOT}/usr/include/vtk-8.1/"
)
use test && mycmakeargs+=(
-DExternalData_OBJECT_STORES="${S}/.ExternalData/MD5"
)
cmake_src_configure
}
src_install() {
BUILD_DIR="${WORKDIR}/${P}_build/ANTS-build"
cmake_src_install
cd "${S}/Scripts" || die "scripts dir not found"
dobin *.sh
dodir /usr/$(get_libdir)/ants
insinto "/usr/$(get_libdir)/ants"
doins *
doenvd "${FILESDIR}"/99ants
}

View File

@ -1 +0,0 @@
ANTSPATH=/usr/bin/

View File

@ -1,117 +0,0 @@
From 329a7be631b33294d9cf3d58e8cdeb62e0aa993c Mon Sep 17 00:00:00 2001
From: Philip A Cook <cookpa@pennmedicine.upenn.edu>
Date: Fri, 26 Jun 2020 18:23:08 +0000
Subject: [PATCH] ENH: Use GNUInstallDirs CMake module
Trying to enable installation to the correct lib dir for each platform
---
Common.cmake | 7 +++++--
Examples/CMakeLists.txt | 32 ++++++++++++++++----------------
2 files changed, 21 insertions(+), 18 deletions(-)
diff --git a/Common.cmake b/Common.cmake
index 5e52d7f1..1e604113 100644
--- a/Common.cmake
+++ b/Common.cmake
@@ -103,8 +103,6 @@ if(PLATFORM_CHECK)
endif()
endif()
-
-
#-------------------------------------------------------------------------
# Augment compiler flags
#-------------------------------------------------------------------------
@@ -124,3 +122,8 @@ if(NOT CMAKE_POSITION_INDEPENDENT_CODE)
set(CMAKE_POSITION_INDEPENDENT_CODE ON)
endif()
endif()
+
+#-------------------------------------------------------------------------
+# Define install dirs for different platforms
+#-------------------------------------------------------------------------
+include(GNUInstallDirs)
diff --git a/Examples/CMakeLists.txt b/Examples/CMakeLists.txt
index 61781f56..cb352748 100644
--- a/Examples/CMakeLists.txt
+++ b/Examples/CMakeLists.txt
@@ -1,4 +1,4 @@
-SET(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
+SET(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}")
## Note that the antsUtilities can always be built static. It will then be linked
## Directly into the other libraries.
add_library(antsUtilities antsUtilities.cxx
@@ -14,11 +14,11 @@ add_library(antsUtilities antsUtilities.cxx
)
target_link_libraries(antsUtilities ${ITK_LIBRARIES} )
install(TARGETS antsUtilities
- RUNTIME DESTINATION bin
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
COMPONENT RUNTIME_antsUtilities
- LIBRARY DESTINATION lib
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
COMPONENT RUNTIME_antsUtilities
- ARCHIVE DESTINATION lib
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
COMPONENT DEVELOPMENT_antsUtilities
)
@@ -34,22 +34,22 @@ macro(STATIC_ANTS_BUILD ANTS_FUNCTION_NAME EXTRA_LIBS)
if (ANTS_INSTALL_LIBS_ONLY)
install(TARGETS l_${ANTS_FUNCTION_NAME}
- # RUNTIME DESTINATION bin
+ # RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
# COMPONENT RUNTIME_${ANTS_FUNCTION_NAME}
- LIBRARY DESTINATION lib
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
COMPONENT RUNTIME_${ANTS_FUNCTION_NAME}
- ARCHIVE DESTINATION lib
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
COMPONENT DEVELOPMENT_${ANTS_FUNCTION_NAME}
)
else()
add_executable( ${ANTS_FUNCTION_NAME} cli_${ANTS_FUNCTION_NAME}.cxx )
target_link_libraries( ${ANTS_FUNCTION_NAME} l_${ANTS_FUNCTION_NAME} )
install(TARGETS l_${ANTS_FUNCTION_NAME} ${ANTS_FUNCTION_NAME}
- RUNTIME DESTINATION bin
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
COMPONENT RUNTIME_${ANTS_FUNCTION_NAME}
- LIBRARY DESTINATION lib
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
COMPONENT RUNTIME_${ANTS_FUNCTION_NAME}
- ARCHIVE DESTINATION lib
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
COMPONENT DEVELOPMENT_${ANTS_FUNCTION_NAME}
)
endif()
@@ -68,11 +68,11 @@ macro(DYNAMIC_ANTS_BUILD ANTS_FUNCTION_NAME EXTRA_LIBS)
if (ANTS_INSTALL_LIBS_ONLY)
install(TARGETS l_${ANTS_FUNCTION_NAME}
- # RUNTIME DESTINATION bin
+ # RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
# COMPONENT RUNTIME_${ANTS_FUNCTION_NAME}
- LIBRARY DESTINATION lib
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
COMPONENT RUNTIME_${ANTS_FUNCTION_NAME}
- ARCHIVE DESTINATION lib
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
COMPONENT DEVELOPMENT_${ANTS_FUNCTION_NAME}
)
else()
@@ -80,11 +80,11 @@ macro(DYNAMIC_ANTS_BUILD ANTS_FUNCTION_NAME EXTRA_LIBS)
target_link_libraries( ${ANTS_FUNCTION_NAME} l_${ANTS_FUNCTION_NAME} )
install(TARGETS l_${ANTS_FUNCTION_NAME} ${ANTS_FUNCTION_NAME}
- RUNTIME DESTINATION bin
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
COMPONENT RUNTIME_${ANTS_FUNCTION_NAME}
- LIBRARY DESTINATION lib
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
COMPONENT RUNTIME_${ANTS_FUNCTION_NAME}
- ARCHIVE DESTINATION lib
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
COMPONENT DEVELOPMENT_${ANTS_FUNCTION_NAME}
)
endif()

View File

@ -1,17 +0,0 @@
--- a/ANTS.cmake 2020-06-08 12:11:14.000000000 -0400
+++ b/ANTS.cmake 2020-08-03 16:44:00.826633506 -0400
@@ -37,7 +37,6 @@
set(${PROJECT_NAME}_VERSION_MAJOR 0)
set(${PROJECT_NAME}_VERSION_MINOR 0)
set(${PROJECT_NAME}_VERSION_PATCH 0)
- set(${PROJECT_NAME}_VERSION_TWEAK 0)
set(${PROJECT_NAME}_VERSION "snapshot-${ANTS_SNAPSHOT_VERSION}")
endif()
@@ -46,7 +45,6 @@
set(${PROJECT_NAME}_VERSION_MAJOR 0)
set(${PROJECT_NAME}_VERSION_MINOR 0)
set(${PROJECT_NAME}_VERSION_PATCH 0)
- set(${PROJECT_NAME}_VERSION_TWEAK 0)
set(${PROJECT_NAME}_VERSION "0.0.0.0")
endif()

View File

@ -1,24 +0,0 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>chr@chymera.eu</email>
<name>Horea Christian</name>
</maintainer>
<maintainer type="project">
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>
</maintainer>
<longdescription>
ANTs extracts information from complex datasets that include imaging
(Word Cloud). Paired with ANTsR (answer), ANTs is useful for managing,
interpreting and visualizing multidimensional data. ANTs is popularly
considered a state-of-the-art medical image registration and segmentation
toolkit. ANTsR is an emerging tool supporting standardized multimodality
image analysis. ANTs depends on the Insight ToolKit (ITK), a widely used
medical image processing library to which ANTs developers contribute.
</longdescription>
<use>
<flag name="vtk">Optional support for a number of surface enabled tools (via sci-libs/vtk).</flag>
</use>
</pkgmetadata>