sci-visualization/fsleyes-widgets: version bump 0.8.4 ahead of Gentoo Science
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Horea Christian <chr@chymera.eu>
This commit is contained in:
parent
12ab12b63c
commit
af200298e9
7
sci-visualization/fsleyes-widgets/ChangeLog
Normal file
7
sci-visualization/fsleyes-widgets/ChangeLog
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
*fsleyes-widgets-0.8.4 (16 Jan 2020)
|
||||||
|
|
||||||
|
16 Jan 2020; <chymera@gentoo.org>
|
||||||
|
+files/fsleyes-widgets-0.8.4-coverage.patch,
|
||||||
|
+files/fsleyes-widgets-0.8.4-tests.patch, +fsleyes-widgets-0.8.4.ebuild,
|
||||||
|
+metadata.xml, -fsleyes-widgets-0.6.5.ebuild, -manifest.xml:
|
||||||
|
sci-visualization/fsleyes-widgets: version bump 0.8.4 ahead of Gentoo Science
|
@ -1 +1 @@
|
|||||||
DIST fsleyes-widgets-0.6.5.tar.gz 1035501 SHA256 498af133b6ee811f3e77657975fb198eee52880ff5b10bd55becc4e59a56dd16 SHA512 686f248276eaead7de26547f27d03c089cef06e3bbadb745527a22fad4c89ca14569bcf267a108ecb6bde64055256f24ca66f2940e1fe896787660ce6b2b672b WHIRLPOOL 768eba8d56e41c53c24c65c63b0ff27a78dc3e6af183bbf5e6ef55d86d4d915a3d0910f3fdc6d032bda434a253713e02bb58dfb135afc6097ff6da7e3db85515
|
DIST fsleyes-widgets-0.8.4.tar.gz 1063873 SHA256 c9de830fe097c9f5a38b31c5acadfeffd26b52f00ed68d9c4906a0010875f444 SHA512 b3b3a5f1a963022f82456c2d6978e02e6f0eb459a76d3aa9f924dbb484ad8359fe9344e9d914c859bd213406707b1b3456de8543b1400728b84fb503ae1fddc8 WHIRLPOOL a306e0209888c4b0b85cf3b77b34889fb205a29a838a8fc26f51011e69e5aaff8e802fa95182fbcd3bf5e00dfd376bb6743f613373dd1ae24ec4d8bf6ca50e62
|
||||||
|
@ -0,0 +1,10 @@
|
|||||||
|
diff --git a/setup.cfg b/setup.cfg
|
||||||
|
index c3ebd936..d678d2df 100644
|
||||||
|
--- a/setup.cfg
|
||||||
|
+++ b/setup.cfg
|
||||||
|
@@ -9,4 +9,4 @@ ignore = E127,E201,E203,E221,E222,E241,E271,E272,E301,E302,E303,E701
|
||||||
|
|
||||||
|
[tool:pytest]
|
||||||
|
testpaths = tests
|
||||||
|
-addopts = -v --cov=fsleyes_widgets
|
||||||
|
+addopts = -v
|
@ -0,0 +1,69 @@
|
|||||||
|
diff --git a/tests/test_floatslider.py b/tests/test_floatslider.py
|
||||||
|
index 87a2477..6bbedb7 100644
|
||||||
|
--- a/tests/test_floatslider.py
|
||||||
|
+++ b/tests/test_floatslider.py
|
||||||
|
@@ -140,8 +140,14 @@ def _test_FloatSlider_changeRange():
|
||||||
|
_test_widget_changeRange(slider)
|
||||||
|
|
||||||
|
|
||||||
|
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
||||||
|
+ "https://github.com/pauldmccarthy/fsleyes-widgets/issues/1"
|
||||||
|
+ )
|
||||||
|
def test_FloatSlider_mouse_non_gtk():
|
||||||
|
run_with_wx(_test_FloatSlider_mouse)
|
||||||
|
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
||||||
|
+ "https://github.com/pauldmccarthy/fsleyes-widgets/issues/1"
|
||||||
|
+ )
|
||||||
|
def test_FloatSlider_mouse_gtk():
|
||||||
|
with mock.patch('fsleyes_widgets.floatslider.wx.Platform', '__WXGTK__'):
|
||||||
|
run_with_wx(_test_FloatSlider_mouse)
|
||||||
|
@@ -322,7 +328,9 @@ def _test_SliderSpinPanel_show_edit_limits():
|
||||||
|
if shouldEv: assert result[0] == expected
|
||||||
|
else: assert result[0] is None
|
||||||
|
|
||||||
|
-
|
||||||
|
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
||||||
|
+ "https://github.com/pauldmccarthy/fsleyes-widgets/issues/1"
|
||||||
|
+ )
|
||||||
|
def test_SliderSpinPanel_events():
|
||||||
|
run_with_wx(_test_SliderSpinPanel_events)
|
||||||
|
def _test_SliderSpinPanel_events():
|
||||||
|
diff --git a/tests/test_notebook.py b/tests/test_notebook.py
|
||||||
|
index a02226c..74e8f63 100644
|
||||||
|
--- a/tests/test_notebook.py
|
||||||
|
+++ b/tests/test_notebook.py
|
||||||
|
@@ -190,6 +190,9 @@ def _test_enable_disable_show_hide(side, ornt):
|
||||||
|
assert notebook.GetSelection() == 1
|
||||||
|
|
||||||
|
|
||||||
|
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
||||||
|
+ "https://github.com/pauldmccarthy/fsleyes-widgets/issues/1"
|
||||||
|
+ )
|
||||||
|
def test_event():
|
||||||
|
nb_run_with_wx(_test_event)
|
||||||
|
def _test_event(side, ornt):
|
||||||
|
diff --git a/tests/test_rangeslider.py b/tests/test_rangeslider.py
|
||||||
|
index 7ddbed6..51267b3 100644
|
||||||
|
--- a/tests/test_rangeslider.py
|
||||||
|
+++ b/tests/test_rangeslider.py
|
||||||
|
@@ -103,6 +103,9 @@ def _test_RangePanel_logic_spin():
|
||||||
|
_test_RangePanel_logic(panel)
|
||||||
|
|
||||||
|
|
||||||
|
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
||||||
|
+ "https://github.com/pauldmccarthy/fsleyes-widgets/issues/1"
|
||||||
|
+ )
|
||||||
|
def test_RangePanel_events_slider():
|
||||||
|
run_with_wx(_test_RangePanel_events_slider)
|
||||||
|
def _test_RangePanel_events_slider():
|
||||||
|
@@ -236,6 +239,9 @@ def _test_RangeSliderSpinPanel_logic():
|
||||||
|
_test_RangePanel_logic(panel)
|
||||||
|
|
||||||
|
|
||||||
|
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
||||||
|
+ "https://github.com/pauldmccarthy/fsleyes-widgets/issues/1"
|
||||||
|
+ )
|
||||||
|
def test_RangeSliderSpinPanel_onchange():
|
||||||
|
run_with_wx(_test_RangeSliderSpinPanel_onchange)
|
||||||
|
def _test_RangeSliderSpinPanel_onchange():
|
||||||
|
|
@ -1,15 +1,15 @@
|
|||||||
# Copyright 1999-2018 Gentoo Foundation
|
# Copyright 1999-2020 Gentoo Authors
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
EAPI=7
|
EAPI=7
|
||||||
|
|
||||||
PYTHON_COMPAT=( python2_7 python3_{5,6} )
|
PYTHON_COMPAT=( python3_{6,7} )
|
||||||
|
|
||||||
inherit distutils-r1 virtualx
|
inherit distutils-r1 virtualx
|
||||||
|
|
||||||
MY_P="widgets-${PV}"
|
MY_P="widgets-${PV}"
|
||||||
|
|
||||||
DESCRIPTION="The new FSL image viewer, released with FSL 5.0.10"
|
DESCRIPTION="The new FSL image viewer, first released with FSL 5.0.10"
|
||||||
HOMEPAGE="https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/tree/master"
|
HOMEPAGE="https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/tree/master"
|
||||||
SRC_URI="https://git.fmrib.ox.ac.uk/fsl/fsleyes/widgets/-/archive/${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
|
SRC_URI="https://git.fmrib.ox.ac.uk/fsl/fsleyes/widgets/-/archive/${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
|
||||||
|
|
||||||
@ -19,7 +19,9 @@ KEYWORDS="~amd64 ~x86"
|
|||||||
IUSE="test"
|
IUSE="test"
|
||||||
|
|
||||||
DEPEND="
|
DEPEND="
|
||||||
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
|
test? (
|
||||||
|
dev-python/pytest[${PYTHON_USEDEP}]
|
||||||
|
)
|
||||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
dev-python/setuptools[${PYTHON_USEDEP}]
|
||||||
"
|
"
|
||||||
RDEPEND="
|
RDEPEND="
|
||||||
@ -32,7 +34,11 @@ RDEPEND="
|
|||||||
|
|
||||||
S="${WORKDIR}/${MY_P}"
|
S="${WORKDIR}/${MY_P}"
|
||||||
|
|
||||||
|
PATCHES=(
|
||||||
|
"${FILESDIR}/fsleyes-widgets-0.8.4-coverage.patch"
|
||||||
|
"${FILESDIR}/fsleyes-widgets-0.8.4-tests.patch"
|
||||||
|
)
|
||||||
|
|
||||||
python_test() {
|
python_test() {
|
||||||
virtx pytest --verbose || die
|
virtx pytest --verbose || die
|
||||||
}
|
}
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user