1
0
Fork 0

dev-lang/lazarus: fixed Python USE flag ahead of Gentoo Main

Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Horea Christian <chr@chymera.eu>
This commit is contained in:
Horea Christian 2019-11-23 17:06:53 +01:00
parent 40de0dd473
commit a91802ccab
No known key found for this signature in database
GPG Key ID: EAA9223EE3BB378A
5 changed files with 143 additions and 0 deletions

View File

@ -0,0 +1,5 @@
*lazarus-2.0.2-r1 (23 Nov 2019)
23 Nov 2019; <chymera@gentoo.org> +files/lazarus-0.9.26-fpcsrc.patch,
+lazarus-2.0.2-r1.ebuild, +metadata.xml:
dev-lang/lazarus: fixed Python USE flag ahead of Gentoo Main

View File

@ -0,0 +1,2 @@
DIST lazarus-2.0.2.tar.gz 67092332 SHA256 e9d07f176e63c6ff7cf693a135ee66135c147ba398f67b8c6fe892c726f6a476 SHA512 0d2bf26afa3128104181fbe57b1adeaba3bb589b0a3b72598507825a3f08201d4480c6cff510a6f866dca4d49417fac3a2f68ca7e58fabe4f4e3bad97323c071 WHIRLPOOL 81bbaf476e121d335a493ed5021fc7b8aadd53dcc22f42e426d3278fa7675ea798c8d9fc30140808bb382c44b824442c6f7863ac83862604cf38a0a4deb11d84
DIST lazarus-python-f362a0ea44a1981558539833a0354c1cf4b10eca.tar.gz 1254207 SHA256 3483e38fd84488e2321575e8549cc20041a7c3f89bb10319dfe6a135b967388c SHA512 3b93ac44838e09bdd61bde50f93d116d113779679f6dff1288a0b16003bbfcea0fca2edcc77cfc013ef605e3e7fca5dc71322f4cf9b5b6f78d25c18e7a74ce8f WHIRLPOOL e863641020ddf80365065f2e27145095fe5e5fc303d15ac867f371a4129a3a39f85960c63a19902386d3dfc8ab652496a8e12b7bd41ce66f081e6e5f5e6620e6

View File

@ -0,0 +1,13 @@
--- lazarus/ide/include/unix/lazbaseconf.inc
+++ lazarus/ide/include/unix/lazbaseconf.inc
@@ -24,8 +24,9 @@
}
const
- DefaultFPCSrcDirs: array[1..15] of string = (
+ DefaultFPCSrcDirs: array[1..16] of string = (
// search first for sources with right version
+ '/usr/lib/fpc/$(FPCVer)/source',
'/usr/share/fpcsrc/$(FPCVer)',
// then search for global paths
'/usr/share/fpcsrc',

View File

@ -0,0 +1,106 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit desktop
FPCVER="3.0.4"
PYTHON_HASH="f362a0ea44a1981558539833a0354c1cf4b10eca"
DESCRIPTION="Lazarus IDE is a feature rich visual programming environment emulating Delphi"
HOMEPAGE="https://www.lazarus-ide.org/"
SRC_URI="
python? ( https://github.com/Alexey-T/Python-for-Lazarus/archive/${PYTHON_HASH}.tar.gz ->\
${PN}-python-${PYTHON_HASH}.tar.gz )
https://sourceforge.net/projects/${PN}/files/Lazarus%20Zip%20_%20GZip/Lazarus%20${PV}/${P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1-with-linking-exception"
SLOT="0" # Note: Slotting Lazarus needs slotting fpc, see DEPEND.
KEYWORDS="~amd64 ~x86"
IUSE="minimal python"
DEPEND=">=dev-lang/fpc-${FPCVER}[source]
net-misc/rsync
x11-libs/gtk+:2
>=sys-devel/binutils-2.19.1-r1:="
RDEPEND="${DEPEND}"
RESTRICT="strip" #269221
S="${WORKDIR}/${PN}"
PATCHES=( "${FILESDIR}"/${PN}-0.9.26-fpcsrc.patch )
src_prepare() {
default
# Use default configuration (minus stripping) unless specifically requested otherwise
if ! test ${PPC_CONFIG_PATH+set} ; then
local FPCVER=$(fpc -iV)
export PPC_CONFIG_PATH="${WORKDIR}"
sed -e 's/^FPBIN=/#&/' /usr/lib/fpc/${FPCVER}/samplecfg |
sh -s /usr/lib/fpc/${FPCVER} "${PPC_CONFIG_PATH}" || die
fi
sed -i \
-e "s;SecondaryConfigPath:='/etc/lazarus';SecondaryConfigPath:=ExpandFileNameUTF8('~/.lazarus');g" \
-e "s;PrimaryConfigPath:=ExpandFileNameUTF8('~/.lazarus');PrimaryConfigPath:='/etc/lazarus';g" \
ide/include/unix/lazbaseconf.inc \
|| die
}
src_compile() {
LCL_PLATFORM=gtk2 emake \
$(usex minimal "" "bigide") \
-j1
if use python; then
addpredict ide/exttools.pas
./lazbuild -B --lazarusdir="." --pcp="../lazarus-package-config" --build-ide= \
--add-package ../Python-for-Lazarus-${PYTHON_HASH}/python4lazarus/python4lazarus_package.lpk \
|| die
sed -i -e "s:${WORKDIR}/Python-for-Lazarus-${PYTHON_HASH}:/etc/lazarus:g" \
../lazarus-package-config/packagefiles.xml \
../lazarus-package-config/idemake.cfg \
../Python-for-Lazarus-${PYTHON_HASH}/python4lazarus/lib/x86_64-linux/python4lazarus_package.compiled \
|| die
sed -i -e "s:${WORKDIR}/lazarus-package-config:/etc/lazarus:g" \
../lazarus-package-config/idemake.cfg \
|| die
fi
}
src_install() {
diropts -m0755
dodir /usr/share
# Using rsync to avoid unnecessary copies and cleaning...
# Note: *.o and *.ppu are needed
rsync -a \
--exclude="CVS" --exclude=".cvsignore" \
--exclude="*.ppw" --exclude="*.ppl" \
--exclude="*.ow" --exclude="*.a"\
--exclude="*.rst" --exclude=".#*" \
--exclude="*.~*" --exclude="*.bak" \
--exclude="*.orig" --exclude="*.rej" \
--exclude=".xvpics" --exclude="*.compiled" \
--exclude="killme*" --exclude=".gdb_hist*" \
--exclude="debian" --exclude="COPYING*" \
--exclude="*.app" \
"${S}" "${ED%/}"/usr/share \
|| die "Unable to copy files!"
dosym ../share/lazarus/startlazarus /usr/bin/startlazarus
dosym ../share/lazarus/startlazarus /usr/bin/lazarus
dosym ../share/lazarus/lazbuild /usr/bin/lazbuild
use minimal || dosym ../share/lazarus/components/chmhelp/lhelp/lhelp /usr/bin/lhelp
dosym ../lazarus/images/ide_icon48x48.png /usr/share/pixmaps/lazarus.png
if use python; then
diropts -m0755
dodir /etc/lazarus
cp -rf ../lazarus-package-config/* \
"${ED%/}"/etc/lazarus || die
cp -rf ../Python-for-Lazarus-${PYTHON_HASH}/python4lazarus \
"${ED%/}"/etc/lazarus || die
fi
make_desktop_entry startlazarus "Lazarus IDE" "lazarus"
}

View File

@ -0,0 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>amynka@gentoo.org</email>
</maintainer>
<longdescription lang="en">
A Borland Delphi lookalike for linux.
Uses the free pascal compiler.
</longdescription>
<use>
<flag name="minimal">Don't build extra packages from the bigide component</flag>
</use>
<upstream>
<remote-id type="sourceforge">downloads</remote-id>
</upstream>
</pkgmetadata>