1
0
Fork 0

dev-python/pynwb: version bump and test skip

linking skipped test reports on upstream issue treacker

Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Horea Christian <chr@chymera.eu>
This commit is contained in:
Horea Christian 2022-01-31 02:46:26 -05:00
parent 10efd05a08
commit a90f5579dd
No known key found for this signature in database
GPG Key ID: 161C0BE6255333D3
5 changed files with 96 additions and 3 deletions

View File

@ -0,0 +1,6 @@
*pynwb-2.0.0_p0 (31 Jan 2022)
31 Jan 2022; <chymera@gentoo.org> +files/pynwb-2.0.0-versions.patch,
+pynwb-2.0.0_p0.ebuild, pynwb-2.0.0.ebuild:
dev-python/pynwb: version bump and test skip linking skipped test reports on
upstream issue treacker

View File

@ -1 +1,2 @@
DIST pynwb-2.0.0.post0.dev5.tar.gz 450799 SHA256 28fdbca8611ee447f2bf30e78d7053626de6dfcf8368db4e01bea62db2f9566d SHA512 840a33cd0a2de5c491e785530e4dab589945015b9a60384ed127a27fbfe4c527b1b10d74a9ffe2a795a29c3bba65aafd007975973a2da68fca73bf71260b7b8b WHIRLPOOL 749958c8aadfdaa369239a8c1b25bb5dd2e27aee58a1cc477ea1b189543ab4178338c55781778ed70db596e97d9d355cbe87d3cba972355cf4762f609ff5194c
DIST pynwb-2.0.0.tar.gz 450082 SHA256 c22c96dd255e69cee1835057d741613d52c2ea1c45b6a1ef7f87ebaa8a5055ad SHA512 4afc319fd9cce0c1e81589236237f9a28b69dd846d96849ae5cc554287a6dd124fd421f700736dbb714cfbe6f260e79f374d1dd63ee92c2776f5173654d61f9a WHIRLPOOL 0a14cb4e7369f52f40294265ea3af760161cbf14a81797f50b372f081f49e94d8a5d6d828e212eb9136b224afbee52ae6a8e299b52a7f10231d59c33c7225284

View File

@ -0,0 +1,21 @@
diff --git a/setup.py b/tmp/setup.py
index 39e75824..f7948f64 100755
--- a/setup.py
+++ b/setup.py
@@ -19,11 +19,11 @@ print('found these packages:', pkgs)
schema_dir = 'nwb-schema/core'
reqs = [
- 'h5py>=2.9,<4',
- 'hdmf>=3.1.1,<4',
- 'numpy>=1.16,<1.22',
- 'pandas>=1.0.5,<2',
- 'python-dateutil>=2.7,<3',
+ 'h5py',
+ 'hdmf',
+ 'numpy',
+ 'pandas',
+ 'python-dateutil',
'setuptools'
]

View File

@ -1,4 +1,4 @@
# Copyright 1999-2021 Gentoo Authors
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@ -24,5 +24,23 @@ RDEPEND="
"
BDEPEND=""
distutils_enable_tests setup.py
# 2 tests fail, ongoing: https://bugs.gentoo.org/814530
PATCHES=(
"${FILESDIR}/${P}-versions.patch"
)
EPYTEST_DESELECT=(
# Reported upsream:
# https://github.com/dandi/dandischema/issues/87
tests/validation/test_validate.py::TestValidateScript::test_validate_file_cached
tests/validation/test_validate.py::TestValidateScript::test_validate_file_cached_bad_ns
tests/validation/test_validate.py::TestValidateScript::test_validate_file_cached_hdmf_common
tests/validation/test_validate.py::TestValidateScript::test_validate_file_cached_ignore
tests/validation/test_validate.py::TestValidateScript::test_validate_file_no_cache
tests/validation/test_validate.py::TestValidateScript::test_validate_file_no_cache_bad_ns
# Reported upstream and fixed in newer version:
# https://github.com/NeurodataWithoutBorders/pynwb/issues/1412#issuecomment-934153799
tests/integration/ros3/test_ros3.py::TestRos3Streaming::test_dandi_read
tests/integration/ros3/test_ros3.py::TestRos3Streaming::test_read
)
distutils_enable_tests pytest

View File

@ -0,0 +1,47 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
MY_PV="$(ver_cut 1-3).post$(ver_cut 5).dev5"
MY_P="${PN}-${MY_PV}"
DESCRIPTION="A Python API for working with Neurodata stored in the NWB Format "
HOMEPAGE="https://github.com/NeurodataWithoutBorders/pynwb"
SRC_URI="https://github.com/NeurodataWithoutBorders/pynwb/releases/download/latest/${MY_P}.tar.gz"
SLOT="0"
LICENSE="BSD"
KEYWORDS="~amd64 ~x86"
RDEPEND="
sci-libs/hdf5[ros3]
dev-python/hdmf[${PYTHON_USEDEP}]
dev-python/h5py[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
"
BDEPEND=""
PATCHES=(
"${FILESDIR}/${PN}-2.0.0-versions.patch"
)
S="${WORKDIR}/${MY_P}"
EPYTEST_DESELECT=(
# Reported upsream
# https://github.com/dandi/dandischema/issues/87
tests/validation/test_validate.py::TestValidateScript::test_validate_file_cached
tests/validation/test_validate.py::TestValidateScript::test_validate_file_cached_bad_ns
tests/validation/test_validate.py::TestValidateScript::test_validate_file_cached_hdmf_common
tests/validation/test_validate.py::TestValidateScript::test_validate_file_cached_ignore
tests/validation/test_validate.py::TestValidateScript::test_validate_file_no_cache
tests/validation/test_validate.py::TestValidateScript::test_validate_file_no_cache_bad_ns
)
distutils_enable_tests pytest