Applied patches from bugs.gentoo.org
https://bugs.gentoo.org/attachment.cgi?id=553606 - by Alex https://bugs.gentoo.org/667318#c11
This commit is contained in:
parent
7ff60f6e24
commit
97e4d2861c
18
dev-python/wxpython/files/wxpython-4.0.3-parallel.patch
Normal file
18
dev-python/wxpython/files/wxpython-4.0.3-parallel.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
--- a/setup.py 2018-06-26 04:20:04.000000000 +0200
|
||||||
|
+++ b/setup.py 2018-11-06 17:47:28.940450375 +0100
|
||||||
|
@@ -105,6 +105,7 @@
|
||||||
|
"""
|
||||||
|
user_options = [
|
||||||
|
('skip-build', None, 'skip building the C/C++ code (assumes it has already been done)'),
|
||||||
|
+ ('parallel=', 'j', "number of parallel build jobs")
|
||||||
|
]
|
||||||
|
boolean_options = ['skip-build']
|
||||||
|
|
||||||
|
@@ -112,6 +113,7 @@
|
||||||
|
def initialize_options(self):
|
||||||
|
orig_build.initialize_options(self)
|
||||||
|
self.skip_build = '--skip-build' in sys.argv
|
||||||
|
+ self.parallel = None
|
||||||
|
|
||||||
|
def finalize_options(self):
|
||||||
|
orig_build.finalize_options(self)
|
59
dev-python/wxpython/files/wxpython-4.0.3-webkit.patch
Normal file
59
dev-python/wxpython/files/wxpython-4.0.3-webkit.patch
Normal file
@ -0,0 +1,59 @@
|
|||||||
|
--- a/wscript 2018-06-26 07:20:04.000000000 +0500
|
||||||
|
+++ b/wscript 2018-10-29 20:10:06.236956371 +0500
|
||||||
|
@@ -131,8 +131,8 @@
|
||||||
|
_copyEnvGroup(conf.env, '_WX', '_WXGL')
|
||||||
|
conf.env.LIB_WXGL += cfg.makeLibName('gl')
|
||||||
|
|
||||||
|
- _copyEnvGroup(conf.env, '_WX', '_WXWEBVIEW')
|
||||||
|
- conf.env.LIB_WXWEBVIEW += cfg.makeLibName('webview')
|
||||||
|
+ #_copyEnvGroup(conf.env, '_WX', '_WXWEBVIEW')
|
||||||
|
+ #conf.env.LIB_WXWEBVIEW += cfg.makeLibName('webview')
|
||||||
|
|
||||||
|
_copyEnvGroup(conf.env, '_WX', '_WXXML')
|
||||||
|
conf.env.LIB_WXXML += cfg.makeLibName('xml', isMSWBase=True)
|
||||||
|
@@ -220,16 +220,16 @@
|
||||||
|
uselib_store='WXGL', mandatory=True,
|
||||||
|
msg='Finding libs for WXGL')
|
||||||
|
|
||||||
|
- conf.check_cfg(path=conf.options.wx_config, package='',
|
||||||
|
- args='--cxxflags --libs webview,core,net' + rpath,
|
||||||
|
- uselib_store='WXWEBVIEW', mandatory=True,
|
||||||
|
- msg='Finding libs for WXWEBVIEW')
|
||||||
|
-
|
||||||
|
- if isDarwin:
|
||||||
|
- conf.check_cfg(path=conf.options.wx_config, package='',
|
||||||
|
- args='--cxxflags --libs core,net' + rpath,
|
||||||
|
- uselib_store='WXWEBKIT', mandatory=True,
|
||||||
|
- msg='Finding libs for WXWEBKIT')
|
||||||
|
+ #conf.check_cfg(path=conf.options.wx_config, package='',
|
||||||
|
+ # args='--cxxflags --libs webview,core,net' + rpath,
|
||||||
|
+ # uselib_store='WXWEBVIEW', mandatory=True,
|
||||||
|
+ # msg='Finding libs for WXWEBVIEW')
|
||||||
|
+
|
||||||
|
+ #if isDarwin:
|
||||||
|
+ # conf.check_cfg(path=conf.options.wx_config, package='',
|
||||||
|
+ # args='--cxxflags --libs core,net' + rpath,
|
||||||
|
+ # uselib_store='WXWEBKIT', mandatory=True,
|
||||||
|
+ # msg='Finding libs for WXWEBKIT')
|
||||||
|
|
||||||
|
conf.check_cfg(path=conf.options.wx_config, package='',
|
||||||
|
args='--cxxflags --libs xml,core,net' + rpath,
|
||||||
|
@@ -567,7 +567,7 @@
|
||||||
|
makeETGRule(bld, 'etg/_stc.py', '_stc', 'WXSTC')
|
||||||
|
makeETGRule(bld, 'etg/_html.py', '_html', 'WXHTML')
|
||||||
|
makeETGRule(bld, 'etg/_glcanvas.py', '_glcanvas', 'WXGL')
|
||||||
|
- makeETGRule(bld, 'etg/_html2.py', '_html2', 'WXWEBVIEW')
|
||||||
|
+ #makeETGRule(bld, 'etg/_html2.py', '_html2', 'WXWEBVIEW')
|
||||||
|
makeETGRule(bld, 'etg/_xml.py', '_xml', 'WXXML')
|
||||||
|
makeETGRule(bld, 'etg/_xrc.py', '_xrc', 'WXXRC')
|
||||||
|
makeETGRule(bld, 'etg/_richtext.py', '_richtext', 'WXHTML WXRICHTEXT')
|
||||||
|
@@ -577,8 +577,8 @@
|
||||||
|
makeETGRule(bld, 'etg/_aui.py', '_aui', 'WXAUI')
|
||||||
|
|
||||||
|
# Modules that are platform-specific
|
||||||
|
- if isDarwin:
|
||||||
|
- makeETGRule(bld, 'etg/_webkit.py', '_webkit', 'WXWEBKIT')
|
||||||
|
+ #if isDarwin:
|
||||||
|
+ #makeETGRule(bld, 'etg/_webkit.py', '_webkit', 'WXWEBKIT')
|
||||||
|
if isWindows:
|
||||||
|
makeETGRule(bld, 'etg/_msw.py', '_msw', 'WX')
|
@ -41,6 +41,11 @@ DEPEND="
|
|||||||
)
|
)
|
||||||
"
|
"
|
||||||
|
|
||||||
|
PATCHES=(
|
||||||
|
"${FILESDIR}/${PN}"-4.0.3-webkit.patch
|
||||||
|
"${FILESDIR}/${PN}"-4.0.3-parallel.patch
|
||||||
|
)
|
||||||
|
|
||||||
S="${WORKDIR}/${MY_PN}-${PV}"
|
S="${WORKDIR}/${MY_PN}-${PV}"
|
||||||
|
|
||||||
python_prepare_all() {
|
python_prepare_all() {
|
||||||
|
Loading…
x
Reference in New Issue
Block a user