1
0
Fork 0

dev-python/nwb-conversion-tools: new package (DANDI ephys stack)

Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Horea Christian <chr@chymera.eu>
This commit is contained in:
Horea Christian 2021-10-19 11:18:57 -04:00
parent 4d1f0752ff
commit 97086923c4
No known key found for this signature in database
GPG Key ID: 161C0BE6255333D3
5 changed files with 86 additions and 0 deletions

View File

@ -0,0 +1,6 @@
*nwb-conversion-tools-0.9.3 (19 Oct 2021)
19 Oct 2021; <chymera@gentoo.org>
+files/nwb-conversion-tools-0.9.3-no-git-versioncheck.patch, +metadata.xml,
+nwb-conversion-tools-0.9.3.ebuild:
dev-python/nwb-conversion-tools: new package (DANDI ephys stack)

View File

@ -0,0 +1 @@
DIST nwb-conversion-tools-0.9.3.tar.gz 8516667 SHA256 4a87c4d014c7737db469acb86bb7f5434bbdc271316f60b1bd3f145258279215 SHA512 24c3c8cd8ae7cdec14a758890cbd6c24b2cc02c6b6468aadb94b5f6ce6ff88feea626e7febc3a9b3ea993019012e0b6bc6d31c91fa3810a0ea92d5625769e955 WHIRLPOOL 27c040d18a84cc41c04397952318d26b9dfe0521b5daaf8c62fea877d55cfeda967fd9664c849c753e0024b1e2b2f7d7dc94bb3e6e2f2bde6991911b5d422e0b

View File

@ -0,0 +1,13 @@
--- a/setup.py 2021-10-19 07:59:23.483551681 -0400
+++ b/setup.py 2021-10-19 08:00:20.289169440 -0400
@@ -22,10 +22,6 @@
with open(os.path.join(here, req_file)) as f:
install_requires = f.read().strip().split("\n")
-# Get remote version
-remote_version = subprocess.run(["git", "describe", "--tags"], stdout=subprocess.PIPE).stdout.decode("utf-8").strip()
-assert "." in remote_version
-
setup(
name="nwb-conversion-tools",
version="0.9.3",

View File

@ -0,0 +1,15 @@
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>gentoo@chymera.eu</email>
<name>Horea Christian</name>
</maintainer>
<maintainer type="project">
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>
</maintainer>
<upstream>
<remote-id type="github">SpikeInterface/spikeinterface</remote-id>
</upstream>
</pkgmetadata>

View File

@ -0,0 +1,51 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{8..9} )
# 3.10 missing on numba and spyking-circus
inherit distutils-r1
DESCRIPTION="Create NWB files by converting proprietary formats and adding essential metadata"
HOMEPAGE="https://github.com/catalystneuro/nwb-conversion-tools"
SRC_URI="https://github.com/catalystneuro/nwb-conversion-tools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
IUSE="test"
#RESTRICT="test"
RDEPEND="
dev-python/h5py[${PYTHON_USEDEP}]
dev-python/jsonschema[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/natsort[${PYTHON_USEDEP}]
dev-python/neo[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/pynwb[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
dev-python/spikeextractors[${PYTHON_USEDEP}]
dev-python/tqdm[${PYTHON_USEDEP}]
"
# also needs:
# spikesorters
# spiketoolkit
# neo == 0.9.0, actually
# roiextractors
DEPEND="
test? (
${RDEPEND}
)
"
BDEPEND=""
PATCHES=(
"${FILESDIR}/${PN}-0.9.3-no-git-versioncheck.patch"
)
distutils_enable_tests pytest