1
0
mirror of synced 2024-12-22 12:50:33 +01:00

removed gst

This commit is contained in:
Horea Christian 2014-08-16 00:20:12 +02:00
parent c297304453
commit 8a32516464
3 changed files with 0 additions and 106 deletions

View File

@ -1 +0,0 @@
DIST gst-python-1.1.90.tar.bz2 411068 SHA256 542c9f9936c95cc419da7af9c004ad34066793baba67c052f0c08c42459f5eef SHA512 29aff2e71844d9510d016099f64e7c30158b3e04568e7dce9da940fffd3189d4d9a6277cf1fc5878a017d2c3faafacbfdc1b1cb69041d6121dc25badb0f4ee15 WHIRLPOOL 9ccbd22732c4f4827f24b6f3bb4ab4210e38ac6092b960fe13a473a746c12c0e246f577c9278480a4be4e5f43f238e7a4dd1a5a61438cad6cff4dc2cbaa48423

View File

@ -1,21 +0,0 @@
diff -ur gst-python-0.10.9.orig/configure.ac gst-python-0.10.9/configure.ac
--- gst-python-0.10.9.orig/configure.ac 2007-11-28 11:33:05.000000000 +0200
+++ gst-python-0.10.9/configure.ac 2007-11-28 18:09:48.000000000 +0200
@@ -363,6 +363,17 @@
AG_GST_VALGRIND_CHECK
+AC_MSG_CHECKING([whether $LD accepts -z,lazy])
+case `$LD -z,lazy -v 2>&1 </dev/null` in
+*GNU* | *'with BFD'*)
+ LDFLAGS="$LDFLAGS -Wl,-z,lazy"
+ AC_MSG_RESULT([yes])
+ ;;
+*)
+ AC_MSG_RESULT([no])
+ ;;
+esac
+
AC_OUTPUT([
Makefile
codegen/Makefile

View File

@ -1,84 +0,0 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-0.10.22-r1.ebuild,v 1.11 2013/10/22 06:23:06 ago Exp $
EAPI="5"
PYTHON_COMPAT=( python2_{6,7} )
inherit autotools eutils python-r1 virtualx
DESCRIPTION="A Python Interface to GStreamer"
HOMEPAGE="http://gstreamer.freedesktop.org/"
SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="1"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
IUSE="examples test"
RDEPEND="
dev-libs/libxml2
>=dev-python/pygobject-3.2.2:3[${PYTHON_USEDEP}]
>=media-libs/gstreamer-1.0.10:1.0
>=media-libs/gst-plugins-base-1.0.10:1.0
"
DEPEND="${RDEPEND}
virtual/pkgconfig
test? (
media-plugins/gst-plugins-ogg:0.10
!!media-plugins/gst-plugins-ivorbis:0.10
media-plugins/gst-plugins-vorbis:0.10
)" # tests a "audiotestsrc ! vorbisenc ! oggmux ! fakesink" pipeline
# XXX: it looks like tests cannot be bothered with two vorbisdec implementations
src_prepare() {
# Leave examples alone
sed -e 's/\(SUBDIRS = .*\)examples/\1/' \
-i Makefile.am Makefile.in || die
sed \
-e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' \
-i configure.ac || die
epatch "${FILESDIR}"/${PN}-0.10.9-lazy.patch
AT_M4DIR="common/m4" eautoreconf
prepare_gst() {
mkdir -p "${BUILD_DIR}" || die
}
python_foreach_impl prepare_gst
}
src_configure() {
configure_gst() {
ECONF_SOURCE="${S}" econf
}
python_foreach_impl run_in_build_dir configure_gst
}
src_compile() {
python_foreach_impl run_in_build_dir default
}
src_test() {
LC_ALL="C" GST_REGISTRY="${T}/registry.cache.xml" python_foreach_impl run_in_build_dir Xemake check
}
src_install() {
python_foreach_impl run_in_build_dir default
prune_libtool_files --modules
dodoc AUTHORS ChangeLog NEWS README TODO
if use examples; then
docinto examples
dodoc examples/*
fi
}
run_in_build_dir() {
pushd "${BUILD_DIR}" > /dev/null || die
"$@"
popd > /dev/null
}