Updated repo location
This commit is contained in:
parent
1ffe58f61d
commit
89aa6e02bd
@ -12,7 +12,7 @@ To enable this overlay make sure you are using a recent Portage version (at leas
|
|||||||
|
|
||||||
```
|
```
|
||||||
[chymeric]
|
[chymeric]
|
||||||
location = /usr/local/portage/chymeric
|
location = /var/lib/overlays/chymeric
|
||||||
sync-type = git
|
sync-type = git
|
||||||
sync-uri = https://github.com/TheChymera/gentoo-overlay.git
|
sync-uri = https://github.com/TheChymera/gentoo-overlay.git
|
||||||
priority=8889
|
priority=8889
|
||||||
|
@ -1,3 +1,4 @@
|
|||||||
DIST Pillow-3.4.2.zip 11042238 BLAKE2B 334af6eeadb3203b51572eca6ad9c196f3eeac14da0f1aedc351db692b33d413fdf5bc5c8564d2f53c324d9485dbdbda664b75a570b779e24f238c21829b4a39 SHA512 5e05206db5bc1b4177384f7e91ee79015c6e1bbdc7c31c997da054391b9b5ec7c1ebdec258a33f598986533894f3324b03d0b4b385b94e72a0517a3437553b39
|
DIST Pillow-3.4.2.zip 11042238 BLAKE2B 334af6eeadb3203b51572eca6ad9c196f3eeac14da0f1aedc351db692b33d413fdf5bc5c8564d2f53c324d9485dbdbda664b75a570b779e24f238c21829b4a39 SHA512 5e05206db5bc1b4177384f7e91ee79015c6e1bbdc7c31c997da054391b9b5ec7c1ebdec258a33f598986533894f3324b03d0b4b385b94e72a0517a3437553b39
|
||||||
DIST Pillow-5.2.0.tar.gz 14499068 BLAKE2B 7111eb8e2911cc197b66bbc06a13459484e2c4a1f5037e4bcf702ea350763b2b758cbeef9749aeb29f1ab64d33081131f7e46a3fbb33fee48e70660f8f75eddb SHA512 2f19512d0573bd4696a5b4d54ff21473492f92705d33bd0994ccd085028d209bfb0031e2b95947c1e8fc9d0b0956cdf1f705c1fbaff39390791cac1708bff22c
|
DIST Pillow-5.2.0.tar.gz 14499068 BLAKE2B 7111eb8e2911cc197b66bbc06a13459484e2c4a1f5037e4bcf702ea350763b2b758cbeef9749aeb29f1ab64d33081131f7e46a3fbb33fee48e70660f8f75eddb SHA512 2f19512d0573bd4696a5b4d54ff21473492f92705d33bd0994ccd085028d209bfb0031e2b95947c1e8fc9d0b0956cdf1f705c1fbaff39390791cac1708bff22c
|
||||||
DIST Pillow-5.3.0.tar.gz 15553718 BLAKE2B df93d136fb5a5ea3021a757edea5dfa7b3fc1f7a71b0f64f1d1d11b95a5dafffad98d3f7b28d5e7c07b1c93d154c9c73a688f37771587c91fb7bfb6956079375 SHA512 0596207069a87a645f7694b19ea5100d753dbb7553148fa5982b073e4e1163b5bd83ddf8b1c783a90a0b718576f08d3f15352f2742d46a425cf639de2409c4ab
|
DIST Pillow-5.3.0.tar.gz 15553718 BLAKE2B df93d136fb5a5ea3021a757edea5dfa7b3fc1f7a71b0f64f1d1d11b95a5dafffad98d3f7b28d5e7c07b1c93d154c9c73a688f37771587c91fb7bfb6956079375 SHA512 0596207069a87a645f7694b19ea5100d753dbb7553148fa5982b073e4e1163b5bd83ddf8b1c783a90a0b718576f08d3f15352f2742d46a425cf639de2409c4ab
|
||||||
|
DIST pillow-5.4.1.tar.gz 15799745 BLAKE2B d9e3851a80a1f94d7292852b9ab806d9a26870795f499bb109a440e64c07112055a4cd382688b977f3c3ae76ed3d6fd38460afff594f964338afa668d288e4de SHA512 20b75ab50df7e9545c76d66ad585922d1f86fbcf8df9d2566882ab8929c3122573b9ec622766523ec46f5e7a98740cc78ff192e3e8f08ab0b77a7f2b033a7f62
|
||||||
|
28
dev-python/pillow/files/pillow-5.4.1-pkg-config.patch
Normal file
28
dev-python/pillow/files/pillow-5.4.1-pkg-config.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
diff -Naur a/setup.py b/setup.py
|
||||||
|
--- a/setup.py 2019-01-06 12:12:16.000000000 +0000
|
||||||
|
+++ b/setup.py 2019-01-08 23:04:45.574698210 +0000
|
||||||
|
@@ -197,12 +197,13 @@
|
||||||
|
|
||||||
|
def _pkg_config(name):
|
||||||
|
try:
|
||||||
|
+ command = os.environ.get('PKG_CONFIG', 'pkg-config')
|
||||||
|
command_libs = [
|
||||||
|
- 'pkg-config',
|
||||||
|
+ command,
|
||||||
|
'--libs-only-L', name,
|
||||||
|
]
|
||||||
|
command_cflags = [
|
||||||
|
- 'pkg-config',
|
||||||
|
+ command,
|
||||||
|
'--cflags-only-I', name,
|
||||||
|
]
|
||||||
|
if not DEBUG:
|
||||||
|
@@ -298,7 +299,7 @@
|
||||||
|
_add_directory(include_dirs, "src/libImaging")
|
||||||
|
|
||||||
|
pkg_config = None
|
||||||
|
- if _cmd_exists('pkg-config'):
|
||||||
|
+ if _cmd_exists(os.environ.get('PKG_CONFIG', 'pkg-config')):
|
||||||
|
pkg_config = _pkg_config
|
||||||
|
|
||||||
|
#
|
12
dev-python/pillow/files/pillow-5.4.1-toolchain-paths.patch
Normal file
12
dev-python/pillow/files/pillow-5.4.1-toolchain-paths.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -Naur a/setup.py b/setup.py
|
||||||
|
--- a/setup.py 2019-01-08 23:06:33.082873069 +0000
|
||||||
|
+++ b/setup.py 2019-01-08 23:06:47.707165225 +0000
|
||||||
|
@@ -356,7 +356,7 @@
|
||||||
|
for d in os.environ[k].split(os.path.pathsep):
|
||||||
|
_add_directory(library_dirs, d)
|
||||||
|
|
||||||
|
- prefix = sysconfig.get_config_var("prefix")
|
||||||
|
+ prefix = None
|
||||||
|
if prefix:
|
||||||
|
_add_directory(library_dirs, os.path.join(prefix, "lib"))
|
||||||
|
_add_directory(include_dirs, os.path.join(prefix, "include"))
|
@ -1,4 +1,4 @@
|
|||||||
# Copyright 1999-2018 Gentoo Authors
|
# Copyright 1999-2019 Gentoo Authors
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
EAPI=7
|
EAPI=7
|
||||||
@ -39,7 +39,7 @@ DEPEND="${RDEPEND}
|
|||||||
dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
|
dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
|
||||||
)
|
)
|
||||||
test? (
|
test? (
|
||||||
dev-python/pytest[${PYTHON_USEDEP}]
|
<dev-python/pytest-3.10[${PYTHON_USEDEP}]
|
||||||
media-gfx/imagemagick[png]
|
media-gfx/imagemagick[png]
|
||||||
)
|
)
|
||||||
"
|
"
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
# Copyright 1999-2018 Gentoo Authors
|
# Copyright 1999-2019 Gentoo Authors
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
EAPI=7
|
EAPI=7
|
||||||
@ -17,7 +17,7 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
|
|||||||
|
|
||||||
LICENSE="HPND"
|
LICENSE="HPND"
|
||||||
SLOT="0"
|
SLOT="0"
|
||||||
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
|
KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
|
||||||
IUSE="doc examples imagequant jpeg jpeg2k lcms test tiff tk truetype webp zlib"
|
IUSE="doc examples imagequant jpeg jpeg2k lcms test tiff tk truetype webp zlib"
|
||||||
|
|
||||||
REQUIRED_USE="test? ( jpeg tiff )"
|
REQUIRED_USE="test? ( jpeg tiff )"
|
||||||
@ -75,7 +75,7 @@ python_compile_all() {
|
|||||||
python_test() {
|
python_test() {
|
||||||
"${PYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
|
"${PYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
|
||||||
# no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
|
# no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
|
||||||
virtx pytest -vx Tests/test_*.py -p no:relaxed
|
virtx pytest -vv -p no:relaxed
|
||||||
}
|
}
|
||||||
|
|
||||||
python_install() {
|
python_install() {
|
||||||
|
105
dev-python/pillow/pillow-5.4.1.ebuild
Normal file
105
dev-python/pillow/pillow-5.4.1.ebuild
Normal file
@ -0,0 +1,105 @@
|
|||||||
|
# Copyright 1999-2019 Gentoo Authors
|
||||||
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
|
EAPI=7
|
||||||
|
|
||||||
|
PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
|
||||||
|
PYTHON_REQ_USE='tk?,threads(+)'
|
||||||
|
|
||||||
|
inherit distutils-r1 toolchain-funcs virtualx
|
||||||
|
|
||||||
|
MY_PN=Pillow
|
||||||
|
MY_P=${MY_PN}-${PV}
|
||||||
|
|
||||||
|
DESCRIPTION="Python Imaging Library (fork)"
|
||||||
|
HOMEPAGE="https://python-pillow.org/"
|
||||||
|
SRC_URI="https://github.com/python-pillow/Pillow/archive/${PV}.tar.gz -> ${P}.tar.gz"
|
||||||
|
|
||||||
|
LICENSE="HPND"
|
||||||
|
SLOT="0"
|
||||||
|
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
|
||||||
|
IUSE="doc examples imagequant jpeg jpeg2k lcms test tiff tk truetype webp zlib"
|
||||||
|
|
||||||
|
REQUIRED_USE="test? ( jpeg tiff )"
|
||||||
|
|
||||||
|
RDEPEND="
|
||||||
|
dev-python/olefile[${PYTHON_USEDEP}]
|
||||||
|
imagequant? ( media-gfx/libimagequant:0 )
|
||||||
|
jpeg? ( virtual/jpeg:0 )
|
||||||
|
jpeg2k? ( media-libs/openjpeg:2= )
|
||||||
|
lcms? ( media-libs/lcms:2= )
|
||||||
|
tiff? ( media-libs/tiff:0=[jpeg,zlib] )
|
||||||
|
truetype? ( media-libs/freetype:2= )
|
||||||
|
webp? ( media-libs/libwebp:0= )
|
||||||
|
zlib? ( sys-libs/zlib:0= )"
|
||||||
|
DEPEND="${RDEPEND}
|
||||||
|
dev-python/setuptools[${PYTHON_USEDEP}]
|
||||||
|
doc? (
|
||||||
|
dev-python/sphinx[${PYTHON_USEDEP}]
|
||||||
|
dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
|
||||||
|
)
|
||||||
|
test? (
|
||||||
|
dev-python/pytest[${PYTHON_USEDEP}]
|
||||||
|
media-gfx/imagemagick[png]
|
||||||
|
)
|
||||||
|
"
|
||||||
|
|
||||||
|
S="${WORKDIR}/${MY_P}"
|
||||||
|
|
||||||
|
PATCHES=(
|
||||||
|
"${FILESDIR}"/${PN}-5.4.1-{pkg-config,toolchain-paths}.patch
|
||||||
|
)
|
||||||
|
|
||||||
|
python_configure_all() {
|
||||||
|
# It's important that these flags are also passed during the install phase
|
||||||
|
# as well. Make sure of that if you change the lines below. See bug 661308.
|
||||||
|
mydistutilsargs=(
|
||||||
|
build_ext
|
||||||
|
--disable-platform-guessing
|
||||||
|
$(use_enable truetype freetype)
|
||||||
|
$(use_enable jpeg)
|
||||||
|
$(use_enable jpeg2k jpeg2000)
|
||||||
|
$(use_enable lcms)
|
||||||
|
$(use_enable tiff)
|
||||||
|
$(use_enable imagequant)
|
||||||
|
$(use_enable webp)
|
||||||
|
$(use_enable webp webpmux)
|
||||||
|
$(use_enable zlib)
|
||||||
|
)
|
||||||
|
|
||||||
|
# setup.py sucks at adding the right toolchain paths but it does
|
||||||
|
# accept additional ones from INCLUDE and LIB so set these. You
|
||||||
|
# wouldn't normally need these at all as the toolchain should look
|
||||||
|
# here anyway but this setup.py does stupid things.
|
||||||
|
export \
|
||||||
|
INCLUDE=${ESYSROOT}/usr/include \
|
||||||
|
LIB=${ESYSROOT}/usr/$(get_libdir)
|
||||||
|
|
||||||
|
# We have patched in this env var.
|
||||||
|
tc-export PKG_CONFIG
|
||||||
|
}
|
||||||
|
|
||||||
|
python_compile_all() {
|
||||||
|
use doc && emake -C docs html
|
||||||
|
}
|
||||||
|
|
||||||
|
python_test() {
|
||||||
|
"${PYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
|
||||||
|
# no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
|
||||||
|
virtx pytest -vv -p no:relaxed
|
||||||
|
}
|
||||||
|
|
||||||
|
python_install() {
|
||||||
|
python_doheader src/libImaging/*.h
|
||||||
|
distutils-r1_python_install
|
||||||
|
}
|
||||||
|
|
||||||
|
python_install_all() {
|
||||||
|
use doc && local HTML_DOCS=( docs/_build/html/. )
|
||||||
|
if use examples ; then
|
||||||
|
docinto example
|
||||||
|
dodoc docs/example/*
|
||||||
|
docompress -x /usr/share/doc/${PF}/example
|
||||||
|
fi
|
||||||
|
distutils-r1_python_install_all
|
||||||
|
}
|
Loading…
x
Reference in New Issue
Block a user