Migrated to Gentoo Science
https://gitweb.gentoo.org/proj/sci.git/commit/?id=cc082a637bcbb6c289216b62cfaacb24212557b5
This commit is contained in:
parent
cb4fe5883f
commit
849f66a476
@ -1,7 +0,0 @@
|
|||||||
*fsleyes-widgets-0.8.4 (16 Jan 2020)
|
|
||||||
|
|
||||||
16 Jan 2020; <chymera@gentoo.org>
|
|
||||||
+files/fsleyes-widgets-0.8.4-coverage.patch,
|
|
||||||
+files/fsleyes-widgets-0.8.4-tests.patch, +fsleyes-widgets-0.8.4.ebuild,
|
|
||||||
+metadata.xml, -fsleyes-widgets-0.6.5.ebuild, -manifest.xml:
|
|
||||||
sci-visualization/fsleyes-widgets: version bump 0.8.4 ahead of Gentoo Science
|
|
@ -1 +0,0 @@
|
|||||||
DIST fsleyes-widgets-0.8.4.tar.gz 1063873 SHA256 c9de830fe097c9f5a38b31c5acadfeffd26b52f00ed68d9c4906a0010875f444 SHA512 b3b3a5f1a963022f82456c2d6978e02e6f0eb459a76d3aa9f924dbb484ad8359fe9344e9d914c859bd213406707b1b3456de8543b1400728b84fb503ae1fddc8 WHIRLPOOL a306e0209888c4b0b85cf3b77b34889fb205a29a838a8fc26f51011e69e5aaff8e802fa95182fbcd3bf5e00dfd376bb6743f613373dd1ae24ec4d8bf6ca50e62
|
|
@ -1,10 +0,0 @@
|
|||||||
diff --git a/setup.cfg b/setup.cfg
|
|
||||||
index c3ebd936..d678d2df 100644
|
|
||||||
--- a/setup.cfg
|
|
||||||
+++ b/setup.cfg
|
|
||||||
@@ -9,4 +9,4 @@ ignore = E127,E201,E203,E221,E222,E241,E271,E272,E301,E302,E303,E701
|
|
||||||
|
|
||||||
[tool:pytest]
|
|
||||||
testpaths = tests
|
|
||||||
-addopts = -v --cov=fsleyes_widgets
|
|
||||||
+addopts = -v
|
|
@ -1,69 +0,0 @@
|
|||||||
diff --git a/tests/test_floatslider.py b/tests/test_floatslider.py
|
|
||||||
index 87a2477..6bbedb7 100644
|
|
||||||
--- a/tests/test_floatslider.py
|
|
||||||
+++ b/tests/test_floatslider.py
|
|
||||||
@@ -140,8 +140,14 @@ def _test_FloatSlider_changeRange():
|
|
||||||
_test_widget_changeRange(slider)
|
|
||||||
|
|
||||||
|
|
||||||
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
|
||||||
+ "https://github.com/pauldmccarthy/fsleyes-widgets/issues/1"
|
|
||||||
+ )
|
|
||||||
def test_FloatSlider_mouse_non_gtk():
|
|
||||||
run_with_wx(_test_FloatSlider_mouse)
|
|
||||||
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
|
||||||
+ "https://github.com/pauldmccarthy/fsleyes-widgets/issues/1"
|
|
||||||
+ )
|
|
||||||
def test_FloatSlider_mouse_gtk():
|
|
||||||
with mock.patch('fsleyes_widgets.floatslider.wx.Platform', '__WXGTK__'):
|
|
||||||
run_with_wx(_test_FloatSlider_mouse)
|
|
||||||
@@ -322,7 +328,9 @@ def _test_SliderSpinPanel_show_edit_limits():
|
|
||||||
if shouldEv: assert result[0] == expected
|
|
||||||
else: assert result[0] is None
|
|
||||||
|
|
||||||
-
|
|
||||||
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
|
||||||
+ "https://github.com/pauldmccarthy/fsleyes-widgets/issues/1"
|
|
||||||
+ )
|
|
||||||
def test_SliderSpinPanel_events():
|
|
||||||
run_with_wx(_test_SliderSpinPanel_events)
|
|
||||||
def _test_SliderSpinPanel_events():
|
|
||||||
diff --git a/tests/test_notebook.py b/tests/test_notebook.py
|
|
||||||
index a02226c..74e8f63 100644
|
|
||||||
--- a/tests/test_notebook.py
|
|
||||||
+++ b/tests/test_notebook.py
|
|
||||||
@@ -190,6 +190,9 @@ def _test_enable_disable_show_hide(side, ornt):
|
|
||||||
assert notebook.GetSelection() == 1
|
|
||||||
|
|
||||||
|
|
||||||
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
|
||||||
+ "https://github.com/pauldmccarthy/fsleyes-widgets/issues/1"
|
|
||||||
+ )
|
|
||||||
def test_event():
|
|
||||||
nb_run_with_wx(_test_event)
|
|
||||||
def _test_event(side, ornt):
|
|
||||||
diff --git a/tests/test_rangeslider.py b/tests/test_rangeslider.py
|
|
||||||
index 7ddbed6..51267b3 100644
|
|
||||||
--- a/tests/test_rangeslider.py
|
|
||||||
+++ b/tests/test_rangeslider.py
|
|
||||||
@@ -103,6 +103,9 @@ def _test_RangePanel_logic_spin():
|
|
||||||
_test_RangePanel_logic(panel)
|
|
||||||
|
|
||||||
|
|
||||||
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
|
||||||
+ "https://github.com/pauldmccarthy/fsleyes-widgets/issues/1"
|
|
||||||
+ )
|
|
||||||
def test_RangePanel_events_slider():
|
|
||||||
run_with_wx(_test_RangePanel_events_slider)
|
|
||||||
def _test_RangePanel_events_slider():
|
|
||||||
@@ -236,6 +239,9 @@ def _test_RangeSliderSpinPanel_logic():
|
|
||||||
_test_RangePanel_logic(panel)
|
|
||||||
|
|
||||||
|
|
||||||
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
|
||||||
+ "https://github.com/pauldmccarthy/fsleyes-widgets/issues/1"
|
|
||||||
+ )
|
|
||||||
def test_RangeSliderSpinPanel_onchange():
|
|
||||||
run_with_wx(_test_RangeSliderSpinPanel_onchange)
|
|
||||||
def _test_RangeSliderSpinPanel_onchange():
|
|
||||||
|
|
@ -1,44 +0,0 @@
|
|||||||
# Copyright 1999-2020 Gentoo Authors
|
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
|
||||||
|
|
||||||
EAPI=7
|
|
||||||
|
|
||||||
PYTHON_COMPAT=( python3_{6,7} )
|
|
||||||
|
|
||||||
inherit distutils-r1 virtualx
|
|
||||||
|
|
||||||
MY_P="widgets-${PV}"
|
|
||||||
|
|
||||||
DESCRIPTION="The new FSL image viewer, first released with FSL 5.0.10"
|
|
||||||
HOMEPAGE="https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/tree/master"
|
|
||||||
SRC_URI="https://git.fmrib.ox.ac.uk/fsl/fsleyes/widgets/-/archive/${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
|
|
||||||
|
|
||||||
LICENSE="BSD"
|
|
||||||
SLOT="0"
|
|
||||||
KEYWORDS="~amd64 ~x86"
|
|
||||||
IUSE="test"
|
|
||||||
|
|
||||||
DEPEND="
|
|
||||||
test? (
|
|
||||||
dev-python/pytest[${PYTHON_USEDEP}]
|
|
||||||
)
|
|
||||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
|
||||||
"
|
|
||||||
RDEPEND="
|
|
||||||
dev-python/deprecation[${PYTHON_USEDEP}]
|
|
||||||
=dev-python/numpy-1*[${PYTHON_USEDEP}]
|
|
||||||
dev-python/matplotlib[${PYTHON_USEDEP}]
|
|
||||||
=dev-python/six-1*[${PYTHON_USEDEP}]
|
|
||||||
dev-python/wxpython[${PYTHON_USEDEP}]
|
|
||||||
"
|
|
||||||
|
|
||||||
S="${WORKDIR}/${MY_P}"
|
|
||||||
|
|
||||||
PATCHES=(
|
|
||||||
"${FILESDIR}/fsleyes-widgets-0.8.4-coverage.patch"
|
|
||||||
"${FILESDIR}/fsleyes-widgets-0.8.4-tests.patch"
|
|
||||||
)
|
|
||||||
|
|
||||||
python_test() {
|
|
||||||
virtx pytest --verbose || die
|
|
||||||
}
|
|
@ -1,18 +0,0 @@
|
|||||||
<?xml version='1.0' encoding='UTF-8'?>
|
|
||||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
|
||||||
<pkgmetadata>
|
|
||||||
<maintainer type="person">
|
|
||||||
<email>horea.christ@gmail.com</email>
|
|
||||||
<name>Horea Christian</name>
|
|
||||||
</maintainer>
|
|
||||||
<maintainer type="project">
|
|
||||||
<email>sci@gentoo.org</email>
|
|
||||||
<name>Gentoo Science Project</name>
|
|
||||||
</maintainer>
|
|
||||||
<longdescription lang="en">
|
|
||||||
FSLeyes is a viewer for 3D and 4D neuroimaging data. It is intended as a
|
|
||||||
replacement for the much loved FSLView. FSLeyes offers similar functionality
|
|
||||||
to FSLView, and aims to improve and expand upon this functionality in many
|
|
||||||
ways.
|
|
||||||
</longdescription>
|
|
||||||
</pkgmetadata>
|
|
Loading…
x
Reference in New Issue
Block a user