dev-python/fscacher: new package (DANDI stack)
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Horea Christian <chr@chymera.eu>
This commit is contained in:
parent
2b976fa6e5
commit
7f4db9a882
5
dev-python/fscacher/ChangeLog
Normal file
5
dev-python/fscacher/ChangeLog
Normal file
@ -0,0 +1,5 @@
|
|||||||
|
*fscacher-0.1.4 (27 Sep 2021)
|
||||||
|
|
||||||
|
27 Sep 2021; <chymera@gentoo.org> +files/fscacher-0.1.4-coverage.patch,
|
||||||
|
+fscacher-0.1.4.ebuild, +metadata.xml:
|
||||||
|
dev-python/fscacher: new package (DANDI stack)
|
1
dev-python/fscacher/Manifest
Normal file
1
dev-python/fscacher/Manifest
Normal file
@ -0,0 +1 @@
|
|||||||
|
DIST fscacher-0.1.4.tar.gz 35097 SHA256 d3ecd4cdc9cad2ee84a3f37f74b6ef3f87279cd28d2ccf8025893fc581269aca SHA512 e3e85cee4c446552215b6d7092bdc72c31709e05dee7efb52fc6fc985992a3ece338c5a0dee54ed7e6aec797d4b7e2bd77b00f634112134c61f402b604103b5c WHIRLPOOL 177afbe8e616c081e71aff1bdd2ed7081fcc4d648ff4f8549832d513392ea53b61f172753d6ea401d74186f01928ad4710f7c30ca974e6f4024f37818cf23eaa
|
9
dev-python/fscacher/files/fscacher-0.1.4-coverage.patch
Normal file
9
dev-python/fscacher/files/fscacher-0.1.4-coverage.patch
Normal file
@ -0,0 +1,9 @@
|
|||||||
|
--- a/tox.ini 2021-09-27 01:00:33.935464308 -0400
|
||||||
|
+++ b/tox.ini 2021-09-27 02:48:34.349729243 -0400
|
||||||
|
@@ -27,7 +27,6 @@
|
||||||
|
asv run {posargs}
|
||||||
|
|
||||||
|
[pytest]
|
||||||
|
-addopts = --cov=fscacher --no-cov-on-fail
|
||||||
|
filterwarnings = error
|
||||||
|
norecursedirs = test/data
|
31
dev-python/fscacher/fscacher-0.1.4.ebuild
Normal file
31
dev-python/fscacher/fscacher-0.1.4.ebuild
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
# Copyright 1999-2021 Gentoo Authors
|
||||||
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
|
EAPI=8
|
||||||
|
|
||||||
|
PYTHON_COMPAT=( python3_{8..10} )
|
||||||
|
inherit distutils-r1
|
||||||
|
|
||||||
|
DESCRIPTION="Cache results of operations on heavy file trees"
|
||||||
|
HOMEPAGE="https://github.com/con/fscacher"
|
||||||
|
SRC_URI="https://github.com/con/fscacher/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
|
||||||
|
|
||||||
|
SLOT="0"
|
||||||
|
LICENSE="MIT"
|
||||||
|
KEYWORDS="~amd64 ~x86"
|
||||||
|
|
||||||
|
RDEPEND="
|
||||||
|
dev-python/appdirs[${PYTHON_USEDEP}]
|
||||||
|
dev-python/joblib[${PYTHON_USEDEP}]
|
||||||
|
"
|
||||||
|
DEPEND="
|
||||||
|
test? (
|
||||||
|
dev-python/pytest-mock[${PYTHON_USEDEP}]
|
||||||
|
)
|
||||||
|
"
|
||||||
|
|
||||||
|
PATCHES=(
|
||||||
|
"${FILESDIR}/${PN}-0.1.4-coverage.patch"
|
||||||
|
)
|
||||||
|
|
||||||
|
distutils_enable_tests pytest
|
19
dev-python/fscacher/metadata.xml
Normal file
19
dev-python/fscacher/metadata.xml
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
<?xml version='1.0' encoding='UTF-8'?>
|
||||||
|
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||||
|
<pkgmetadata>
|
||||||
|
<maintainer type="person">
|
||||||
|
<email>gentoo@chymera.eu</email>
|
||||||
|
<name>Horea Christian</name>
|
||||||
|
</maintainer>
|
||||||
|
<maintainer type="project">
|
||||||
|
<email>sci@gentoo.org</email>
|
||||||
|
<name>Gentoo Science Project</name>
|
||||||
|
</maintainer>
|
||||||
|
<longdescription lang="en">
|
||||||
|
fscacher provides a cache and decorator for memoizing functions whose
|
||||||
|
outputs depend upon the contents of a file argument. If you have a
|
||||||
|
function `foo()` that takes a file path as its first argument, and if
|
||||||
|
the behavior of `foo()` is pure in the contents of the path and the
|
||||||
|
values of its other arguments, fscacher can help cache that function,
|
||||||
|
</longdescription>
|
||||||
|
</pkgmetadata>
|
Loading…
x
Reference in New Issue
Block a user