ebuild to fix guile compatibility https://bugs.gentoo.org/show_bug.cgi?id=590536#c10
This commit is contained in:
parent
873924a75b
commit
6f68f417d9
1
app-office/gnucash/Manifest
Normal file
1
app-office/gnucash/Manifest
Normal file
@ -0,0 +1 @@
|
||||
DIST gnucash-2.6.13.tar.bz2 13564015 SHA256 0fe3c12c849cddee502da07edc8e3db286d32333f4e7cb327bed735f480ee735 SHA512 daad6d55485de6ce3ca6affe232c51252d853c803734f4737ab2477e7724c42fa2ea764f5fdeea00d956bcbaad338a30fe21c62a578a818d5e8b4f5878f060b5 WHIRLPOOL 6f1ed3e9eaf9e80e8131fc48ff5480790a15093f1d2ab9b2c074644feb3c4d5db60315ba9e480f9697c21f0be7908f922ceff51a284632d65eb4fa7bda551e3b
|
187
app-office/gnucash/files/guile2.patch
Normal file
187
app-office/gnucash/files/guile2.patch
Normal file
@ -0,0 +1,187 @@
|
||||
--- a/src/report/report-system/Makefile.am 2016-05-29
|
||||
18:25:33.000000000 +0200
|
||||
+++ b/src/report/report-system/Makefile.am 2016-08-08
|
||||
16:33:28.500840868 +0200
|
||||
@@ -119,6 +119,7 @@
|
||||
--guile-load-dir ${top_builddir}/src/gnc-module \
|
||||
--guile-load-dir ${top_builddir}/src/gnome-utils \
|
||||
--guile-load-dir ${top_builddir}/src/scm \
|
||||
+ --guile-load-dir ${top_builddir}/src/report/report-system \
|
||||
--library-dir ${top_builddir}/src/libqof/qof \
|
||||
--library-dir ${top_builddir}/src/engine \
|
||||
--library-dir ${top_builddir}/src/app-utils \
|
||||
--- a/src/report/standard-reports/Makefile.am 2016-05-29
|
||||
18:25:33.000000000 +0200
|
||||
+++ b/src/report/standard-reports/Makefile.am 2016-08-08
|
||||
16:41:14.693405600 +0200
|
||||
@@ -81,12 +81,14 @@
|
||||
--gnc-module-dir ${top_builddir}/src/gnome-utils \
|
||||
--gnc-module-dir ${top_builddir}/src/html \
|
||||
--gnc-module-dir ${top_builddir}/src/report/report-system \
|
||||
+ --gnc-module-dir ${top_builddir}/src/report/standard-reports \
|
||||
--guile-load-dir ${top_builddir}/src/app-utils \
|
||||
--guile-load-dir ${top_builddir}/src/core-utils \
|
||||
--guile-load-dir ${top_builddir}/src/engine \
|
||||
--guile-load-dir ${top_builddir}/src/gnc-module \
|
||||
--guile-load-dir ${top_builddir}/src/gnome-utils \
|
||||
--guile-load-dir ${top_builddir}/src/report/report-system \
|
||||
+ --guile-load-dir ${top_builddir}/src/report/standard-reports \
|
||||
--guile-load-dir ${top_builddir}/src/scm \
|
||||
--library-dir ${top_builddir}/src/libqof/qof \
|
||||
--library-dir ${top_builddir}/src/engine \
|
||||
@@ -97,7 +99,8 @@
|
||||
--library-dir ${top_builddir}/src/backend/xml \
|
||||
--library-dir ${top_builddir}/src/backend/sql \
|
||||
--library-dir ${top_builddir}/src/html \
|
||||
- --library-dir ${top_builddir}/src/report/report-system
|
||||
+ --library-dir ${top_builddir}/src/report/report-system \
|
||||
+ --library-dir ${top_builddir}/src/report/standard-reports
|
||||
|
||||
%.go : %.scm .scm-links $(pkglib_LTLIBRARIES)
|
||||
GNC_UNINSTALLED=yes \
|
||||
--- a/src/report/business-reports/Makefile.am 2016-05-29
|
||||
18:25:33.000000000 +0200
|
||||
+++ b/src/report/business-reports/Makefile.am 2016-08-08
|
||||
18:45:04.778463532 +0200
|
||||
@@ -51,6 +51,7 @@
|
||||
--gnc-module-dir ${top_builddir}/src/html \
|
||||
--gnc-module-dir ${top_builddir}/src/report/report-system \
|
||||
--gnc-module-dir ${top_builddir}/src/report/standard-reports \
|
||||
+ --gnc-module-dir ${top_builddir}/src/report/business-reports \
|
||||
--guile-load-dir ${top_builddir}/src/app-utils \
|
||||
--guile-load-dir ${top_builddir}/src/core-utils \
|
||||
--guile-load-dir ${top_builddir}/src/engine \
|
||||
@@ -58,6 +59,7 @@
|
||||
--guile-load-dir ${top_builddir}/src/gnome-utils \
|
||||
--guile-load-dir ${top_builddir}/src/report/report-system \
|
||||
--guile-load-dir ${top_builddir}/src/report/standard-reports \
|
||||
+ --guile-load-dir ${top_builddir}/src/report/business-reports \
|
||||
--guile-load-dir ${top_builddir}/src/scm \
|
||||
--library-dir ${top_builddir}/src/engine \
|
||||
--library-dir ${top_builddir}/src/libqof/qof \
|
||||
@@ -68,7 +70,8 @@
|
||||
--library-dir ${top_builddir}/src/backend/sql \
|
||||
--library-dir ${top_builddir}/src/html \
|
||||
--library-dir ${top_builddir}/src/gnc-module \
|
||||
- --library-dir ${top_builddir}/src/report/report-system
|
||||
+ --library-dir ${top_builddir}/src/report/report-system \
|
||||
+ --library-dir ${top_builddir}/src/report/business-reports
|
||||
|
||||
|
||||
%.go : %.scm .scm-links $(pkglib_LTLIBRARIES)
|
||||
--- a/src/report/utility-reports/Makefile.am 2016-05-29
|
||||
18:25:33.000000000 +0200
|
||||
+++ b/src/report/utility-reports/Makefile.am 2016-08-08
|
||||
18:42:29.714930181 +0200
|
||||
@@ -53,12 +53,14 @@
|
||||
--gnc-module-dir ${top_builddir}/src/gnome-utils \
|
||||
--gnc-module-dir ${top_builddir}/src/html \
|
||||
--gnc-module-dir ${top_builddir}/src/report/report-system \
|
||||
+ --gnc-module-dir ${top_builddir}/src/report/utility-reports \
|
||||
--guile-load-dir ${top_builddir}/src/app-utils \
|
||||
--guile-load-dir ${top_builddir}/src/core-utils \
|
||||
--guile-load-dir ${top_builddir}/src/engine \
|
||||
--guile-load-dir ${top_builddir}/src/gnc-module \
|
||||
--guile-load-dir ${top_builddir}/src/gnome-utils \
|
||||
--guile-load-dir ${top_builddir}/src/report/report-system \
|
||||
+ --guile-load-dir ${top_builddir}/src/report/utility-reports \
|
||||
--guile-load-dir ${top_builddir}/src/scm \
|
||||
--library-dir ${top_builddir}/src/engine \
|
||||
--library-dir ${top_builddir}/src/libqof/qof \
|
||||
@@ -69,7 +71,8 @@
|
||||
--library-dir ${top_builddir}/src/backend/xml \
|
||||
--library-dir ${top_builddir}/src/backend/sql \
|
||||
--library-dir ${top_builddir}/src/html \
|
||||
- --library-dir ${top_builddir}/src/report/report-system
|
||||
+ --library-dir ${top_builddir}/src/report/report-system \
|
||||
+ --library-dir ${top_builddir}/src/report/utility-reports
|
||||
|
||||
%.go : %.scm .scm-links $(pkglib_LTLIBRARIES)
|
||||
GNC_UNINSTALLED=yes \
|
||||
--- a/src/report/locale-specific/us/Makefile.am 2016-05-29
|
||||
18:25:33.000000000 +0200
|
||||
+++ b/src/report/locale-specific/us/Makefile.am 2016-08-08
|
||||
18:54:37.061288131 +0200
|
||||
@@ -58,6 +58,7 @@
|
||||
--gnc-module-dir ${top_builddir}/src/gnome-utils \
|
||||
--gnc-module-dir ${top_builddir}/src/html \
|
||||
--gnc-module-dir ${top_builddir}/src/report/report-system \
|
||||
+ --gnc-module-dir ${top_builddir}/src/report/locale-specific/us \
|
||||
--gnc-module-dir ${top_builddir}/src/tax/us \
|
||||
--guile-load-dir ${top_builddir}/src/app-utils \
|
||||
--guile-load-dir ${top_builddir}/src/core-utils \
|
||||
@@ -65,6 +66,7 @@
|
||||
--guile-load-dir ${top_builddir}/src/gnc-module \
|
||||
--guile-load-dir ${top_builddir}/src/gnome-utils \
|
||||
--guile-load-dir ${top_builddir}/src/report/report-system \
|
||||
+ --guile-load-dir ${top_builddir}/src/report/locale-specific/us \
|
||||
--guile-load-dir ${top_builddir}/src/scm \
|
||||
--guile-load-dir ${top_builddir}/src/tax/us \
|
||||
--library-dir ${top_builddir}/src/engine \
|
||||
@@ -76,7 +78,8 @@
|
||||
--library-dir ${top_builddir}/src/backend/xml \
|
||||
--library-dir ${top_builddir}/src/backend/sql \
|
||||
--library-dir ${top_builddir}/src/html \
|
||||
- --library-dir ${top_builddir}/src/report/report-system
|
||||
+ --library-dir ${top_builddir}/src/report/report-system \
|
||||
+ --library-dir ${top_builddir}/src/report/locale-specific/us
|
||||
|
||||
%.go : %.scm .scm-links $(pkglib_LTLIBRARIES)
|
||||
GNC_UNINSTALLED=yes \
|
||||
--- a/src/report/stylesheets/Makefile.am 2016-05-29
|
||||
18:25:33.000000000 +0200
|
||||
+++ b/src/report/stylesheets/Makefile.am 2016-08-08
|
||||
19:18:06.940583895 +0200
|
||||
@@ -68,12 +68,14 @@
|
||||
--gnc-module-dir ${top_builddir}/src/html \
|
||||
--gnc-module-dir ${top_builddir}/src/gnome-utils \
|
||||
--gnc-module-dir ${top_builddir}/src/report/report-system \
|
||||
+ --gnc-module-dir ${top_builddir}/src/report/stylesheets \
|
||||
--guile-load-dir ${top_builddir}/src/app-utils \
|
||||
--guile-load-dir ${top_builddir}/src/core-utils \
|
||||
--guile-load-dir ${top_builddir}/src/engine \
|
||||
--guile-load-dir ${top_builddir}/src/gnc-module \
|
||||
--guile-load-dir ${top_builddir}/src/gnome-utils \
|
||||
--guile-load-dir ${top_builddir}/src/report/report-system \
|
||||
+ --guile-load-dir ${top_builddir}/src/report/stylesheets \
|
||||
--guile-load-dir ${top_builddir}/src/scm \
|
||||
--library-dir ${top_builddir}/src/libqof/qof \
|
||||
--library-dir ${top_builddir}/src/engine \
|
||||
@@ -84,7 +86,8 @@
|
||||
--library-dir ${top_builddir}/src/backend/xml \
|
||||
--library-dir ${top_builddir}/src/backend/sql \
|
||||
--library-dir ${top_builddir}/src/html \
|
||||
- --library-dir ${top_builddir}/src/report/report-system
|
||||
+ --library-dir ${top_builddir}/src/report/report-system \
|
||||
+ --library-dir ${top_builddir}/src/report/stylesheets
|
||||
|
||||
%.go : %.scm .scm-links $(pkglib_LTLIBRARIES)
|
||||
GNC_UNINSTALLED=yes \
|
||||
--- a/src/engine/test/Makefile.am 2016-05-29 18:25:33.000000000
|
||||
+0200
|
||||
+++ b/src/engine/test/Makefile.am 2016-08-08 19:42:14.220035162
|
||||
+0200
|
||||
@@ -64,18 +64,21 @@
|
||||
--gnc-module-dir ${top_builddir}/src/engine \
|
||||
--gnc-module-dir ${top_builddir}/src/engine/test \
|
||||
--gnc-module-dir ${top_builddir}/src/app-utils \
|
||||
+ --gnc-module-dir ${top_builddir}/src/engine/test \
|
||||
--guile-load-dir ${top_builddir}/src/gnc-module \
|
||||
--guile-load-dir ${top_builddir}/src/engine \
|
||||
--guile-load-dir ${top_builddir}/src/app-utils \
|
||||
--guile-load-dir ${top_builddir}/src/core-utils \
|
||||
--guile-load-dir ${top_builddir}/src/scm \
|
||||
+ --guile-load-dir ${top_builddir}/src/engine/test \
|
||||
--library-dir ${top_builddir}/src/libqof/qof \
|
||||
--library-dir ${top_builddir}/src/core-utils \
|
||||
--library-dir ${top_builddir}/src/gnc-module \
|
||||
--library-dir ${top_builddir}/src/engine \
|
||||
--library-dir ${top_builddir}/src/app-utils \
|
||||
--library-dir ${top_builddir}/src/backend/xml \
|
||||
- --library-dir ${top_builddir}/src/backend/sql
|
||||
+ --library-dir ${top_builddir}/src/backend/sql \
|
||||
+ --library-dir ${top_builddir}/src/engine/test
|
||||
|
||||
$(SCM_TESTS): %: $(srcdir)/%.scm Makefile .scm-links
|
||||
echo '${GUILE} --debug -l $(srcdir)/$*.scm -c "(exit
|
||||
(run-test))"' > $@
|
108
app-office/gnucash/gnucash-2.6.13-r1.ebuild
Normal file
108
app-office/gnucash/gnucash-2.6.13-r1.ebuild
Normal file
@ -0,0 +1,108 @@
|
||||
# Copyright 1999-2016 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Id$
|
||||
|
||||
EAPI="6"
|
||||
GNOME2_LA_PUNT="yes"
|
||||
PYTHON_COMPAT=( python2_7 )
|
||||
|
||||
inherit gnome2 python-single-r1
|
||||
|
||||
DESCRIPTION="A personal finance manager"
|
||||
HOMEPAGE="http://www.gnucash.org/"
|
||||
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
|
||||
|
||||
SLOT="0"
|
||||
LICENSE="GPL-2"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="chipcard debug +doc gnome-keyring hbci mysql ofx postgres python quotes sqlite"
|
||||
|
||||
# FIXME: rdepend on dev-libs/qof when upstream fix their mess (see configure.ac)
|
||||
# libdbi version requirement for sqlite taken from bug #455134
|
||||
RDEPEND="
|
||||
>=dev-libs/glib-2.32.0:2
|
||||
>=dev-libs/popt-1.5
|
||||
>=dev-libs/libxml2-2.5.10:2
|
||||
dev-libs/libxslt
|
||||
>=dev-scheme/guile-2[deprecated,regex]
|
||||
dev-scheme/guile-www
|
||||
gnome-base/libgnomecanvas
|
||||
>=net-libs/webkit-gtk-1.2:2
|
||||
>=sys-libs/zlib-1.1.4
|
||||
>=x11-libs/gtk+-2.24:2
|
||||
>=x11-libs/goffice-0.7.0:0.8[gnome]
|
||||
x11-libs/pango
|
||||
gnome-keyring? ( >=app-crypt/libsecret-0.18 )
|
||||
ofx? ( >=dev-libs/libofx-0.9.1 )
|
||||
hbci? ( >=net-libs/aqbanking-5[gtk,ofx?]
|
||||
sys-libs/gwenhywfar[gtk]
|
||||
chipcard? ( sys-libs/libchipcard )
|
||||
)
|
||||
python? ( ${PYTHON_DEPS} )
|
||||
quotes? ( dev-perl/Date-Manip
|
||||
>=dev-perl/Finance-Quote-1.11
|
||||
dev-perl/HTML-TableExtract )
|
||||
sqlite? ( >=dev-db/libdbi-0.9.0
|
||||
>=dev-db/libdbi-drivers-0.9.0[sqlite] )
|
||||
postgres? ( dev-db/libdbi dev-db/libdbi-drivers[postgres] )
|
||||
mysql? ( dev-db/libdbi dev-db/libdbi-drivers[mysql] )
|
||||
"
|
||||
DEPEND="${RDEPEND}
|
||||
dev-util/intltool
|
||||
gnome-base/gnome-common
|
||||
sys-devel/libtool
|
||||
virtual/pkgconfig
|
||||
"
|
||||
PDEPEND="doc? ( >=app-doc/gnucash-docs-2.2.0 )"
|
||||
|
||||
pkg_setup() {
|
||||
use python && python-single-r1_pkg_setup
|
||||
}
|
||||
|
||||
src_prepare() {
|
||||
# Skip test that needs some locales to be present
|
||||
sed -i -e '/test_suite_gnc_date/d' src/libqof/qof/test/test-qof.c || die
|
||||
epatch "${FILESDIR}/guile2.patch"
|
||||
gnome2_src_prepare
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
local myconf
|
||||
|
||||
DOCS="doc/README.OFX doc/README.HBCI"
|
||||
|
||||
if use sqlite || use mysql || use postgres ; then
|
||||
myconf+=" --enable-dbi"
|
||||
else
|
||||
myconf+=" --disable-dbi"
|
||||
fi
|
||||
|
||||
# gtkmm is experimental and shouldn't be enabled, upstream bug #684166
|
||||
gnome2_src_configure \
|
||||
$(use_enable debug) \
|
||||
$(use_enable gnome-keyring password-storage) \
|
||||
$(use_enable ofx) \
|
||||
$(use_enable hbci aqbanking) \
|
||||
$(use_enable python) \
|
||||
--with-guile=2.0 \
|
||||
--disable-doxygen \
|
||||
--disable-gtkmm \
|
||||
--enable-locale-specific-tax \
|
||||
--disable-error-on-warning \
|
||||
${myconf}
|
||||
}
|
||||
|
||||
src_test() {
|
||||
GUILE_WARN_DEPRECATED=no \
|
||||
GNC_DOT_DIR="${T}"/.gnucash \
|
||||
emake check
|
||||
}
|
||||
|
||||
src_install() {
|
||||
# Parallel installation fails from time to time, bug #359123
|
||||
MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_install GNC_DOC_INSTALL_DIR=/usr/share/doc/${PF}
|
||||
|
||||
rm -rf "${ED}"/usr/share/doc/${PF}/{examples/,COPYING,INSTALL,*win32-bin.txt,projects.html}
|
||||
mv "${ED}"/usr/share/doc/${PF} "${T}"/cantuseprepalldocs || die
|
||||
dodoc "${T}"/cantuseprepalldocs/*
|
||||
}
|
Loading…
x
Reference in New Issue
Block a user