sci-visualization/fsleyes: new package
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Horea Christian <chr@chymera.eu>
This commit is contained in:
parent
84d15a3b38
commit
6acbced85d
@ -1,2 +1,10 @@
|
|||||||
|
*fsleyes-0.32.0 (24 Jan 2020)
|
||||||
|
|
||||||
|
24 Jan 2020; <chymera@gentoo.org> +files/fsleyes-0.32.0-coverage.patch,
|
||||||
|
+files/fsleyes-0.32.0-tests_fail.patch,
|
||||||
|
+files/fsleyes-0.32.0-tests_timeout.patch, +fsleyes-0.32.0.ebuild,
|
||||||
|
-fsleyes-0.26.2.ebuild, -fsleyes-0.27.3.ebuild, metadata.xml:
|
||||||
|
sci-visualization/fsleyes: new package
|
||||||
|
|
||||||
15 Apr 2019; <chymera@gentoo.org> fsleyes-0.27.3.ebuild:
|
15 Apr 2019; <chymera@gentoo.org> fsleyes-0.27.3.ebuild:
|
||||||
sci-visualization/fsleyes:
|
sci-visualization/fsleyes:
|
||||||
|
@ -1,2 +1 @@
|
|||||||
DIST fsleyes-0.26.2.tar.gz 82646638 SHA256 d702c8905eaadeb38ac5393a0207074c37639f7a74acc4b1f7e04a84bd17b9f6 SHA512 36bb376726f7cafd2b850686230077f1c4d65692c9d76259a3278e2e1e8bec3df86d0a2439262b56f9ab2d10519fddd89cbbfa5b2fd4c218820b10ecebae59d3 WHIRLPOOL 90737e94f1f7fa9d03f93d5946598a55eb6955170ef6b94e2d7cfb30deb0063daaf30cabf6db052ee9c8a78f5535c2cc003b437d4234d04957c6985d203dc2ad
|
DIST fsleyes-0.32.0.tar.gz 87700064 SHA256 5e728b265608df8cf1a18ddda8694446e44550b0072884a5bb2bf70cb6489862 SHA512 de501e0527c94faad77bffdc6e9262ae185e661bc1b2ca494d75e7f33d7532b7b786c0b776682a0fa08fc48708e3d090de5319b02d4f9b3c0abb75c7cf1e9d1a WHIRLPOOL 1446c04514dbaf07d86b61c231f56d12433d6f49b1dfafb971d444fca067a7bacd9d1593981b19fcb5f4d503ad736ff2f4a9588514a2851180af632108f3b301
|
||||||
DIST fsleyes-0.27.3.tar.gz 83243157 SHA256 df7d5c40097962333e182d25179f243920f7f44611a456146ed53b37ade8bdbe SHA512 7a109d656edfa4bd7b4d81867bfdf219169c7066f1bf9c700db092d8b82645b71f334fb790e2893bdc38ea51a3a19ee47fabb57371a01da65e685e886916051c WHIRLPOOL e9a333961a470eb2b4f9ff635d4b8d36dc2087df87f0d14ed5d6c53e0fbff8f9a3affa347e7345d15eb3aee711e3c2d7c7eb3805f6358ec0d7d937fa4db614df
|
|
||||||
|
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/setup.cfg b/setup.cfg
|
||||||
|
index fcb594a..dccad97 100644
|
||||||
|
--- a/setup.cfg
|
||||||
|
+++ b/setup.cfg
|
||||||
|
@@ -9,7 +9,7 @@ ignore = E127,E201,E203,E221,E222,E241,E271,E272,E301,E302,E303,E701,W504
|
||||||
|
|
||||||
|
[tool:pytest]
|
||||||
|
testpaths = tests
|
||||||
|
-addopts = -v --cov=fsleyes
|
||||||
|
+addopts = -v
|
||||||
|
markers =
|
||||||
|
overlayclitest: Overlay scene test invoked via FSLeyes command line
|
||||||
|
clitest: Test invoked via FSLeyes command line
|
@ -0,0 +1,62 @@
|
|||||||
|
diff --git a/tests/actions/test_copyoverlay.py b/tests/actions/test_copyoverlay.py
|
||||||
|
index 3509ba6..371813e 100644
|
||||||
|
--- a/tests/actions/test_copyoverlay.py
|
||||||
|
+++ b/tests/actions/test_copyoverlay.py
|
||||||
|
@@ -19,7 +19,11 @@ import fsleyes.actions.copyoverlay as copyoverlay
|
||||||
|
|
||||||
|
from .. import run_with_orthopanel, realYield
|
||||||
|
|
||||||
|
+import pytest
|
||||||
|
|
||||||
|
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
||||||
|
+ "https://github.com/pauldmccarthy/fsleyes/issues/38"
|
||||||
|
+ )
|
||||||
|
def test_copyImage_3d():
|
||||||
|
run_with_orthopanel(_test_copyImage_3d)
|
||||||
|
def _test_copyImage_3d(panel, overlayList, displayCtx):
|
||||||
|
@@ -103,7 +107,9 @@ def _test_copyImage_3d(panel, overlayList, displayCtx):
|
||||||
|
assert np.all(copy[5:25, 5:25, 5:25] == img3d[:, :, :])
|
||||||
|
overlayList.remove(copy)
|
||||||
|
|
||||||
|
-
|
||||||
|
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
||||||
|
+ "https://github.com/pauldmccarthy/fsleyes/issues/38"
|
||||||
|
+ )
|
||||||
|
def test_copyImage_4d():
|
||||||
|
run_with_orthopanel(_test_copyImage_4d)
|
||||||
|
def _test_copyImage_4d(panel, overlayList, displayCtx):
|
||||||
|
@@ -220,6 +226,9 @@ def make_rgb():
|
||||||
|
return fslimage.Image(rgb, xform=np.eye(4))
|
||||||
|
|
||||||
|
|
||||||
|
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
||||||
|
+ "https://github.com/pauldmccarthy/fsleyes/issues/38"
|
||||||
|
+ )
|
||||||
|
def test_copyImage_multiValued():
|
||||||
|
run_with_orthopanel(_test_copyImage_multiValued)
|
||||||
|
def _test_copyImage_multiValued(panel, overlayList, displayCtx):
|
||||||
|
@@ -281,6 +290,9 @@ def _test_copyImage_multiValued(panel, overlayList, displayCtx):
|
||||||
|
overlayList.remove(copy)
|
||||||
|
|
||||||
|
|
||||||
|
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
||||||
|
+ "https://github.com/pauldmccarthy/fsleyes/issues/38"
|
||||||
|
+ )
|
||||||
|
def test_CopyOverlayAction():
|
||||||
|
run_with_orthopanel(_test_CopyOverlayAction)
|
||||||
|
def _test_CopyOverlayAction(panel, overlayList, displayCtx):
|
||||||
|
diff --git a/tests/actions/test_newimage.py b/tests/actions/test_newimage.py
|
||||||
|
index cfd6b5a..e9c2ff8 100644
|
||||||
|
--- a/tests/actions/test_newimage.py
|
||||||
|
+++ b/tests/actions/test_newimage.py
|
||||||
|
@@ -82,6 +82,9 @@ def test_newImage():
|
||||||
|
assert img.name == 'whaa'
|
||||||
|
|
||||||
|
|
||||||
|
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
||||||
|
+ "https://github.com/pauldmccarthy/fsleyes/issues/38"
|
||||||
|
+ )
|
||||||
|
def test_NewImageAction():
|
||||||
|
run_with_orthopanel(_test_NewImageAction)
|
||||||
|
|
||||||
|
|
@ -0,0 +1,61 @@
|
|||||||
|
diff --git a/tests/actions/test_newimage.py b/tests/actions/test_newimage.py
|
||||||
|
index a7d159e4..7bc76fb0 100644
|
||||||
|
--- a/tests/actions/test_newimage.py
|
||||||
|
+++ b/tests/actions/test_newimage.py
|
||||||
|
@@ -16,6 +16,7 @@ import fsl.transform.affine as fslaffine
|
||||||
|
import fsleyes.actions.newimage as newimage
|
||||||
|
from .. import run_with_fsleyes, run_with_orthopanel, realYield
|
||||||
|
|
||||||
|
+import pytest
|
||||||
|
|
||||||
|
class MockNewImageDialog(object):
|
||||||
|
initOverride = False
|
||||||
|
@@ -121,7 +122,9 @@ def _test_NewImageAction(panel, overlayList, displayCtx):
|
||||||
|
overlayList.clear()
|
||||||
|
realYield()
|
||||||
|
|
||||||
|
-
|
||||||
|
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
||||||
|
+ "https://github.com/pauldmccarthy/fsleyes/issues/38"
|
||||||
|
+ )
|
||||||
|
def test_NewImageAction_existing():
|
||||||
|
run_with_orthopanel(_test_NewImageAction_existing)
|
||||||
|
|
||||||
|
@@ -156,7 +156,9 @@ def _test_NewImageAction_existing(panel, overlayList, displayCtx):
|
||||||
|
assert old.sameSpace(new)
|
||||||
|
assert new.dtype == np.int32
|
||||||
|
|
||||||
|
-
|
||||||
|
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
||||||
|
+ "https://github.com/pauldmccarthy/fsleyes/issues/38"
|
||||||
|
+ )
|
||||||
|
def test_NewImageDialog():
|
||||||
|
run_with_fsleyes(_test_NewImageDialog)
|
||||||
|
|
||||||
|
diff --git a/tests/actions/test_resample.py b/tests/actions/test_resample.py
|
||||||
|
index e883002c..ae1741cc 100644
|
||||||
|
--- a/tests/actions/test_resample.py
|
||||||
|
+++ b/tests/actions/test_resample.py
|
||||||
|
@@ -25,7 +25,11 @@ from .. import (run_with_fsleyes,
|
||||||
|
simtext,
|
||||||
|
simclick)
|
||||||
|
|
||||||
|
+import pytest
|
||||||
|
|
||||||
|
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
||||||
|
+ "https://github.com/pauldmccarthy/fsleyes/issues/38"
|
||||||
|
+ )
|
||||||
|
def test_resample():
|
||||||
|
run_with_orthopanel(_test_resample)
|
||||||
|
|
||||||
|
@@ -132,6 +136,9 @@ def _test_resample(panel, overlayList, displayCtx):
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
+@pytest.mark.skip(reason="Known to fail on Gentoo:"
|
||||||
|
+ "https://github.com/pauldmccarthy/fsleyes/issues/38"
|
||||||
|
+ )
|
||||||
|
def test_ResampleDialog():
|
||||||
|
run_with_fsleyes(_test_ResampleDialog)
|
||||||
|
|
||||||
|
|
@ -1,87 +0,0 @@
|
|||||||
# Copyright 1999-2018 Gentoo Foundation
|
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
|
||||||
|
|
||||||
EAPI=6
|
|
||||||
|
|
||||||
PYTHON_COMPAT=( python{2_7,3_5,3_6} )
|
|
||||||
|
|
||||||
inherit distutils-r1 gnome2-utils virtualx
|
|
||||||
|
|
||||||
MY_HASH="bfc2c0919b68583b6237cbdd9492e69a7bed30189b19dd21f7ba59f9f39e"
|
|
||||||
|
|
||||||
DESCRIPTION="The new FSL image viewer, released with FSL 5.0.10"
|
|
||||||
HOMEPAGE="https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/tree/master"
|
|
||||||
SRC_URI="
|
|
||||||
https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/-/archive/${PV}/${P}.tar.gz
|
|
||||||
https://github.com/pauldmccarthy/fsleyes/archive/${PV}.tar.gz -> ${P}.tar.gz
|
|
||||||
"
|
|
||||||
|
|
||||||
LICENSE="Apache-2.0"
|
|
||||||
SLOT="0"
|
|
||||||
KEYWORDS="~amd64 ~x86"
|
|
||||||
IUSE="test"
|
|
||||||
|
|
||||||
DEPEND="
|
|
||||||
test? (
|
|
||||||
${RDEPEND}
|
|
||||||
dev-python/mock[${PYTHON_USEDEP}]
|
|
||||||
dev-python/pytest[${PYTHON_USEDEP}]
|
|
||||||
dev-python/pytest-cov[${PYTHON_USEDEP}]
|
|
||||||
)
|
|
||||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
|
||||||
"
|
|
||||||
|
|
||||||
RDEPEND="
|
|
||||||
dev-python/fslpy[${PYTHON_USEDEP}]
|
|
||||||
=dev-python/jinja-2*[${PYTHON_USEDEP}]
|
|
||||||
>=dev-python/matplotlib-1.5.1[${PYTHON_USEDEP}]
|
|
||||||
>=dev-python/numpy-1.14.0[${PYTHON_USEDEP}]
|
|
||||||
>=dev-python/pillow-3.4.2[${PYTHON_USEDEP}]
|
|
||||||
>=dev-python/pyopengl-3.1.0[${PYTHON_USEDEP}]
|
|
||||||
>=dev-python/pyopengl_accelerate-3.1.0[${PYTHON_USEDEP}]
|
|
||||||
=dev-python/pyparsing-2*[${PYTHON_USEDEP}]
|
|
||||||
=dev-python/six-1*[${PYTHON_USEDEP}]
|
|
||||||
>=dev-python/wxpython-3.0.2.0[${PYTHON_USEDEP}]
|
|
||||||
>=sci-libs/scipy-0.18[${PYTHON_USEDEP}]
|
|
||||||
=sci-libs/nibabel-2*[${PYTHON_USEDEP}]
|
|
||||||
sci-visualization/fsleyes-widgets[${PYTHON_USEDEP}]
|
|
||||||
sci-visualization/fsleyes-props[${PYTHON_USEDEP}]
|
|
||||||
"
|
|
||||||
|
|
||||||
PATCHES=(
|
|
||||||
"${FILESDIR}/${PN}-0.26.2-fsldir.patch"
|
|
||||||
)
|
|
||||||
|
|
||||||
src_prepare() {
|
|
||||||
sed -i -e "s/Pillow>=3.2.0,<5.0/Pillow>=3.2.0/g" requirements.txt
|
|
||||||
distutils-r1_src_prepare
|
|
||||||
}
|
|
||||||
|
|
||||||
python_install_all() {
|
|
||||||
distutils-r1_python_install_all
|
|
||||||
doicon userdoc/images/fsleyes_icon.png
|
|
||||||
local size
|
|
||||||
for size in 16 32 128 256 512 ; do
|
|
||||||
doicon -s ${size} assets/icons/app_icon/${PN}.iconset/icon_${size}x${size}.png
|
|
||||||
done
|
|
||||||
make_desktop_entry fsleyes FSLeyes /usr/share/icons/hicolor/128x128/apps/icon_128x128.png
|
|
||||||
}
|
|
||||||
|
|
||||||
pkg_postinst() {
|
|
||||||
gnome2_icon_cache_update
|
|
||||||
}
|
|
||||||
pkg_postrm() {
|
|
||||||
gnome2_icon_cache_update
|
|
||||||
}
|
|
||||||
|
|
||||||
python_test() {
|
|
||||||
rm tests/test_addmaskdataseries.py
|
|
||||||
rm tests/test_embed.py
|
|
||||||
rm tests/test_overlay_displayprops.py
|
|
||||||
rm tests/test_overlay_freesurfermesh.py
|
|
||||||
rm tests/test_overlay_giftimesh.py
|
|
||||||
rm tests/test_screenshot.py
|
|
||||||
rm tests/test_state.py
|
|
||||||
rm tests/test_views.py
|
|
||||||
virtx pytest -v || die
|
|
||||||
}
|
|
@ -1,13 +1,11 @@
|
|||||||
# Copyright 1999-2019 Gentoo Authors
|
# Copyright 1999-2020 Gentoo Authors
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
EAPI=6
|
EAPI=7
|
||||||
|
|
||||||
PYTHON_COMPAT=( python{2_7,3_5,3_6} )
|
PYTHON_COMPAT=( python3_6 )
|
||||||
|
|
||||||
inherit distutils-r1 gnome2-utils virtualx
|
inherit distutils-r1 desktop virtualx
|
||||||
|
|
||||||
MY_HASH="bfc2c0919b68583b6237cbdd9492e69a7bed30189b19dd21f7ba59f9f39e"
|
|
||||||
|
|
||||||
DESCRIPTION="The new FSL image viewer, released with FSL 5.0.10"
|
DESCRIPTION="The new FSL image viewer, released with FSL 5.0.10"
|
||||||
HOMEPAGE="https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/tree/master"
|
HOMEPAGE="https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/tree/master"
|
||||||
@ -26,7 +24,6 @@ DEPEND="
|
|||||||
${RDEPEND}
|
${RDEPEND}
|
||||||
dev-python/mock[${PYTHON_USEDEP}]
|
dev-python/mock[${PYTHON_USEDEP}]
|
||||||
dev-python/pytest[${PYTHON_USEDEP}]
|
dev-python/pytest[${PYTHON_USEDEP}]
|
||||||
dev-python/pytest-cov[${PYTHON_USEDEP}]
|
|
||||||
)
|
)
|
||||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
dev-python/setuptools[${PYTHON_USEDEP}]
|
||||||
"
|
"
|
||||||
@ -48,12 +45,11 @@ RDEPEND="
|
|||||||
sci-visualization/fsleyes-props[${PYTHON_USEDEP}]
|
sci-visualization/fsleyes-props[${PYTHON_USEDEP}]
|
||||||
"
|
"
|
||||||
|
|
||||||
# Tests fail
|
|
||||||
# https://github.com/pauldmccarthy/fsleyes/issues/14#issuecomment-477191925
|
|
||||||
#RESTRICT="test"
|
|
||||||
|
|
||||||
PATCHES=(
|
PATCHES=(
|
||||||
"${FILESDIR}/${PN}-0.26.2-fsldir.patch"
|
"${FILESDIR}/${PN}-0.26.2-fsldir.patch"
|
||||||
|
"${FILESDIR}/${PN}-0.32.0-coverage.patch"
|
||||||
|
"${FILESDIR}/${PN}-0.32.0-tests_timeout.patch"
|
||||||
|
"${FILESDIR}/${PN}-0.32.0-tests_fail.patch"
|
||||||
)
|
)
|
||||||
|
|
||||||
src_prepare() {
|
src_prepare() {
|
||||||
@ -79,9 +75,5 @@ pkg_postrm() {
|
|||||||
}
|
}
|
||||||
|
|
||||||
python_test() {
|
python_test() {
|
||||||
rm tests/test_addmaskdataseries.py
|
|
||||||
rm tests/test_embed.py
|
|
||||||
rm tests/test_overlay_displayprops.py
|
|
||||||
rm tests/test_resample.py
|
|
||||||
virtx pytest -vv || die
|
virtx pytest -vv || die
|
||||||
}
|
}
|
@ -2,7 +2,7 @@
|
|||||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||||
<pkgmetadata>
|
<pkgmetadata>
|
||||||
<maintainer type="person">
|
<maintainer type="person">
|
||||||
<email>horea.christ@gmail.com</email>
|
<email>chr@chymera.eu</email>
|
||||||
<name>Horea Christian</name>
|
<name>Horea Christian</name>
|
||||||
</maintainer>
|
</maintainer>
|
||||||
<maintainer type="project">
|
<maintainer type="project">
|
||||||
|
Loading…
Reference in New Issue
Block a user