dev-python/pycryptodomex: moved to Gentoo Science
https://gitweb.gentoo.org/proj/sci.git/commit/?id=2acb2e9a2b53726945e74c0e64f082291217230f
This commit is contained in:
parent
c0ed1ed368
commit
651872cdfb
@ -1,2 +0,0 @@
|
|||||||
DIST pycryptodomex-3.10.4.tar.gz 3797210 SHA256 acd3498a8ccf8ad20ce7daa5f7f5e6521465eeceb026f28a6adb0228dd9fcc6e SHA512 38a24f8a51c6b3d03e6fc7226921956bfaea4d8839a1e308de417d76931eedc969d913b62d7001bf2116ab613c31e6802194127af25cee2ff83971f871a62111 WHIRLPOOL 60786c71df0a9ca92ebb7a7633676bc6aaf19ebdb69f68a99058252e715462067f53b12cb83277d82d16e3ab4b49c594061e2e0c73a1bddd976b1f51877b626a
|
|
||||||
DIST pycryptodomex-3.14.1.tar.gz 3372625 SHA256 2ce76ed0081fd6ac8c74edc75b9d14eca2064173af79843c24fa62573263c1f2 SHA512 cd01431b9178bcb27332741097cf020859c48df83219bac9d6ffa1f52db1f112b562478260baa1aed4674e2833d6e0cd5794a43dafb09fda007fdce7a7330495 WHIRLPOOL 678b958ceb09528c8400f4ff65ba526a9b86cb7465e6eab4db0815f5f8b080931f7ef3254efb162ef65d36d82bfa56a313be8294516670b4559a6724ab79c227
|
|
@ -1,50 +0,0 @@
|
|||||||
diff -dupr a/setup.py b/setup.py
|
|
||||||
--- a/setup.py 2021-02-09 13:49:46.356455141 +0100
|
|
||||||
+++ b/setup.py 2021-02-09 13:50:49.351076275 +0100
|
|
||||||
@@ -367,13 +367,15 @@ ext_modules = [
|
|
||||||
sources=["src/CAST.c"],
|
|
||||||
py_limited_api=True),
|
|
||||||
Extension("Crypto.Cipher._raw_des",
|
|
||||||
- include_dirs=['src/', 'src/libtom/'],
|
|
||||||
+ include_dirs=['src/'],
|
|
||||||
sources=["src/DES.c"],
|
|
||||||
- py_limited_api=True),
|
|
||||||
+ py_limited_api=True,
|
|
||||||
+ extra_link_args=["-ltomcrypt"]),
|
|
||||||
Extension("Crypto.Cipher._raw_des3",
|
|
||||||
- include_dirs=['src/', 'src/libtom/'],
|
|
||||||
+ include_dirs=['src/'],
|
|
||||||
sources=["src/DES3.c"],
|
|
||||||
- py_limited_api=True),
|
|
||||||
+ py_limited_api=True,
|
|
||||||
+ extra_link_args=["-ltomcrypt"]),
|
|
||||||
Extension("Crypto.Util._cpuid_c",
|
|
||||||
include_dirs=['src/'],
|
|
||||||
sources=['src/cpuid.c'],
|
|
||||||
@@ -410,9 +412,10 @@ ext_modules = [
|
|
||||||
sources=["src/ARC4.c"],
|
|
||||||
py_limited_api=True),
|
|
||||||
Extension("Crypto.Cipher._Salsa20",
|
|
||||||
- include_dirs=['src/', 'src/libtom/'],
|
|
||||||
+ include_dirs=['src/'],
|
|
||||||
sources=["src/Salsa20.c"],
|
|
||||||
- py_limited_api=True),
|
|
||||||
+ py_limited_api=True,
|
|
||||||
+ extra_link_args=["-ltomcrypt"]),
|
|
||||||
Extension("Crypto.Cipher._chacha20",
|
|
||||||
include_dirs=['src/'],
|
|
||||||
sources=["src/chacha20.c"],
|
|
||||||
Only in b: setup.py.orig
|
|
||||||
Only in b: setup.py.rej
|
|
||||||
diff -dupr a/src/DES.c b/src/DES.c
|
|
||||||
--- a/src/DES.c 2021-02-09 13:49:46.336454729 +0100
|
|
||||||
+++ b/src/DES.c 2021-02-09 13:50:02.640123617 +0100
|
|
||||||
@@ -39,7 +39,7 @@ FAKE_INIT(raw_des3)
|
|
||||||
|
|
||||||
/* Include the actial DES implementation */
|
|
||||||
#define LTC_NO_PROTOTYPES
|
|
||||||
-#include "libtom/tomcrypt_des.c"
|
|
||||||
+#include <tomcrypt.h>
|
|
||||||
|
|
||||||
struct block_state {
|
|
||||||
symmetric_key sk;
|
|
@ -1,21 +0,0 @@
|
|||||||
<?xml version='1.0' encoding='UTF-8'?>
|
|
||||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
|
||||||
<pkgmetadata>
|
|
||||||
<maintainer type="person">
|
|
||||||
<email>gentoo@chymera.eu</email>
|
|
||||||
<name>Horea Christian</name>
|
|
||||||
</maintainer>
|
|
||||||
<maintainer type="project">
|
|
||||||
<email>sci@gentoo.org</email>
|
|
||||||
<name>Gentoo Science Project</name>
|
|
||||||
</maintainer>
|
|
||||||
<longdescription lang="en">
|
|
||||||
Equivalent package to dev-python/cryptodome which installs
|
|
||||||
modules under the Cryptodome package, so that PyCrypto and
|
|
||||||
PyCryptodome can coexist.
|
|
||||||
</longdescription>
|
|
||||||
<upstream>
|
|
||||||
<remote-id type="github">Legrandin/pycryptodome</remote-id>
|
|
||||||
<remote-id type="pypi">pycryptodomex</remote-id>
|
|
||||||
</upstream>
|
|
||||||
</pkgmetadata>
|
|
@ -1,43 +0,0 @@
|
|||||||
# Copyright 1999-2022 Gentoo Authors
|
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
|
||||||
|
|
||||||
EAPI=8
|
|
||||||
|
|
||||||
DISTUTILS_USE_PEP517=setuptools
|
|
||||||
PYTHON_COMPAT=( python3_{8..10} pypy3)
|
|
||||||
PYTHON_REQ_USE="threads(+)"
|
|
||||||
|
|
||||||
inherit distutils-r1
|
|
||||||
|
|
||||||
DESCRIPTION="Cryptographic library for Python"
|
|
||||||
HOMEPAGE="https://www.pycryptodome.org https://pypi.org/project/pycryptodomex/"
|
|
||||||
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
|
|
||||||
|
|
||||||
LICENSE="BSD-2 Unlicense"
|
|
||||||
SLOT="0"
|
|
||||||
KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
|
|
||||||
IUSE="test"
|
|
||||||
RESTRICT="!test? ( test )"
|
|
||||||
|
|
||||||
DEPEND="
|
|
||||||
dev-libs/gmp:0=
|
|
||||||
>=dev-libs/libtomcrypt-1.18.2-r1:=
|
|
||||||
"
|
|
||||||
BDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
|
|
||||||
RDEPEND="
|
|
||||||
${DEPEND}
|
|
||||||
${BDEPEND}
|
|
||||||
"
|
|
||||||
|
|
||||||
PATCHES=(
|
|
||||||
"${FILESDIR}/pycryptodome-3.10.1-system-libtomcrypt.patch"
|
|
||||||
)
|
|
||||||
|
|
||||||
distutils_enable_tests setup.py
|
|
||||||
|
|
||||||
python_prepare_all() {
|
|
||||||
# make sure we're unbundling it correctly
|
|
||||||
rm -r src/libtom || die
|
|
||||||
|
|
||||||
distutils-r1_python_prepare_all
|
|
||||||
}
|
|
@ -1,43 +0,0 @@
|
|||||||
# Copyright 1999-2022 Gentoo Authors
|
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
|
||||||
|
|
||||||
EAPI=8
|
|
||||||
|
|
||||||
DISTUTILS_USE_PEP517=setuptools
|
|
||||||
PYTHON_COMPAT=( python3_{8..10} pypy3)
|
|
||||||
PYTHON_REQ_USE="threads(+)"
|
|
||||||
|
|
||||||
inherit distutils-r1
|
|
||||||
|
|
||||||
DESCRIPTION="Cryptographic library for Python"
|
|
||||||
HOMEPAGE="https://www.pycryptodome.org https://pypi.org/project/pycryptodomex/"
|
|
||||||
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
|
|
||||||
|
|
||||||
LICENSE="BSD-2 Unlicense"
|
|
||||||
SLOT="0"
|
|
||||||
KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
|
|
||||||
IUSE="test"
|
|
||||||
RESTRICT="!test? ( test )"
|
|
||||||
|
|
||||||
DEPEND="
|
|
||||||
dev-libs/gmp:0=
|
|
||||||
>=dev-libs/libtomcrypt-1.18.2-r1:=
|
|
||||||
"
|
|
||||||
BDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
|
|
||||||
RDEPEND="
|
|
||||||
${DEPEND}
|
|
||||||
${BDEPEND}
|
|
||||||
"
|
|
||||||
|
|
||||||
PATCHES=(
|
|
||||||
"${FILESDIR}/pycryptodome-3.10.1-system-libtomcrypt.patch"
|
|
||||||
)
|
|
||||||
|
|
||||||
distutils_enable_tests setup.py
|
|
||||||
|
|
||||||
python_prepare_all() {
|
|
||||||
# make sure we're unbundling it correctly
|
|
||||||
rm -r src/libtom || die
|
|
||||||
|
|
||||||
distutils-r1_python_prepare_all
|
|
||||||
}
|
|
Loading…
x
Reference in New Issue
Block a user