Merge branch 'master' of github.com:TheChymera/overlay
This commit is contained in:
commit
60790e5987
7
dev-python/ci_info/ChangeLog
Normal file
7
dev-python/ci_info/ChangeLog
Normal file
@ -0,0 +1,7 @@
|
||||
06 Oct 2021; <chymera@gentoo.org> ci_info-0.2.0.ebuild:
|
||||
dev-python/ci_info: tests broken as per upstream
|
||||
|
||||
*ci_info-0.2.0 (06 Oct 2021)
|
||||
|
||||
06 Oct 2021; <chymera@gentoo.org> +ci_info-0.2.0.ebuild, +metadata.xml:
|
||||
dev-python/ci_info: new package (DANDI stack)
|
1
dev-python/ci_info/Manifest
Normal file
1
dev-python/ci_info/Manifest
Normal file
@ -0,0 +1 @@
|
||||
DIST ci_info-0.2.0.tar.gz 26001 SHA256 fa4e0bb63514dfee49fb4709fd84d29b12836f6d0c9506982a4b6f2219fa3232 SHA512 cedb489874f663b169330444632d6574b84ce95e9a4221ca41f76e56582ea7f4d8dd5ffb2130b74c2847d9c69866822ebf24eb7b87e6a3a4a276f1029dcac202 WHIRLPOOL fb12e3ac63f36c8d16da11bb90b3c262d1c1fc9045593db279ab13ea194528224e231b7f917cb2c2facea52b104048f29115fda9ad4188a1ed729a7ab98bc40b
|
29
dev-python/ci_info/ci_info-0.2.0.ebuild
Normal file
29
dev-python/ci_info/ci_info-0.2.0.ebuild
Normal file
@ -0,0 +1,29 @@
|
||||
# Copyright 2021 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
PYTHON_COMPAT=( python3_{8..10} )
|
||||
inherit distutils-r1
|
||||
|
||||
MY_PN=ci-info
|
||||
|
||||
DESCRIPTION="Gather continuous integration information on the fly"
|
||||
HOMEPAGE="https://github.com/mgxd/ci-info"
|
||||
SRC_URI="https://github.com/mgxd/ci-info/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="MIT"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test"
|
||||
# Tests broken without specific CI environment:
|
||||
# https://github.com/mgxd/ci-info/issues/7
|
||||
RESTRICT="test"
|
||||
|
||||
DEPEND=""
|
||||
RDEPEND=""
|
||||
BDEPEND=""
|
||||
|
||||
S="${WORKDIR}/${MY_PN}-${PV}"
|
||||
|
||||
distutils_enable_tests pytest
|
15
dev-python/ci_info/metadata.xml
Normal file
15
dev-python/ci_info/metadata.xml
Normal file
@ -0,0 +1,15 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<maintainer type="person">
|
||||
<email>gentoo@chymera.eu</email>
|
||||
<name>Horea Christian</name>
|
||||
</maintainer>
|
||||
<maintainer type="project">
|
||||
<email>sci@gentoo.org</email>
|
||||
<name>Gentoo Science Project</name>
|
||||
</maintainer>
|
||||
<upstream>
|
||||
<remote-id type="github">mgxd/ci-info</remote-id>
|
||||
</upstream>
|
||||
</pkgmetadata>
|
4
dev-python/etelemetry/ChangeLog
Normal file
4
dev-python/etelemetry/ChangeLog
Normal file
@ -0,0 +1,4 @@
|
||||
*etelemetry-0.2.2 (06 Oct 2021)
|
||||
|
||||
06 Oct 2021; <chymera@gentoo.org> +etelemetry-0.2.2.ebuild, +metadata.xml:
|
||||
dev-python/etelemetry: new package (DANDI stack)
|
1
dev-python/etelemetry/Manifest
Normal file
1
dev-python/etelemetry/Manifest
Normal file
@ -0,0 +1 @@
|
||||
DIST etelemetry-0.2.2.tar.gz 25890 SHA256 bfec416552d248ad0f50b90ba5ff015e825ad70e4a87f7a06cc7da6d19152897 SHA512 478d6a529c4363a699bc3c3ff84e02c168fab3ba8e2397c6babf07afb7565fb34b8dcdca6d7dc7878085e6ec96acb82e96c9bf2dd5ef5b7b5ebf05e1cdb70549 WHIRLPOOL 6c3f9a00203f096d13fc205a275c53cc41e0f61bd0a922564d9c7d6373af4e00a452240a5b8307bace8af652cedbffc8b2c4ee0189e70cd83630839da46d21a5
|
31
dev-python/etelemetry/etelemetry-0.2.2.ebuild
Normal file
31
dev-python/etelemetry/etelemetry-0.2.2.ebuild
Normal file
@ -0,0 +1,31 @@
|
||||
# Copyright 2021 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
PYTHON_COMPAT=( python3_{8..10} )
|
||||
inherit distutils-r1
|
||||
|
||||
MY_PN=etelemetry-client
|
||||
|
||||
DESCRIPTION="Lightweight python client to communicate with the etelemetry server"
|
||||
HOMEPAGE="https://github.com/sensein/etelemetry-client"
|
||||
SRC_URI="https://github.com/sensein/etelemetry-client/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test"
|
||||
RESTRICT="!test? ( test )"
|
||||
|
||||
DEPEND="
|
||||
dev-python/versioneer[${PYTHON_USEDEP}]
|
||||
"
|
||||
RDEPEND="
|
||||
dev-python/requests[${PYTHON_USEDEP}]
|
||||
"
|
||||
BDEPEND=""
|
||||
|
||||
S="${WORKDIR}/${MY_PN}-${PV}"
|
||||
|
||||
distutils_enable_tests pytest
|
15
dev-python/etelemetry/metadata.xml
Normal file
15
dev-python/etelemetry/metadata.xml
Normal file
@ -0,0 +1,15 @@
|
||||
<?xml version='1.0' encoding='UTF-8'?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<maintainer type="person">
|
||||
<email>gentoo@chymera.eu</email>
|
||||
<name>Horea Christian</name>
|
||||
</maintainer>
|
||||
<maintainer type="project">
|
||||
<email>sci@gentoo.org</email>
|
||||
<name>Gentoo Science Project</name>
|
||||
</maintainer>
|
||||
<upstream>
|
||||
<remote-id type="github">sensein/etelemetry-client</remote-id>
|
||||
</upstream>
|
||||
</pkgmetadata>
|
@ -1,5 +1,4 @@
|
||||
*pycryptodomex-3.10.4 (27 Sep 2021)
|
||||
*pycryptodomex-3.10.1 (06 Oct 2021)
|
||||
|
||||
27 Sep 2021; <chymera@gentoo.org> +metadata.xml,
|
||||
+pycryptodomex-3.10.4.ebuild:
|
||||
dev-python/pycryptodomex: new package (DANDI stack)
|
||||
06 Oct 2021; <chymera@gentoo.org> +pycryptodomex-3.10.1.ebuild, -ChangeLog:
|
||||
dev-python/pycryptodomex: tests fail
|
||||
|
@ -1 +1,2 @@
|
||||
DIST pycryptodomex-3.10.1.tar.gz 3787268 SHA256 541cd3e3e252fb19a7b48f420b798b53483302b7fe4d9954c947605d0a263d62 SHA512 0ffd37e75caf6472529bbc231c7e74290267094eb3a6013a55d32dc6e11313017bb8161bdfef6c96e911e788b837caa445a9e1fe3e17e5e0254c139378f2a5e6 WHIRLPOOL e07f6da41f17da89d59d4656aa1c40fe039f6bbb14fb7dde9cfdb0d86c639005f7e87f747c937c3ad4e941b39634c0399ebb905aca05625fc60d4ca5efd7797b
|
||||
DIST pycryptodomex-3.10.4.tar.gz 3797210 SHA256 acd3498a8ccf8ad20ce7daa5f7f5e6521465eeceb026f28a6adb0228dd9fcc6e SHA512 38a24f8a51c6b3d03e6fc7226921956bfaea4d8839a1e308de417d76931eedc969d913b62d7001bf2116ab613c31e6802194127af25cee2ff83971f871a62111 WHIRLPOOL 60786c71df0a9ca92ebb7a7633676bc6aaf19ebdb69f68a99058252e715462067f53b12cb83277d82d16e3ab4b49c594061e2e0c73a1bddd976b1f51877b626a
|
||||
|
34
dev-python/pycryptodomex/pycryptodomex-3.10.1.ebuild
Normal file
34
dev-python/pycryptodomex/pycryptodomex-3.10.1.ebuild
Normal file
@ -0,0 +1,34 @@
|
||||
# Copyright 1999-2021 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
PYTHON_COMPAT=( python3_{8..10} )
|
||||
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="Cryptographic library for Python"
|
||||
HOMEPAGE="https://www.pycryptodome.org https://pypi.org/project/pycryptodomex/"
|
||||
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
|
||||
|
||||
LICENSE="BSD"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
|
||||
IUSE="test"
|
||||
RESTRICT="test"
|
||||
# Numerous tests fail, reported upstream https://github.com/Legrandin/pycryptodome/issues/549
|
||||
|
||||
DOCS="README.rst"
|
||||
|
||||
RDEPEND=""
|
||||
BDEPEND="
|
||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
||||
test? (
|
||||
dev-python/nose[${PYTHON_USEDEP}]
|
||||
dev-python/pytest[${PYTHON_USEDEP}]
|
||||
)"
|
||||
|
||||
python_test() {
|
||||
nosetests --verbose || die
|
||||
py.test -v -v || die
|
||||
}
|
@ -1,7 +1,8 @@
|
||||
02 Oct 2021; <chymera@gentoo.org> dandi-cli-0.27.2.ebuild:
|
||||
dev-vcs/dandi-cli: let tests break for testing purposes
|
||||
*dandi-cli-0.28.0 (06 Oct 2021)
|
||||
|
||||
*dandi-cli-0.27.2 (27 Sep 2021)
|
||||
|
||||
27 Sep 2021; <chymera@gentoo.org> +dandi-cli-0.27.2.ebuild, +metadata.xml:
|
||||
dev-vcs/dandi-cli: new package (DANDI stack) tests fail
|
||||
06 Oct 2021; <chymera@gentoo.org> +dandi-cli-0.28.0.ebuild,
|
||||
+files/dandi-cli-0.27.2-no-etelemetry.patch,
|
||||
+files/dandi-cli-0.27.2-pip-versioncheck.patch,
|
||||
+files/dandi-cli-0.28.0-pip-versioncheck.patch, -ChangeLog,
|
||||
dandi-cli-0.27.2.ebuild, metadata.xml:
|
||||
dev-vcs/dandi-cli: added etelemetry support
|
||||
|
@ -1 +1,2 @@
|
||||
DIST dandi-cli-0.27.2.tar.gz 172781 SHA256 179bbe77be65272932f6e1fc133b043eb94449847155fde3c45455c30b6cbdcc SHA512 00c522a1f5c922e6a38e257defbb02a03480156d61bcf80de3326131533a5cc332771ea05e2a995d7ace71b0ba551151d4ec3d3f4456197cb358133d3aa3fe89 WHIRLPOOL bf059cad4f8a9988a783d0001a68ebec8d480f3188f756af720aa5f0e32002e8301a3f98b2e0c492bb3be07f39959839e8b67c5544c0a3e18e757332a6bdb70c
|
||||
DIST dandi-cli-0.28.0.tar.gz 173403 SHA256 27b67c93a8625dd15db2e3513ae3448569ccade2dc82eb1f110de5b1c02b5ec3 SHA512 399ee378798a3c7fdc92314dca25e91178bb157145205e43a1d2ec461f36c674ed1b63b97f805ab9d25eb30d18d82827e38024b8a72c691c3992af60fc286be3 WHIRLPOOL 3381c9f7f0c7c5263bb2a8019205a44d0b6084fc9719034462ea7d66f0f23a617dfc3468676102f931444b4b43b788e8c7c65615ebae5f30c635d51badbaf92a
|
||||
|
@ -13,15 +13,15 @@ SRC_URI="https://github.com/dandi/dandi-cli/archive/refs/tags/${PV}.tar.gz -> ${
|
||||
LICENSE="Apache-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test"
|
||||
#RESTRICT="test"
|
||||
IUSE="test +etelemetry"
|
||||
RESTRICT="test"
|
||||
# Test fail during collection, reported upstream: https://github.com/dandi/dandi-cli/issues/774
|
||||
|
||||
RDEPEND="
|
||||
dev-python/appdirs[${PYTHON_USEDEP}]
|
||||
dev-python/click[${PYTHON_USEDEP}]
|
||||
dev-python/click-didyoumean[${PYTHON_USEDEP}]
|
||||
dev-python/dandischema[${PYTHON_USEDEP}]
|
||||
=dev-python/dandischema-0.3*[${PYTHON_USEDEP}]
|
||||
dev-python/fasteners[${PYTHON_USEDEP}]
|
||||
dev-python/fscacher[${PYTHON_USEDEP}]
|
||||
dev-python/humanize[${PYTHON_USEDEP}]
|
||||
@ -40,8 +40,6 @@ RDEPEND="
|
||||
dev-python/tqdm[${PYTHON_USEDEP}]
|
||||
dev-python/wheel[${PYTHON_USEDEP}]
|
||||
"
|
||||
# also needs:
|
||||
# etelemetry
|
||||
|
||||
DEPEND="
|
||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
||||
@ -55,6 +53,17 @@ DEPEND="
|
||||
|
||||
distutils_enable_tests pytest
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${P}-pip-versioncheck.patch"
|
||||
)
|
||||
|
||||
src_prepare() {
|
||||
if ! use etelemetry; then
|
||||
eapply "${FILESDIR}/${PN}-0.27.2-no-etelemetry.patch"
|
||||
fi
|
||||
default
|
||||
}
|
||||
|
||||
#python_install_all() {
|
||||
# distutils-r1_python_install_all
|
||||
# dodoc README.md
|
||||
|
70
dev-vcs/dandi-cli/dandi-cli-0.28.0.ebuild
Normal file
70
dev-vcs/dandi-cli/dandi-cli-0.28.0.ebuild
Normal file
@ -0,0 +1,70 @@
|
||||
# Copyright 1999-2021 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
PYTHON_COMPAT=( python3_{8..10} )
|
||||
inherit distutils-r1
|
||||
|
||||
DESCRIPTION="DANDI command line client to facilitate common operations"
|
||||
HOMEPAGE="https://github.com/dandi/dandi-cli"
|
||||
SRC_URI="https://github.com/dandi/dandi-cli/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="Apache-2.0"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="test +etelemetry"
|
||||
RESTRICT="test"
|
||||
# Test fail during collection, reported upstream: https://github.com/dandi/dandi-cli/issues/774
|
||||
|
||||
RDEPEND="
|
||||
dev-python/appdirs[${PYTHON_USEDEP}]
|
||||
dev-python/click[${PYTHON_USEDEP}]
|
||||
dev-python/click-didyoumean[${PYTHON_USEDEP}]
|
||||
=dev-python/dandischema-0.4*[${PYTHON_USEDEP}]
|
||||
dev-python/fasteners[${PYTHON_USEDEP}]
|
||||
dev-python/fscacher[${PYTHON_USEDEP}]
|
||||
dev-python/humanize[${PYTHON_USEDEP}]
|
||||
dev-python/joblib[${PYTHON_USEDEP}]
|
||||
dev-python/keyring[${PYTHON_USEDEP}]
|
||||
dev-python/keyrings_alt[${PYTHON_USEDEP}]
|
||||
dev-python/packaging[${PYTHON_USEDEP}]
|
||||
dev-python/pydantic[${PYTHON_USEDEP}]
|
||||
dev-python/pynwb[${PYTHON_USEDEP}]
|
||||
dev-python/pyout[${PYTHON_USEDEP}]
|
||||
dev-python/python-dateutil[${PYTHON_USEDEP}]
|
||||
dev-python/requests[${PYTHON_USEDEP}]
|
||||
dev-python/ruamel-yaml[${PYTHON_USEDEP}]
|
||||
dev-python/semantic_version[${PYTHON_USEDEP}]
|
||||
dev-python/tenacity[${PYTHON_USEDEP}]
|
||||
dev-python/tqdm[${PYTHON_USEDEP}]
|
||||
dev-python/wheel[${PYTHON_USEDEP}]
|
||||
"
|
||||
|
||||
DEPEND="
|
||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
||||
test? (
|
||||
dev-python/anys[${PYTHON_USEDEP}]
|
||||
dev-python/responses[${PYTHON_USEDEP}]
|
||||
dev-python/pyfakefs[${PYTHON_USEDEP}]
|
||||
dev-python/pytest-mock[${PYTHON_USEDEP}]
|
||||
)
|
||||
"
|
||||
|
||||
distutils_enable_tests pytest
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${P}-pip-versioncheck.patch"
|
||||
)
|
||||
|
||||
src_prepare() {
|
||||
if ! use etelemetry; then
|
||||
eapply "${FILESDIR}/${PN}-0.27.2-no-etelemetry.patch"
|
||||
fi
|
||||
default
|
||||
}
|
||||
|
||||
#python_install_all() {
|
||||
# distutils-r1_python_install_all
|
||||
# dodoc README.md
|
||||
#}
|
30
dev-vcs/dandi-cli/files/dandi-cli-0.27.2-no-etelemetry.patch
Normal file
30
dev-vcs/dandi-cli/files/dandi-cli-0.27.2-no-etelemetry.patch
Normal file
@ -0,0 +1,30 @@
|
||||
--- a/dandi/utils.py 2021-09-21 11:51:39.799524534 -0400
|
||||
+++ b/dandi/utils.py 2021-10-06 04:58:00.506440719 -0400
|
||||
@@ -734,27 +734,4 @@
|
||||
def check_dandi_version():
|
||||
if os.environ.get("DANDI_NO_ET"):
|
||||
return
|
||||
- try:
|
||||
- import etelemetry
|
||||
-
|
||||
- try:
|
||||
- etelemetry.check_available_version(
|
||||
- "dandi/dandi-cli", __version__, lgr=lgr, raise_exception=True
|
||||
- )
|
||||
- except etelemetry.client.BadVersionError:
|
||||
- # note: SystemExit is based of BaseException, so is not Exception
|
||||
- raise SystemExit(
|
||||
- "DANDI CLI has detected that you are using a version that is known to "
|
||||
- "contain bugs, is incompatible with our current data archive, or has "
|
||||
- "other significant performance limitations. "
|
||||
- "To continue using DANDI CLI, please upgrade your dandi client to a newer "
|
||||
- "version (e.g., using pip install --upgrade dandi if you installed using pip). "
|
||||
- "If you have any issues, please contact the DANDI "
|
||||
- "helpdesk at https://github.com/dandi/helpdesk/issues/new/choose ."
|
||||
- )
|
||||
- except Exception as exc:
|
||||
- lgr.warning(
|
||||
- "Failed to check for a more recent version available with etelemetry: %s",
|
||||
- exc,
|
||||
- )
|
||||
os.environ["DANDI_NO_ET"] = "1"
|
@ -0,0 +1,13 @@
|
||||
--- a/setup.cfg 2021-10-06 11:44:40.549337707 -0400
|
||||
+++ b/dsetup.cfg 2021-10-06 11:45:10.236935245 -0400
|
||||
@@ -30,8 +30,8 @@
|
||||
appdirs
|
||||
click
|
||||
click-didyoumean
|
||||
- dandischema ~= 0.3.1
|
||||
- etelemetry >= 0.2.2
|
||||
+ dandischema
|
||||
+ etelemetry
|
||||
fasteners
|
||||
fscacher
|
||||
# Specifying != might be what causes pip 19.3.1 first to install hdmf 1.5.1
|
@ -0,0 +1,13 @@
|
||||
--- a/setup.cfg 2021-10-06 11:44:40.549337707 -0400
|
||||
+++ b/dsetup.cfg 2021-10-06 11:45:10.236935245 -0400
|
||||
@@ -30,8 +30,8 @@
|
||||
appdirs
|
||||
click
|
||||
click-didyoumean
|
||||
- dandischema ~= 0.4.1
|
||||
- etelemetry >= 0.2.2
|
||||
+ dandischema
|
||||
+ etelemetry
|
||||
fasteners
|
||||
fscacher
|
||||
# Specifying != might be what causes pip 19.3.1 first to install hdmf 1.5.1
|
@ -16,4 +16,7 @@
|
||||
has a set of options to alter their behavior. Please run
|
||||
`dandi COMMAND --help` to get more information
|
||||
</longdescription>
|
||||
<use>
|
||||
<flag name="etelemetry">version checking to respect server schema version</flag>
|
||||
</use>
|
||||
</pkgmetadata>
|
||||
|
Loading…
x
Reference in New Issue
Block a user